<!DOCTYPE html><html prefix="og: http://ogp.me/ns#" lang="en">
<head>
    <meta charset="utf-8">
    <title>Watch Rimac Nevera Destroy Tesla Model S Plaid In Drag Races</title>

            <link href="https://fonts.googleapis.com/css?family=Open+Sans:300,400,600,700&display=swap" rel="stylesheet">
    
    <style>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</style>

    <link rel="icon" type="image/png" sizes="32x32" href="https://cdn.motor1.com/images/static/insideevs/favicon-32.png">
    <link rel="icon" type="image/png" sizes="96x96" href="https://cdn.motor1.com/images/static/insideevs/favicon-96.png">
    <link rel="icon" type="image/png" sizes="128x128" href="https://cdn.motor1.com/images/static/insideevs/favicon-128.png">
    <link rel="icon" type="image/png" sizes="195x195" href="https://cdn.motor1.com/images/static/insideevs/favicon-195.png">
    <link rel="icon" type="image/png" sizes="196x196" href="https://cdn.motor1.com/images/static/insideevs/favicon-196.png">
    <link rel="icon" type="image/png" sizes="228x228" href="https://cdn.motor1.com/images/static/insideevs/favicon-228.png">
    <link rel="apple-touch-icon-precomposed" href="https://cdn.motor1.com/images/static/insideevs/favicon-57.png">
    <link rel="apple-touch-icon" sizes="114x114" href="https://cdn.motor1.com/images/static/insideevs/favicon-114.png">
    <link rel="apple-touch-icon" sizes="72x72" href="https://cdn.motor1.com/images/static/insideevs/favicon-72.png">
    <link rel="apple-touch-icon" sizes="144x144" href="https://cdn.motor1.com/images/static/insideevs/favicon-144.png">
    <link rel="apple-touch-icon" sizes="60x60" href="https://cdn.motor1.com/images/static/insideevs/favicon-60.png">
    <link rel="apple-touch-icon" sizes="120x120" href="https://cdn.motor1.com/images/static/insideevs/favicon-120.png">
    <link rel="apple-touch-icon" sizes="76x76" href="https://cdn.motor1.com/images/static/insideevs/favicon-76.png">
    <link rel="apple-touch-icon" sizes="152x152" href="https://cdn.motor1.com/images/static/insideevs/favicon-152.png">
    <link rel="apple-touch-icon" sizes="180x180" href="https://cdn.motor1.com/images/static/insideevs/favicon-180.png">

    <meta name="msapplication-square128x128logo" content="https://cdn.motor1.com/images/static/insideevs/smalltile.png"/>
    <meta name="msapplication-square270x270logo" content="https://cdn.motor1.com/images/static/insideevs/mediumtile.png"/>
    <meta name="msapplication-square580x580logo" content="https://cdn.motor1.com/images/static/insideevs/largetile.png"/>

    
    <link rel="shortcut icon" type="image/x-icon" href="/favicon.ico"/>

    <script type="application/ld+json">
                    {"@context":"http:\/\/schema.org","@type":"NewsArticle","headline":"Watch Rimac Nevera Destroy Tesla Model S Plaid In Drag Races","description":"The two quickest production cars in the world, that happen to be electric - the Tesla Model S Plaid and Rimac Nevera - recently met at the drag strip.","author":{"@type":"Person","name":"Mark Kane"},"url":"https:\/\/insideevs.com\/news\/527462\/rimac-nevera-tesla-plaid-race\/","datePublished":"2021-08-18T17:13:12Z","dateModified":"2021-08-18T17:13:12Z","publisher":{"@type":"Organization","name":"InsideEVs","logo":{"@type":"ImageObject","url":"https:\/\/insideevs.com\/logo.jpg","width":"415","height":"60"}},"image":["https:\/\/cdn.motor1.com\/images\/mgl\/eEWLM\/s1\/1-914-hp-nevera-vs-plaid-source-dragtimes.webp","https:\/\/cdn.motor1.com\/images\/mgl\/eEWLM\/s1\/4x3\/1-914-hp-nevera-vs-plaid-source-dragtimes.webp","https:\/\/cdn.motor1.com\/images\/mgl\/eEWLM\/s1\/1x1\/1-914-hp-nevera-vs-plaid-source-dragtimes.webp"],"mainEntityOfPage":{"@type":"WebPage","url":"https:\/\/insideevs.com\/news\/527462\/rimac-nevera-tesla-plaid-race\/"},"wordCount":"734"}
                </script>
            <script type="application/ld+json">
                {"@context":"http:\/\/schema.org","@type":"VideoObject","contentURL":"https:\/\/insideevs.com\/news\/527462\/rimac-nevera-tesla-plaid-race\/","name":"Watch Rimac Nevera Destroy Tesla Model S Plaid In Drag Races","description":"The two quickest production cars in the world, that happen to be electric - the Tesla Model S Plaid and Rimac Nevera - recently met at the drag strip.","uploadDate":"2021-08-18T17:13:12Z","thumbnailUrl":"https:\/\/cdn.motor1.com\/images\/mgl\/eEWLM\/s3\/1-914-hp-nevera-vs-plaid-source-dragtimes.jpg"}
            </script>
        
                <script type="application/ld+json">
                    {"@context":"https:\/\/schema.org","@type":"BreadcrumbList","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https:\/\/insideevs.com\/"},{"@type":"ListItem","position":2,"name":"Tesla","item":"https:\/\/insideevs.com\/tesla\/"},{"@type":"ListItem","position":3,"name":"Model S","item":"https:\/\/insideevs.com\/tesla\/model-s\/"},{"@type":"ListItem","position":4,"name":"News","item":"https:\/\/insideevs.com\/tesla\/model-s\/news\/"}]}
                </script>
            
    
    

    

        <script>
        window.polymerLocale = 'en-US';
        window.polymerLocalePath = 'https://cdn.motor1.com/kp/static4ui/prod_v2_eks_251/polymer2/locales1628615898/en-US.json';
        var jsVars = {"services":{"brealtime":{"load":0,"id":"12851701"}},"ads":{"dfp":{"id":"6122441"}},"ui":{"auto_infinite_scroll":true}};    </script>

    
    <link title="Latest news" type="application/rss+xml" rel="alternate" href="/rss/news/all/"/>
    <link title="Latest videos" type="application/rss+xml" rel="alternate" href="/rss/videos/all/"/>
        <meta name="description" content="The two quickest production cars in the world, that happen to be electric - the Tesla Model S Plaid and Rimac Nevera - recently met at the drag strip.">
<meta property="og:title" content="Watch Rimac Nevera Destroy Tesla Model S Plaid In Drag Races">
<meta property="og:type" content="article">
<meta property="og:url" content="https://insideevs.com/news/527462/rimac-nevera-tesla-plaid-race/">
<meta property="og:image" content="https://cdn.motor1.com/images/mgl/eEWLM/s1/1-914-hp-nevera-vs-plaid-source-dragtimes.jpg">
<meta property="og:image:url" content="https://cdn.motor1.com/images/mgl/eEWLM/s1/1-914-hp-nevera-vs-plaid-source-dragtimes.jpg">
<meta property="og:image:secure_url" content="https://cdn.motor1.com/images/mgl/eEWLM/s1/1-914-hp-nevera-vs-plaid-source-dragtimes.jpg">
<meta property="og:image:type" content="image/jpeg">
<meta property="og:image:width" content="1920">
<meta property="og:image:height" content="1080">
<meta property="og:image:alt" content="Watch Rimac Nevera Destroy Tesla Model S Plaid In Drag Races:  Tesla Model S, Races and Chases">
<meta property="og:description" content="The two quickest production cars in the world, that happen to be electric - the Tesla Model S Plaid and Rimac Nevera - recently met at the drag strip.">
<meta property="og:site_name" content="InsideEVs">
<meta property="fb:admins" content="100001157785488">
<meta property="fb:app_id" content="984245018262500">
<meta property="fb:pages" content="357684877628739">
<meta property="twitter:card" content="summary_large_image">
<meta property="twitter:site" content="InsideEVs">
<meta property="twitter:title" content="Watch Rimac Nevera Destroy Tesla Model S Plaid In Drag Races">
<meta property="twitter:description" content="...as expected since the Nevera has almost two times the peak power output.">
<meta property="twitter:image" content="https://cdn.motor1.com/images/mgl/eEWLM/s3/1-914-hp-nevera-vs-plaid-source-dragtimes.jpg">
<meta property="robots" content="max-snippet:500, max-video-preview:10, max-image-preview:large">
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<meta http-equiv="X-UA-Compatible" content="IE=edge"><link href="https://insideevs.com/news/527462/rimac-nevera-tesla-plaid-race/" hreflang="x-default" rel="alternate">
<link href="https://insideevs.com/news/527462/rimac-nevera-tesla-plaid-race/" hreflang="en" rel="alternate">
<link href="https://insideevs.com/news/527462/rimac-nevera-tesla-plaid-race/" rel="canonical">
<link href="https://insideevs.com/news/527462/rimac-nevera-tesla-plaid-race/amp/" rel="amphtml">
    <script>
        let bundleRange = `                    <link rel="stylesheet" type="text/css" href="https://cdn.motor1.com/kp/static4ui/prod_v2_eks_251/design/dist/css/0_5b680bad3fdfed4fb8ac.css"><link rel="stylesheet" type="text/css" href="https://cdn.motor1.com/kp/static4ui/prod_v2_eks_251/design/dist/css/2_5b680bad3fdfed4fb8ac.css"><link rel="stylesheet" type="text/css" href="https://cdn.motor1.com/kp/static4ui/prod_v2_eks_251/design/dist/css/3_5b680bad3fdfed4fb8ac.css"><link rel="stylesheet" type="text/css" href="https://cdn.motor1.com/kp/static4ui/prod_v2_eks_251/design/dist/css/12_5b680bad3fdfed4fb8ac.css"><link rel="stylesheet" type="text/css" href="https://cdn.motor1.com/kp/static4ui/prod_v2_eks_251/design/dist/css/21_5b680bad3fdfed4fb8ac.css"><link rel="stylesheet" type="text/css" href="https://cdn.motor1.com/kp/static4ui/prod_v2_eks_251/design/dist/css/index_articles_detail_5b680bad3fdfed4fb8ac.css">                                                    <link rel="stylesheet" type="text/css" href="https://cdn.motor1.com/kp/static4ui/prod_v2_eks_251/ev-design/dist/css/0_074d5cc86ad1d0319b6c.css">                `;

        document.addEventListener('DOMContentLoaded', (event) => {
            $('head').append(bundleRange);
        });
    </script>


    <script>
        window.isAuthorized = 0    </script>


    

        
                <script>
                window.top.adGrid = window.top.adGrid || {};
                window.top.adGrid.cmd = window.top.adGrid.cmd || [];
                var adGridInitiate = function() {
                    this.adGridCall(function () {
                        var pageMeta = {};
                        this.setMetaDataFromPage(pageMeta);
                    })
                };
                window.top.adGrid.cmd.push([adGridInitiate]);
        </script>
    
</head>
<body         class="nojs not-touch m1-skin-layout
            bgWhite                                                                        no-sliding-banner                        "
        data-spotim-id="" data-edtn="ev_us"
        data-track-url=""         data-rtl="false"

        >
<div class="hiddenBlock">
    </div>
<div data-role="page" id="page_index_articles_detail" class="root">

    <div id="layout_header_spacer"></div>


<div class="m1-header-main">
            <div class="m1-header-main-box">
        <div class="m1-header-main-box-wrapper">
            <div class="box-item-left">
                <div class="m1-hamburger-button" data-hide-scroll="m1-left-side-box" data-close-delay="0.5" data-delay="0.01" onclick="" data-button data-id="mainMenuToggle" data-value="mainMenu" data-clear="2" data-multi>
                    <span></span>
                    <span></span>
                    <span></span>
                </div>
            </div>
            <div class="wrapper-box-item-center">
                <div class="box-item-center">
                    <a class="m1-header-logo" href="/" title="Home">
                        <img class="logo_placeholder" 
                            src="data:image/png;base64,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"
                            alt="InsideEVs Logo"
                        >
                    </a>
                </div>
            </div>
            <div class="box-item-center-wrapper-align">
                <ul class="m1-navigation-main print-hide">
                        <li class="grand top left mobile">
            <a href="/news/" >
                                    News                            </a>
        </li>
                    <li class="grand top left">
            <a href="/reviews/" >
                                    Reviews                            </a>
        </li>
                    <li class="grand left">
            <a href="/features/" >
                                    Features                            </a>
        </li>
                    <li class="grand left">
            <a href="/car-lists/" >
                                    Car Lists                            </a>
        </li>
                    <li class="mobile">
            <a href="/tesla/" >
                                    Tesla                            </a>
        </li>
                    <li class="top left">
            <a href="/reviews/344001/compare-evs/" >
                                    Compare EVs                            </a>
        </li>
                    <li class="left">
            <a href="/features/341500/the-ultimate-buyers-guide-to-home-ev-chargers-plus-top-5-picks/" >
                                    Charger Guide                            </a>
        </li>
                    <li class="left">
            <a href="/features/category/buying-advice/" >
                                    Buying Advice                            </a>
        </li>
                    <li class="left">
            <a href="/news/343998/monthly-plug-in-ev-sales-scorecard/" >
                                    EV Sales Scorecard                            </a>
        </li>
                    <li class="mobile">
            <a href="/news/343998/monthly-plug-in-ev-sales-scorecard/" >
                                    EV Sales                            </a>
        </li>
                    <li class="left">
            <a href="/makes/" >
                                    Makes                            </a>
        </li>
                    <li class="left">
            <a href="/body-styles/" >
                                    Body Style                            </a>
        </li>
                    <li class="left top _blank">
            <a href="https://insideevsforum.com/community/index.php" target = "_blank">
                                    Forum                            </a>
        </li>
                    <li class="left _blank">
            <a href="https://www.myev.com/cars-for-sale" target = "_blank">
                                    Buy                            </a>
        </li>
                    <li class="podcast ico left">
            <a href="https://insideevs.com/features/category/podcast/" >
                                    Podcast                            </a>
        </li>
                    <li class="photos ico left">
            <a href="/photos/" >
                                    Photos                            </a>
        </li>
                    <li class="videos ico left">
            <a href="/videos/" >
                                    Videos                            </a>
        </li>
                    <li class="top plugin-sale">
            <a href="/news/343998/monthly-plug-in-ev-sales-scorecard/" >
                                    Ev Sales Scorecard                            </a>
        </li>
    </ul>
                <div class="m1-navigation-main-part-right">
                    <div class="rewards-container">

                    </div>
                                            <div class="m1-search-form-button-wrapper">
                            <button class="m1-search-form-button-animate icon-search m1-mobile-search"
                                    onclick
                                    data-button
                                    data-id="toggleBox"
                                    data-clear="1"
                                    data-value="searchBox"
                                    data-multi
                                    type="submit">
                            </button>
                            <div class="m1-search-panel">
                                <form action="/search/" class="m1-search-form" method="GET" id="header_search_form" data-native="0" novalidate="novalidate">
                                    <input class="m1-search-panel-input m1-search-form-text" id="search_input" type="text" value="" name="q" placeholder="Search" autocomplete="off">
                                    <button class="m1-search-panel-button m1-search-form-button-animate icon-search " type="submit">
                                    </button>
                                    <button onclick=""
                                            data-button
                                            data-id="toggleBox"
                                            data-value="searchBox"
                                            data-clear="1"
                                            data-toggle="1"
                                            data-multi
                                            class="m1-search-panel-button m1-drawer-close-button">
                                    </button>
                                </form>
                            </div>
                        </div>
                                    </div>

                
                
            </div>
                            <div class="box-item-right">
                    <div class="m1-editions-switcher-m" data-hide-scroll="m1-scrollbar" data-close-delay="0.5"  data-delay="0.01" onclick="" data-button data-id="toggleBox" data-value="editionsMenu" data-clear="2" data-multi>
                                                <span class="edf edf-230"></span>
                                            </div>
                    <div class="m1-editions-switcher" data-hide-scroll="m1-scrollbar" data-close-delay="0.5" data-delay="0.01" onclick="" data-button data-id="toggleBox" data-value="editionsMenu" data-clear="2" data-multi>
                                                <span class="edf edf-230"></span>
                                                <span class="title">USA / Global</span>
                    </div>
                </div>
                    </div>
    </div>
</div>
<div class="m1-header-ad top-banner-placeholder">
    <div class="Adgrid_footboard"></div></div>    <div class="pageAdSkin" id="page_skin_top">
        <div class="adSizer"><img alt="" src="data:image/gif;base64,R0lGODlhAQABAIAAAP///wAAACH5BAEAAAAALAAAAAABAAEAAAICRAEAOw=="></div>
        <a class="pageAdSkinUrl"></a>
    </div>
    
    

    

    


    <div class="pre-center breadcrumbs-area ">
                <div slot="breadcrumbs" class="breadcrumbs">
        <a href="/">Home</a><span class="sep"></span><a href="/tesla/">Tesla</a><span class="sep"></span><a href="/tesla/model-s/">Model S</a><span class="sep"></span><a href="/tesla/model-s/news/">News</a>    </div>
        <h1 class="m1-article-title">Watch Rimac Nevera Destroy Tesla Model S Plaid In Drag Races</h1>
    </div>
            <div class="kpre-center videoBoxArticle">
                        <div class="videoBoxArticle-wrapper youtube-video-wrapper lazy">
                
<img class="sizer" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAABAAAAAJCAYAAAA7KqwyAAAAGXRFWHRTb2Z0d2FyZQBBZG9iZSBJbWFnZVJlYWR5ccllPAAAABpJREFUeNpi/P//PwMlgImBQjBqwLAwACDAAOVfAw9/ZDvcAAAAAElFTkSuQmCC" alt=""/>                <div class="video-player">
                    <div class="video-player-close icon-cross"></div>
                    <iframe data-src="https://www.youtube.com/embed/GUB1z5wr5p8" allowfullscreen="" data-mce-data-src="https://www.youtube.com/embed/GUB1z5wr5p8" width="560" height="315" frameborder="0"></iframe>                </div>
            </div>
        </div>
    
<div class="pre-center padding  b-padding-skin pre-center-feature" id="post_box">
    <div data-bubbles="keyword" data-url="/news/store-keywords/" data-name="id"></div>
    <div class="content-area  " id="article_box" >
        <div class="content-area-box">
                            <div class="postTopInfo ">
                    <div class="postMeta-Top">
                                                        <div class="postDate"><span class="date" data-time="1629292392"></span><span class="date-data">Aug 18, 2021</span><span class="small"> at</span> 1:13pm ET</div>                                                                            <div class="shareTrendingBox">
                                                                                                            <a href="/news/527462/rimac-nevera-tesla-plaid-race/#comments" class="commentsNumber disqus-comment-count" data-disqus-url="//insideevscom.disqus.com/count-data.json?url=https://insideevs.com/news/527462/rimac-nevera-tesla-plaid-race/"></a>
                                                                                                                                    <div slot="share-box" class="big-shareBox shareBox share-box-dropdown to-down"><div class="share-box-wrapper"><span class="shareBox-separator" data-value="share-list-1629307676" data-button onClick="" data-id="toggleBox" data-static> <span class="active"><span class="icon-plus">+</span></span><span class="passive"><span class="icon-plus">+</span></span></span><a href="https://insideevs.com/news/527462/rimac-nevera-tesla-plaid-race/" class="share-button share-button-gallery" rel="nofollow noopener"><span class="icon share-empty"></span></a><div class="share-list" data-button-target="share-list-1629307676"><ul><li class="facebook"><a data-button="" data-id="share" data-url="/connect/share/" data-name="network_id" target="_blank" rel="nofollow noopener" data-extra-params="id:'527462',type_id:'1'" data-value="1" data-share-network="Facebook" data-share-url="https://insideevs.com/news/527462/rimac-nevera-tesla-plaid-race/" data-width="600" data-height="600" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Finsideevs.com%2Fnews%2F527462%2Frimac-nevera-tesla-plaid-race%2F"><span class="social-bg icon facebook"></span><span class="name">Share on Facebook</span></a></li><li class="twitter"><a data-button="" data-id="share" data-url="/connect/share/" data-name="network_id" target="_blank" rel="nofollow noopener" data-extra-params="id:'527462',type_id:'1'" data-value="2" data-share-network="Twitter" data-share-url="https://insideevs.com/news/527462/rimac-nevera-tesla-plaid-race/" data-width="600" data-height="450" href="https://twitter.com/intent/tweet?url=https%3A%2F%2Finsideevs.com%2Fnews%2F527462%2Frimac-nevera-tesla-plaid-race%2F&text=Watch+Rimac+Nevera+Destroy+Tesla+Model+S+Plaid+In+Drag+Races&via=insideevs.com"><span class="social-bg icon twitter"></span><span class="name">Share on Twitter</span></a></li><li class="linkedin"><a data-button="" data-id="share" data-url="/connect/share/" data-name="network_id" target="_blank" rel="nofollow noopener" data-extra-params="id:'527462',type_id:'1'" data-value="3" data-share-network="LinkedIn" data-share-url="https://insideevs.com/news/527462/rimac-nevera-tesla-plaid-race/" data-width="600" data-height="600" href="https://www.linkedin.com/cws/share?url=https%3A%2F%2Finsideevs.com%2Fnews%2F527462%2Frimac-nevera-tesla-plaid-race%2F"><span class="social-bg icon linkedin"></span><span class="name">Share on LinkedIn</span></a></li><li class="flipboard"><a data-button="" data-id="share" data-url="/connect/share/" data-name="network_id" target="_blank" rel="nofollow noopener" data-extra-params="id:'527462',type_id:'1'" data-value="7" data-share-network="Flipboard" data-share-url="https://insideevs.com/news/527462/rimac-nevera-tesla-plaid-race/" data-width="600" data-height="600" href="https://share.flipboard.com/bookmarklet/popout?url=https%3A%2F%2Finsideevs.com%2Fnews%2F527462%2Frimac-nevera-tesla-plaid-race%2F&title=Watch+Rimac+Nevera+Destroy+Tesla+Model+S+Plaid+In+Drag+Races&v=2"><span class="social-bg icon flipboard"></span><span class="name">Share on Flipboard</span></a></li><li class="reddit"><a data-button="" data-id="share" data-url="/connect/share/" data-name="network_id" target="_blank" rel="nofollow noopener" data-extra-params="id:'527462',type_id:'1'" data-value="6" data-share-network="Reddit" data-share-url="https://insideevs.com/news/527462/rimac-nevera-tesla-plaid-race/" data-width="900" data-height="600" href="https://www.reddit.com/submit?url=https%3A%2F%2Finsideevs.com%2Fnews%2F527462%2Frimac-nevera-tesla-plaid-race%2F"><span class="social-bg icon reddit"></span><span class="name">Share on Reddit</span></a></li><li class="whatsapp"><a data-button="" data-id="share" data-url="/connect/share/" data-name="network_id" target="_blank" rel="nofollow noopener" data-extra-params="id:'527462',type_id:'1'" data-value="6" data-share-network="WhatsApp" data-share-url="https://insideevs.com/news/527462/rimac-nevera-tesla-plaid-race/" data-width="600" data-height="600" href="https://api.whatsapp.com/send?text=https%3A%2F%2Finsideevs.com%2Fnews%2F527462%2Frimac-nevera-tesla-plaid-race%2F"><span class="social-bg icon whatsapp"></span><span class="name">Share on WhatsApp</span></a></li><li class="mailto"><a data-button="" data-id="mailTo" target="_blank" rel="nofollow noopener" data-extra-params="id:'527462',type_id:'1'" data-share-url="https://insideevs.com/news/527462/rimac-nevera-tesla-plaid-race/" data-width="600" data-height="400" href="mailto:?body=https%3A%2F%2Finsideevs.com%2Fnews%2F527462%2Frimac-nevera-tesla-plaid-race%2F&subject=Watch%20Rimac%20Nevera%20Destroy%20Tesla%20Model%20S%20Plaid%20In%20Drag%20Races"><span class="social-bg icon mailto"></span><span class="name">Send to email</span></a></li></ul></div></div></div>                            </div>
                                            </div>


                        <div class="postAuthorBox withAvatar" xmlns="http://www.w3.org/1999/xhtml">
                    <div class="postAuthorThumb">
                <a class="userRThumb" href="/info/team/mark-kane/">
                    <picture>
                        <source type="image/webp" srcset="https://cdn.motor1.com/images/atr/vmq/s4/mark-kane1.webp">
                        <source type="image/jpeg" srcset="https://cdn.motor1.com/images/atr/vmq/s4/mark-kane1.jpg">
                        <img src="https://cdn.motor1.com/images/atr/vmq/s4/mark-kane1.jpg" alt="Mark Kane" />
                    </picture>
                </a>
            </div>
                <div class="postAuthorInfo">
            <div class="postAuthor">
                <span class="name">
                    <span class="label">By</span>:
                                            <a class="author" content="Mark Kane" href="/info/team/mark-kane/">Mark Kane</a>
                                    </span>
            </div>
                                            </div>
            </div>
                    <div class="clear"></div>

                </div>

            <div class="postContent content-wrapper">
                                                    <h2 class="preview">
                        ...as expected since the Nevera has almost two times the peak power output.                    </h2>
                                                <div class="postBody description e-content">
                                <p>The two quickest production cars in the world, which happen to be electric - the <a href="https://insideevs.com/tesla/model-s/">Tesla Model S</a> Plaid and <a href="https://insideevs.com/tag/rimac-nevera/">Rimac Nevera</a> - recently met at the Famoso Dragstrip in California.</p>
<p><em>DragTimes</em> had a rare opportunity to conduct three drag races between the two and each of them was easily won by the Nevera. No surprise here, as the Croatian supercar's 1/4 mile record is 8.582 seconds, while Tesla does about 9.247 seconds. The 0.9 second difference translated to a significant gap on the track.</p>
<p>In the first race, the quicker reaction time of the Tesla driver allows us to see that even with a bit of a head start, the Plaid is still no match for the Rimac Nevera. Here are the results:</p>
<p><strong>Race #1</strong></p>
<ul style="list-style-type: disc;">
<li>Rimac Nevera: 8.655 seconds @166.66 mph</li>
<li>Tesla Model S Plaid: 9.272 seconds @152.68 mph</li>
</ul>
<p><strong>Race #2</strong></p>
<ul style="list-style-type: disc;">
<li>Rimac Nevera: 8.641 seconds @166.44 mph</li>
<li>Tesla Model S Plaid: 9.312 seconds @151.34 mph</li>
</ul>
<p><strong>Race #3</strong></p>
<ul style="list-style-type: disc;">
<li>Rimac Nevera: 8.615 seconds @166.39 mph</li>
<li>Tesla Model S Plaid: 9.294 seconds @151.75 mph</li>
</ul>
<p>Rimac Nevera destroying Tesla Model S Plaid was fully expected. It's a four-motor electric supercar ($2.4 million) with a peak system output of 1,408 kW (1.4 MW), while the Plaid is equipped with three electric motors and a total system output of up to about 760 kW.</p>
<p>Previously, we saw how <a href="https://insideevs.com/news/523383/tesla-plaid-porsche-taycan-race/">the Tesla Model S Plaid destroyed the Porsche Taycan Turbo S</a>, equipped with two motors and a total peak system output of 560 kW.</p>
<p>Some might say that the race against the Rimac Nevera is a kind of revenge, as Porsche is a shareholder in Rimac Automobili.</p><div class="Adgrid_Native"></div>
<p>Anyway, here we have it - the quickest electric supercar and electric flagship sedan on the market.</p>
<section class="relatedContent-new" contenteditable="false" draggable="true" data-widget="related-content" data-widget-size="content" data-params="%7B%22type_id%22%3A0%2C%22title_id%22%3A%22%22%2C%22items%22%3A%5B%7B%22article_edition_id%22%3A%22525410%22%2C%22title%22%3A%22Tesla%20Model%20S%20Plaid%20Gives%20'Normal'%20Car%2010%20Second%20Head%20Start%22%2C%22alias%22%3A%22tesla-plaid-10second-head-start%22%2C%22section%22%3A%221%22%2C%22is_video%22%3A%221%22%2C%22images%22%3A%7B%22s5%22%3A%22https%3A%2F%2Fcdn.motor1.com%2Fimages%2Fmgl%2FY1O3e%2Fs5%2Ftesla-plaid-gives-10-second-head-start---still-wins-source-csp-shorts.jpg%22%7D%7D%2C%7B%22article_edition_id%22%3A%22522285%22%2C%22title%22%3A%22Watch%20Tesla%20Model%20S%20Plaid%20Vs%20Shelby%20GT500%20In%20Roll%20Races%22%2C%22alias%22%3A%22tesla-models-plaid-shelby-gt500%22%2C%22section%22%3A%221%22%2C%22is_video%22%3A%221%22%2C%22images%22%3A%7B%22s5%22%3A%22https%3A%2F%2Fcdn.motor1.com%2Fimages%2Fmgl%2FGxBPG%2Fs5%2Ftesla-plaid-model-s-vs-1-000-hp-2020-shelby-gt500-roll-race-solo-1-4-mile-passes-source-drag-racing-and-car-stuff.jpg%22%7D%7D%5D%7D"> <p class="trending-content_header">More races</p> <div class="wrapper-related-item"> <div class="related-item"><a href="https://insideevs.com/news/525410/tesla-plaid-10second-head-start/"> <span class="lazy related-item-img"> <span class="icon play">⠀</span> <img src="https://cdn.motor1.com/custom/share/placeholder_0.jpg" alt="tesla plaid 10second head start" data-srcset="https://cdn.motor1.com/images/mgl/Y1O3e/s6/tesla-plaid-gives-10-second-head-start---still-wins-source-csp-shorts.jpg 1x,
https://cdn.motor1.com/images/mgl/Y1O3e/s4/tesla-plaid-gives-10-second-head-start---still-wins-source-csp-shorts.jpg 2x" data-src="https://cdn.motor1.com/images/mgl/Y1O3e/s6/tesla-plaid-gives-10-second-head-start---still-wins-source-csp-shorts.jpg" /> </span> <span class="title-related-item">Tesla Model S Plaid Gives 'Normal' Car 10 Second Head Start</span> </a></div> <div class="related-item"><a href="https://insideevs.com/news/522285/tesla-models-plaid-shelby-gt500/"> <span class="lazy related-item-img"> <span class="icon play">⠀</span> <img src="https://cdn.motor1.com/custom/share/placeholder_1.jpg" alt="tesla models plaid shelby gt500" data-srcset="https://cdn.motor1.com/images/mgl/GxBPG/s6/tesla-plaid-model-s-vs-1-000-hp-2020-shelby-gt500-roll-race-solo-1-4-mile-passes-source-drag-racing-and-car-stuff.jpg 1x,
https://cdn.motor1.com/images/mgl/GxBPG/s4/tesla-plaid-model-s-vs-1-000-hp-2020-shelby-gt500-roll-race-solo-1-4-mile-passes-source-drag-racing-and-car-stuff.jpg 2x" data-src="https://cdn.motor1.com/images/mgl/GxBPG/s6/tesla-plaid-model-s-vs-1-000-hp-2020-shelby-gt500-roll-race-solo-1-4-mile-passes-source-drag-racing-and-car-stuff.jpg" /> </span> <span class="title-related-item">Watch Tesla Model S Plaid Vs Shelby GT500 In Roll Races</span> </a></div> </div> </section>
<p><strong>Rimac Nevera specs:</strong></p>
<ul style="list-style-type: disc;">
<li>up to <strong>550 km (342 miles) of WLTP</strong> range (preliminary)</li>
<li><strong>120 kWh</strong> battery; liquid cooled<br />800V system voltage (maximum 730 V)<br />Lithium Manganese Nickel chemistry<br />Cell format: cylindrical 2170<br />number of cells: 6,960</li>
<li>Acceleration<br />0-60 mph (96.5 km/h) in 1.85 seconds (*high-friction surface, one foot roll-out)<br />0-100 km/h (62 mph) in 1.97 seconds (*high-friction surface, one foot roll-out)<br />0-300 km/h (186 mph) in 9.3 seconds (high-friction surface, one foot roll-out)<br />1/4 mile (402 m) time in 8.6 seconds<br />DragTimes' run: 8.582 seconds at 167.51 mph (269.5 km/h)</li>
<li>top speed of 412 km/h (258 mph)</li>
<li>all-wheel drive</li>
<li>system output of 1,408 kW (or 1.4 MW; 1,914 hp) and 2,360 Nm<br />four independent surface-mounted, carbon-sleeve, permanent-magnet electric motors<br />four independent inverters and gearboxes<br />Rimac's intelligent All Wheel Torque Vectoring system (R-AWTV)<br />front motors: 250 kW (340 hp) and 280 Nm each, combined with two single speed gearboxes (two independent gearboxes - one at each outer end of the axle) <br />rear motors: 450 kW (612 hp) and 900 Nm each, combined with double single speed gearbox (two gearboxes in one housing between the motors) </li>
<li>AC charging (on-board): 22 kW three-phase</li>
<li>DC fast charging: up to 500 kW (0-80% SOC in 22 minutes, using ultra-fast charger)</li>
<li>length 4750 mm; Width 1986 mm; Height 1208 mm; Wheelbase 2745 mm</li>
<li>weight of 2,150 kg</li>
<li>Tires: Michelin Pilot Sport 4S (Front 275/35 R20; Rear 315/35 R20)</li>
</ul>
<p><strong>Tesla Model S Plaid specs:</strong></p>
<ul style="list-style-type: disc;">
<li>up to 390 miles (628 km) of EPA est. range</li>
<li>battery capacity: N/A</li>
<li>0-60 mph (96.5 km/h) in 1.99 seconds (*with rollout subtracted)<br />0-100 km/h (62 mph) in 2.1 seconds (*with rollout subtracted)<br /><a href="https://insideevs.com/news/514979/tesla-cant-60mph-under-2seconds/"><em>MotorTrend</em>'s 0-60 mph (asphalt, no rollout): 2.28 seconds</a>; <a href="https://insideevs.com/news/515597/how-quick-tesla-models-plaid/">2.3 seconds according to <em>ICSI</em></a></li>
<li>1/4 mile 9.23 seconds at 155 mph trap speed according to Tesla<br /><a href="https://insideevs.com/news/513651/jay-leno-tesla-plaid-record/">Jay Leno's 1/4 mile record of 9.247 seconds at 152.16 mph trap speed</a><br /><a href="https://insideevs.com/news/519291/tesla-plaid-full-performance-tests/">DragTimes' run: 9.248 seconds at 151.83 mph</a><br /><a href="https://insideevs.com/news/522426/tesla-models-plaid-drag-record/">record time of 9.081 seconds at 154.10 mph trap speed with removed interior <span class="sentence corrected"><span class="correction sac" data-start-index="22" data-end-index="26" data-type="Spelling">pieces</span></span> - July 24, 2021 at the World Wide Technology Raceway in St. Louis</a></li>
<li>top speed of 200 mph (322 km/h) †when equipped with the proper wheels and tires (available fall 2021)</li>
<li>three-motor all-wheel drive (one motor in the front and two motors in the rear)</li>
<li>system output: 1,020 hp (about 760 kW)</li>
<li>DC fast charging: at up to 250 kW (Superchargers)<br />can replenish 187 miles (301 km) in 15 minutes</li>
<li>Drag Coefficient 0.208 Cd</li>
<li>Wheels 19" or 21"</li>
<li>Cargo 28 cu ft</li>
<li>Weight 4,766 lbs (2,162 kg)</li>
</ul>                </div>


                    
                    <!-- new gallery place, attached gallery -->
                                        

                

                
                

                



                                

                                    <div class="parent-shareBox parent-shareBox-bottom">
                                                                                                            <a href="/news/527462/rimac-nevera-tesla-plaid-race/#comments" class="commentsNumber disqus-comment-count" data-disqus-url="//insideevscom.disqus.com/count-data.json?url=https://insideevs.com/news/527462/rimac-nevera-tesla-plaid-race/"></a>
                                                                            <div slot="share-box" class="big-shareBox shareBox share-box-dropdown to-down"><div class="share-box-wrapper"><span class="shareBox-separator" data-value="share-list-1629306910" data-button onClick="" data-id="toggleBox" data-static> <span class="active"><span class="icon-plus">+</span></span><span class="passive"><span class="icon-plus">+</span></span></span><a href="https://insideevs.com/news/527462/rimac-nevera-tesla-plaid-race/" class="share-button share-button-gallery" rel="nofollow noopener"><span class="icon share-empty"></span></a><div class="share-list" data-button-target="share-list-1629306910"><ul><li class="facebook"><a data-button="" data-id="share" data-url="/connect/share/" data-name="network_id" target="_blank" rel="nofollow noopener" data-extra-params="id:'527462',type_id:'1'" data-value="1" data-share-network="Facebook" data-share-url="https://insideevs.com/news/527462/rimac-nevera-tesla-plaid-race/" data-width="600" data-height="600" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Finsideevs.com%2Fnews%2F527462%2Frimac-nevera-tesla-plaid-race%2F"><span class="social-bg icon facebook"></span><span class="name">Share on Facebook</span></a></li><li class="twitter"><a data-button="" data-id="share" data-url="/connect/share/" data-name="network_id" target="_blank" rel="nofollow noopener" data-extra-params="id:'527462',type_id:'1'" data-value="2" data-share-network="Twitter" data-share-url="https://insideevs.com/news/527462/rimac-nevera-tesla-plaid-race/" data-width="600" data-height="450" href="https://twitter.com/intent/tweet?url=https%3A%2F%2Finsideevs.com%2Fnews%2F527462%2Frimac-nevera-tesla-plaid-race%2F&text=Watch+Rimac+Nevera+Destroy+Tesla+Model+S+Plaid+In+Drag+Races&via=insideevs.com"><span class="social-bg icon twitter"></span><span class="name">Share on Twitter</span></a></li><li class="linkedin"><a data-button="" data-id="share" data-url="/connect/share/" data-name="network_id" target="_blank" rel="nofollow noopener" data-extra-params="id:'527462',type_id:'1'" data-value="3" data-share-network="LinkedIn" data-share-url="https://insideevs.com/news/527462/rimac-nevera-tesla-plaid-race/" data-width="600" data-height="600" href="https://www.linkedin.com/cws/share?url=https%3A%2F%2Finsideevs.com%2Fnews%2F527462%2Frimac-nevera-tesla-plaid-race%2F"><span class="social-bg icon linkedin"></span><span class="name">Share on LinkedIn</span></a></li><li class="flipboard"><a data-button="" data-id="share" data-url="/connect/share/" data-name="network_id" target="_blank" rel="nofollow noopener" data-extra-params="id:'527462',type_id:'1'" data-value="7" data-share-network="Flipboard" data-share-url="https://insideevs.com/news/527462/rimac-nevera-tesla-plaid-race/" data-width="600" data-height="600" href="https://share.flipboard.com/bookmarklet/popout?url=https%3A%2F%2Finsideevs.com%2Fnews%2F527462%2Frimac-nevera-tesla-plaid-race%2F&title=Watch+Rimac+Nevera+Destroy+Tesla+Model+S+Plaid+In+Drag+Races&v=2"><span class="social-bg icon flipboard"></span><span class="name">Share on Flipboard</span></a></li><li class="reddit"><a data-button="" data-id="share" data-url="/connect/share/" data-name="network_id" target="_blank" rel="nofollow noopener" data-extra-params="id:'527462',type_id:'1'" data-value="6" data-share-network="Reddit" data-share-url="https://insideevs.com/news/527462/rimac-nevera-tesla-plaid-race/" data-width="900" data-height="600" href="https://www.reddit.com/submit?url=https%3A%2F%2Finsideevs.com%2Fnews%2F527462%2Frimac-nevera-tesla-plaid-race%2F"><span class="social-bg icon reddit"></span><span class="name">Share on Reddit</span></a></li><li class="whatsapp"><a data-button="" data-id="share" data-url="/connect/share/" data-name="network_id" target="_blank" rel="nofollow noopener" data-extra-params="id:'527462',type_id:'1'" data-value="6" data-share-network="WhatsApp" data-share-url="https://insideevs.com/news/527462/rimac-nevera-tesla-plaid-race/" data-width="600" data-height="600" href="https://api.whatsapp.com/send?text=https%3A%2F%2Finsideevs.com%2Fnews%2F527462%2Frimac-nevera-tesla-plaid-race%2F"><span class="social-bg icon whatsapp"></span><span class="name">Share on WhatsApp</span></a></li><li class="mailto"><a data-button="" data-id="mailTo" target="_blank" rel="nofollow noopener" data-extra-params="id:'527462',type_id:'1'" data-share-url="https://insideevs.com/news/527462/rimac-nevera-tesla-plaid-race/" data-width="600" data-height="400" href="mailto:?body=https%3A%2F%2Finsideevs.com%2Fnews%2F527462%2Frimac-nevera-tesla-plaid-race%2F&subject=Watch%20Rimac%20Nevera%20Destroy%20Tesla%20Model%20S%20Plaid%20In%20Drag%20Races"><span class="social-bg icon mailto"></span><span class="name">Send to email</span></a></li></ul></div></div></div>                    </div>
                                            <div class="tip-us-email-container">
                            <div class="tip-us-email">
                                <span>Got a tip for us? Email:</span>
                                <a href="mailto: tips@insideevs.com?subject=rimac-nevera-tesla-plaid-race">
                                    tips@insideevs.com                                </a>
                            </div>
                        </div>
                                                        

                
                
                
                
                

                                

                
            </div>
        </div>






                    <div class="sidebar" id="post_sidebar">
                                    <div class="Adgrid_right_rail"></div>                                    
                                        <div class="trending-content">
        <div class="content-header">
            <p class="trending-content_header">Trending</p>
        </div>
                    
            <div class="trending-content_item">
                <a class="trending-content_thumb thumb zoom"  href="/features/527262/tesla-models-plaid-doug-demuro/">
                                            <span class="icon play"></span>
                                        <picture class="lazy">
                        <source type="image/webp" srcset="https://cdn.motor1.com/images/mgl/QjGV3/s6/tesla-model-s-plaid-doug-demuro-review.webp">
                        <source type="image/jpeg" srcset="https://cdn.motor1.com/images/mgl/QjGV3/s6/tesla-model-s-plaid-doug-demuro-review.jpg">
                        <img src="https://cdn.motor1.com/custom/share/placeholder_0.jpg" alt="Tesla Model S Plaid Is Like Nothing Doug DeMuro Has Ever Driven" data-src="https://cdn.motor1.com/images/mgl/QjGV3/s6/tesla-model-s-plaid-doug-demuro-review.jpg" class="desaturate">                    </picture>
                </a>
                <a class="trending-content_link"  href="/features/527262/tesla-models-plaid-doug-demuro/">Tesla Model S Plaid Is Like Nothing Doug DeMuro Has Ever Driven</a>
            </div>
                    
            <div class="trending-content_item">
                <a class="trending-content_thumb thumb zoom"  href="/news/527462/rimac-nevera-tesla-plaid-race/">
                                            <span class="icon play"></span>
                                        <picture class="lazy">
                        <source type="image/webp" srcset="https://cdn.motor1.com/images/mgl/eEWLM/s6/1-914-hp-nevera-vs-plaid-source-dragtimes.webp">
                        <source type="image/jpeg" srcset="https://cdn.motor1.com/images/mgl/eEWLM/s6/1-914-hp-nevera-vs-plaid-source-dragtimes.jpg">
                        <img src="https://cdn.motor1.com/custom/share/placeholder_1.jpg" alt="Watch Rimac Nevera Destroy Tesla Model S Plaid In Drag Races" data-src="https://cdn.motor1.com/images/mgl/eEWLM/s6/1-914-hp-nevera-vs-plaid-source-dragtimes.jpg" class="desaturate">                    </picture>
                </a>
                <a class="trending-content_link"  href="/news/527462/rimac-nevera-tesla-plaid-race/">Watch Rimac Nevera Destroy Tesla Model S Plaid In Drag Races</a>
            </div>
                    
            <div class="trending-content_item">
                <a class="trending-content_thumb thumb zoom"  href="/news/527421/tesla-models-owner-quality-issues/">
                                            <span class="icon play"></span>
                                        <picture class="lazy">
                        <source type="image/webp" srcset="https://cdn.motor1.com/images/mgl/33Bl1/s6/2021-tesla-model-s-owner-complains-about-quality-issues.webp">
                        <source type="image/jpeg" srcset="https://cdn.motor1.com/images/mgl/33Bl1/s6/2021-tesla-model-s-owner-complains-about-quality-issues.jpg">
                        <img src="https://cdn.motor1.com/custom/share/placeholder_2.jpg" alt="2021 Tesla Model S Owner Says Quality Issues Not Okay On $100K Car" data-src="https://cdn.motor1.com/images/mgl/33Bl1/s6/2021-tesla-model-s-owner-complains-about-quality-issues.jpg" class="desaturate">                    </picture>
                </a>
                <a class="trending-content_link"  href="/news/527421/tesla-models-owner-quality-issues/">2021 Tesla Model S Owner Says Quality Issues Not Okay On $100K Car</a>
            </div>
                    
            <div class="trending-content_item">
                <a class="trending-content_thumb thumb zoom"  href="/features/527466/tesla-model3-toyota-camry-cost/">
                                            <span class="icon play"></span>
                                        <picture class="lazy">
                        <source type="image/webp" srcset="https://cdn.motor1.com/images/mgl/rx6p9/s6/tesla-model-3-vs-toyota-camry-5-year-ownership-cost.webp">
                        <source type="image/jpeg" srcset="https://cdn.motor1.com/images/mgl/rx6p9/s6/tesla-model-3-vs-toyota-camry-5-year-ownership-cost.jpg">
                        <img src="https://cdn.motor1.com/custom/share/placeholder_3.jpg" alt="Tesla Model 3 Vs Toyota Camry: Ultimate Ownership Cost Analysis" data-src="https://cdn.motor1.com/images/mgl/rx6p9/s6/tesla-model-3-vs-toyota-camry-5-year-ownership-cost.jpg" class="desaturate">                    </picture>
                </a>
                <a class="trending-content_link"  href="/features/527466/tesla-model3-toyota-camry-cost/">Tesla Model 3 Vs Toyota Camry: Ultimate Ownership Cost Analysis</a>
            </div>
                    
            <div class="trending-content_item">
                <a class="trending-content_thumb thumb zoom"  href="/news/527230/gm-replace-bolt-modules-fire/">
                                        <picture class="lazy">
                        <source type="image/webp" srcset="https://cdn.motor1.com/images/mgl/bpbll/s6/2020-chevrolet-bolt-ev.webp">
                        <source type="image/jpeg" srcset="https://cdn.motor1.com/images/mgl/bpbll/s6/2020-chevrolet-bolt-ev.jpg">
                        <img src="https://cdn.motor1.com/custom/share/placeholder_4.jpg" alt="And So It Goes, GM Will Replace Chevy Bolt EV Battery Modules" data-src="https://cdn.motor1.com/images/mgl/bpbll/s6/2020-chevrolet-bolt-ev.jpg" class="desaturate">                    </picture>
                </a>
                <a class="trending-content_link"  href="/news/527230/gm-replace-bolt-modules-fire/">And So It Goes, GM Will Replace Chevy Bolt EV Battery Modules</a>
            </div>
            </div>

                
                                    <div class="Adgrid_right_rail"></div>                            </div>
                <div class="clear"></div>
    </div>
</div>


<div id="container_3rd_party_service" class="container_3rd_party pre-center padding print-hide" data-edtn="ev_us">

            <div id="strossle-container">
        </div>
    
    
                    <div class="myevFeedContainer" data-tags="drag race,rimac,dragtimes,tesla drag race,plaid,rimac nevera,Tesla,Races and Chases"></div>
        <script type="text/javascript" src="https://www.myev.com/js/insideevs_v1.2.js" defer></script>
    
    
                <div class="sellwild-container">
    <div class="sellwild-wrapper" data-src="insideevs/insideevs-insideevs.js">
    </div>
</div>

    
    
        <div class="content-area">
        <div class="content-area-box">
                            <div id="comments" class="comment-container no-apb">
                                                                                            <div id="disqus_thread" class="diquas-wrapper" data-cid="article-527462" data-url="/news/527462/rimac-nevera-tesla-plaid-race/" data-title="Watch Rimac Nevera Destroy Tesla Model S Plaid In Drag Races">
                            </div>
                                                                                                                            <p class="text-uppercase bottom-heading">About this article</p>
                <table class="additionalInfo">
                                            <tr>
                            <td>Category</td>
                            <td><div class="list">
                                                                            <a href="/news/category/races-chases/">Races and Chases</a>
                                                                    </div></td>
                        </tr>
                                                                                    <tr>
                            <td>Tags</td>
                            <td>
                                <div class="list">
                                                                            <a href="/tag/drag-race/">drag race</a>
                                                                            <a href="/tag/rimac/">rimac</a>
                                                                            <a href="/tag/dragtimes/">dragtimes</a>
                                                                            <a href="/tag/tesla-drag-race/">tesla drag race</a>
                                                                            <a href="/tag/plaid/">plaid</a>
                                                                            <a href="/tag/rimac-nevera/">rimac nevera</a>
                                                                    </div>
                            </td>
                        </tr>
                                                                                                <tr>
                                <td>Make/Model</td>
                                <td>
                                    <div class="list">
                                                                                                                                <a href="/tesla/model-s/">Tesla Model S</a>
                                                                            </div>
                                </td>
                            </tr>
                                                    <tr>
                                <td>Body Style</td>
                                <td>
                                    <div class="list">
                                                                                                                                                                                                                                                                                                                                                    <a href="/body-styles/sedan/">
                                                Sedan                                            </a>
                                                                            </div>
                                </td>
                            </tr>
                                                            </table>                                    </div>
                                    
                    </div>
        <div class="sidebar">
                            <div class="mobile-adv">
                    <div class="Adgrid_right_rail"></div>                </div>
                <div class="lazy-load-adv">
                    <div class="Adgrid_right_rail"></div>                </div>
                                </div>
        <div class="clear"></div>

    </div>


    


    
                </div>

<div class="pre-center mobile-skyscraper-box">
            <div class="Adgrid_right_rail"></div>    
</div>

<div class="cpre-center print-hide">
    </div>

    <div id="stop_share_box" class="print-hide"></div>

    


        </div>


<div class="m1-left-side">
    <div class="m1-drawer left-to-right disabled" data-button-target="mainMenu">
        <div onclick="" data-button data-id="mainMenuToggle" data-close-delay="0.5" data-value="mainMenu" data-hide-scroll="m1-left-side-box" data-clear="2" class="m1-drawer-close-button dark active" data-toggle="1" data-multi></div>
        <div class="m1-left-side-top">
            <div class="m1-user-side-label">
                <span class="label flex-parent two-line">
                   <a class="login" href="/connect/msnt/">Sign In</a>
                   <span class="hide_mobile">or</span>
                   <a class="register" href="/connect/msnt/?is_registration=1">Sign Up</a>
                </span>
                <span class="hide_mobile userpic icon-user"></span>
            </div>
        </div>
        <div class="m1-left-side-box">
                        <ul class="m1-navigation-main print-hide">
                                <li class="m1-navigation-main__animated-block grand top left mobile">
            <a 
                href="/news/" 
                                 
            >
                                    News                                
            </a>
        </li>
                            <li class="m1-navigation-main__animated-block grand top left">
            <a 
                href="/reviews/" 
                                 
            >
                                    Reviews                                
            </a>
        </li>
                            <li class="m1-navigation-main__animated-block grand left">
            <a 
                href="/features/" 
                                 
            >
                                    Features                                
            </a>
        </li>
                            <li class="m1-navigation-main__animated-block grand left">
            <a 
                href="/car-lists/" 
                                 
            >
                                    Car Lists                                
            </a>
        </li>
                            <li class="m1-navigation-main__animated-block mobile">
            <a 
                href="/tesla/" 
                                 
            >
                                    Tesla                                
            </a>
        </li>
                            <li class="m1-navigation-main__animated-block top left">
            <a 
                href="/reviews/344001/compare-evs/" 
                                 
            >
                                    Compare EVs                                
            </a>
        </li>
                            <li class="m1-navigation-main__animated-block left">
            <a 
                href="/features/341500/the-ultimate-buyers-guide-to-home-ev-chargers-plus-top-5-picks/" 
                                 
            >
                                    Charger Guide                                
            </a>
        </li>
                            <li class="m1-navigation-main__animated-block left">
            <a 
                href="/features/category/buying-advice/" 
                                 
            >
                                    Buying Advice                                
            </a>
        </li>
                            <li class="m1-navigation-main__animated-block left">
            <a 
                href="/news/343998/monthly-plug-in-ev-sales-scorecard/" 
                                 
            >
                                    EV Sales Scorecard                                
            </a>
        </li>
                            <li class="m1-navigation-main__animated-block mobile">
            <a 
                href="/news/343998/monthly-plug-in-ev-sales-scorecard/" 
                                 
            >
                                    EV Sales                                
            </a>
        </li>
                            <li class="m1-navigation-main__animated-block left">
            <a 
                href="/makes/" 
                                 
            >
                                    Makes                                
            </a>
        </li>
                            <li class="m1-navigation-main__animated-block left">
            <a 
                href="/body-styles/" 
                                 
            >
                                    Body Style                                
            </a>
        </li>
                            <li class="m1-navigation-main__animated-block left top _blank">
            <a 
                href="https://insideevsforum.com/community/index.php" 
                                 
            >
                                    Forum                                
            </a>
        </li>
                            <li class="m1-navigation-main__animated-block left _blank">
            <a 
                href="https://www.myev.com/cars-for-sale" 
                                 
            >
                                    Buy                                
            </a>
        </li>
                            <li class="m1-navigation-main__animated-block podcast ico left">
            <a 
                href="https://insideevs.com/features/category/podcast/" 
                                 
            >
                                    Podcast                                
            </a>
        </li>
                            <li class="m1-navigation-main__animated-block photos ico left">
            <a 
                href="/photos/" 
                                 
            >
                                    Photos                                
            </a>
        </li>
                            <li class="m1-navigation-main__animated-block videos ico left">
            <a 
                href="/videos/" 
                                 
            >
                                    Videos                                
            </a>
        </li>
                            <li class="m1-navigation-main__animated-block top plugin-sale">
            <a 
                href="/news/343998/monthly-plug-in-ev-sales-scorecard/" 
                                 
            >
                                    Ev Sales Scorecard                                
            </a>
        </li>
    </ul>
            <div class="m1-menus-box">
                <div class="m1-navigation-main__animated-block m1-extra-menus-box">
                    <a href="/" class="m1-side-logo"></a>
                                        <div class="m1-editions-switcher-mobile">
                        <a href="/info/about-us/" class="m1-editions-switcher" onclick="" data-close-delay="0.5" data-delay="0.01" data-button="" data-hide-scroll="m1-scrollbar" data-id="toggleBox" data-value="editionsMenu" data-clear="2" data-multi="">
                            <span class="title">Edition:</span>
                                                        <span class="edf edf-230"></span>
                                                    </a>
                    </div>
                    
                                            <ul class="m1-social-menu">
                                                                                <li class="facebook"  ><a class="icon-facebook-redirect-link" href="https://www.facebook.com/InsideeVs/" target="_blank" rel="nofollow noopener"></a></li>
                                                                                                                                                                <li class="twitter"  ><a class="icon-twitter-redirect-link" href="https://twitter.com/InsideEVs" target="_blank" rel="nofollow noopener"></a></li>
                                                                                                                                                                <li class="flipboard"  ><a class="icon-flipboard-redirect-link" href="https://flipboard.com/@InsideEVs" target="_blank" rel="nofollow noopener"></a></li>
                                                                                                                                                                                                                    <li class="gnews"  ><a class="icon-gnews-redirect-link" href="https://news.google.com/publications/CAAqBwgKMLHIlAswkJCqAw" target="_blank" rel="nofollow noopener"></a></li>
                                                                                                                                                                                                                                                                                                                            <li class="youtube"  ><a class="icon-youtube-redirect-link" href="https://www.youtube.com/channel/UCw4aq8JMlCMBMOQ0PliCkIQ?sub_confirmation=1" target="_blank" rel="nofollow noopener"></a></li>
                                                                                                                                                                                                                    <li class="rss"  ><a class="icon-rss-redirect-link" href="/rss/" ></a></li>
                                                                                                                                </ul>
                    
                    <ul class="m1-info-menu">
                        <li><a href="/info/about-us/">About Us</a></li>
                                                    <li><a href="https://newsletter.insideevs.com/signup/" target="_blank">Newsletter</a></li>
                                                <li><a href="/info/advertising/">Advertising</a></li>
                        <li><a href="/info/feedback/tip-us/">Tip us</a></li>
                        <li><a href="/info/contact/">Contact</a></li>
                                                                                <li><a href="https://info.wrightsmedia.com/insideevs-licensing-permissions" target="_blank">LICENSING</a></li>
                                                                            <li class="one-trust">
                                <!-- OneTrust Cookies Settings button start -->
                                <button id="ot-sdk-btn" class="ot-sdk-show-settings">Cookie Settings</button>
                                <!-- OneTrust Cookies Settings button end -->
                            </li>
                                                <li><a href="/info/cookie-policy/">Cookie policy</a></li>
                        <li><a href="https://accounts.motorsportnetwork.com/legal/privacy-policy" target="_blank">Privacy policy</a></li>
                    </ul>

                </div>
                <div class="m1-navigation-main__animated-block m1-msn-menus-box">
                    <ul class="m1-msn-menu">
                        <li><a href="https://www.motorsport.com/" target="_blank" rel="nofollow noopener">Motorsport.com</a></li>
                        <li><a href="https://motorsport.tv/" target="_blank" rel="nofollow noopener">Motorsport.tv</a></li>
                                                    <li><a href="https://www.motor1.com" target="_blank" rel="nofollow noopener">Motor1.com</a></li>
                                                                                                    <li><a href="https://www.rideapart.com/" target="_blank" rel="nofollow noopener">Rideapart.com</a></li>
                                                <li><a href="https://www.myev.com/" target="_blank" rel="nofollow noopener">Myev.com</a></li>
                    </ul>
                </div>
                <div class="m1-navigation-main__animated-block m1-footer">
                    &copy; 2021 <a target="_blank" rel="nofollow noopener" class="m1-msn-name" href="https://www.motorsportnetwork.com/company/about">Motorsport Network.</a>                                                         </div>
                            </div>
        </div>
    </div>
    <div class="m1-drawer-overlay"></div>
</div>

    
<div class="m1-right-side">
    <div class="m1-drawer right-to-left disabled" data-button-target="editionsMenu">
        
        <div onclick="" data-button data-id="toggleBox" data-value="editionsMenu" data-close-delay="0.5" data-hide-scroll="m1-scrollbar" data-clear="2" class="m1-drawer-close-button active" data-toggle="1" data-multi></div>
    
        <div class="m1-editions-switcher active" data-close-delay="0.5" data-delay="0.01" onclick="" data-button data-id="toggleBox" data-value="editionsMenu" data-clear="2" data-toggle="1" data-multi>
                        <span class="edf edf-230"></span>
                        <span class="title">USA / Global</span>
        </div>
        <div class="m1-editions-label">Our International Editions</div>
        <div class="m1-editions-box m1-scrollbar">
            
            <ul class="m1-editions-list">
                                            <li class="current">

                    <a href="https://insideevs.com">
                                        <span class="flags">
                                            <span class="edf edf-230"></span>
                                        </span>
                    <span class="label">
                                        InsideEVs: USA / Global                    </span>
                    </a>
                </li>
                                            <li>

                    <a href="https://insideevs.fr">
                                        <span class="flags">
                                            <span class="edf edf-72"></span>
                                            <span class="edf edf-21"></span>
                                            <span class="edf edf-211"></span>
                                            <span class="edf edf-145"></span>
                                            <span class="edf edf-128"></span>
                                        </span>
                    <span class="label">
                                        InsideEVs: France                    </span>
                    </a>
                </li>
                                            <li>

                    <a href="https://insideevs.it">
                                        <span class="flags">
                                            <span class="edf edf-106"></span>
                                        </span>
                    <span class="label">
                                        InsideEVs: Italy                    </span>
                    </a>
                </li>
                                            <li>

                    <a href="https://insideevs.uol.com.br">
                                        <span class="flags">
                                            <span class="edf edf-30"></span>
                                            <span class="edf edf-177"></span>
                                        </span>
                    <span class="label">
                                        InsideEVs: Brasil                    </span>
                    </a>
                </li>
                                            <li>

                    <a href="https://insideevs.ru">
                                        <span class="flags">
                                            <span class="edf edf-182"></span>
                                            <span class="edf edf-20"></span>
                                            <span class="edf edf-227"></span>
                                            <span class="edf edf-112"></span>
                                        </span>
                    <span class="label">
                                        InsideEVs: Russia                    </span>
                    </a>
                </li>
                                            <li>

                    <a href="https://insideevs.de">
                                        <span class="flags">
                                            <span class="edf edf-80"></span>
                                            <span class="edf edf-14"></span>
                                            <span class="edf edf-211"></span>
                                        </span>
                    <span class="label">
                                        InsideEVs:Deutschland                    </span>
                    </a>
                </li>
                                            <li>

                    <a href="https://insideevs.com.tr">
                                        <span class="flags">
                                            <span class="edf edf-222"></span>
                                        </span>
                    <span class="label">
                                        InsideEVs:Turkey                    </span>
                    </a>
                </li>
                            <li>
                                    </li>
            </ul>
            
        </div>


    
    </div>
    <div class="m1-drawer-overlay"></div>
</div>
<m1-check-availability-response-dialog
        user-data='{"email":"","zip":"20149","phone":"","firstName":"","lastName":""}'
        edition="ev_us"
        oem-url="/buy/new/lead/"
        vin-url="/buy/used/lead/"
></m1-check-availability-response-dialog>


    <div id="share_box_content_wrapper">
        <div slot="share-box" class="big-shareBox shareBox share-box-dropdown to-down"><div class="share-box-wrapper"><span class="shareBox-separator" data-value="share-list-1629307645" data-button onClick="" data-id="toggleBox" data-static> <span class="active"><span class="icon-plus">+</span></span><span class="passive"><span class="icon-plus">+</span></span></span><a href="https://insideevs.com/news/527462/rimac-nevera-tesla-plaid-race/" class="share-button share-button-gallery" rel="nofollow noopener"><span class="icon share-empty"></span></a><div class="share-list" data-button-target="share-list-1629307645"><ul><li class="facebook"><a data-button="" data-id="share" data-url="/connect/share/" data-name="network_id" target="_blank" rel="nofollow noopener" data-extra-params="id:'527462',type_id:'1'" data-value="1" data-share-network="Facebook" data-share-url="https://insideevs.com/news/527462/rimac-nevera-tesla-plaid-race/" data-width="600" data-height="600" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Finsideevs.com%2Fnews%2F527462%2Frimac-nevera-tesla-plaid-race%2F"><span class="social-bg icon facebook"></span><span class="name">Share on Facebook</span></a></li><li class="twitter"><a data-button="" data-id="share" data-url="/connect/share/" data-name="network_id" target="_blank" rel="nofollow noopener" data-extra-params="id:'527462',type_id:'1'" data-value="2" data-share-network="Twitter" data-share-url="https://insideevs.com/news/527462/rimac-nevera-tesla-plaid-race/" data-width="600" data-height="450" href="https://twitter.com/intent/tweet?url=https%3A%2F%2Finsideevs.com%2Fnews%2F527462%2Frimac-nevera-tesla-plaid-race%2F&text=Watch+Rimac+Nevera+Destroy+Tesla+Model+S+Plaid+In+Drag+Races&via=insideevs.com"><span class="social-bg icon twitter"></span><span class="name">Share on Twitter</span></a></li><li class="linkedin"><a data-button="" data-id="share" data-url="/connect/share/" data-name="network_id" target="_blank" rel="nofollow noopener" data-extra-params="id:'527462',type_id:'1'" data-value="3" data-share-network="LinkedIn" data-share-url="https://insideevs.com/news/527462/rimac-nevera-tesla-plaid-race/" data-width="600" data-height="600" href="https://www.linkedin.com/cws/share?url=https%3A%2F%2Finsideevs.com%2Fnews%2F527462%2Frimac-nevera-tesla-plaid-race%2F"><span class="social-bg icon linkedin"></span><span class="name">Share on LinkedIn</span></a></li><li class="flipboard"><a data-button="" data-id="share" data-url="/connect/share/" data-name="network_id" target="_blank" rel="nofollow noopener" data-extra-params="id:'527462',type_id:'1'" data-value="7" data-share-network="Flipboard" data-share-url="https://insideevs.com/news/527462/rimac-nevera-tesla-plaid-race/" data-width="600" data-height="600" href="https://share.flipboard.com/bookmarklet/popout?url=https%3A%2F%2Finsideevs.com%2Fnews%2F527462%2Frimac-nevera-tesla-plaid-race%2F&title=Watch+Rimac+Nevera+Destroy+Tesla+Model+S+Plaid+In+Drag+Races&v=2"><span class="social-bg icon flipboard"></span><span class="name">Share on Flipboard</span></a></li><li class="reddit"><a data-button="" data-id="share" data-url="/connect/share/" data-name="network_id" target="_blank" rel="nofollow noopener" data-extra-params="id:'527462',type_id:'1'" data-value="6" data-share-network="Reddit" data-share-url="https://insideevs.com/news/527462/rimac-nevera-tesla-plaid-race/" data-width="900" data-height="600" href="https://www.reddit.com/submit?url=https%3A%2F%2Finsideevs.com%2Fnews%2F527462%2Frimac-nevera-tesla-plaid-race%2F"><span class="social-bg icon reddit"></span><span class="name">Share on Reddit</span></a></li><li class="whatsapp"><a data-button="" data-id="share" data-url="/connect/share/" data-name="network_id" target="_blank" rel="nofollow noopener" data-extra-params="id:'527462',type_id:'1'" data-value="6" data-share-network="WhatsApp" data-share-url="https://insideevs.com/news/527462/rimac-nevera-tesla-plaid-race/" data-width="600" data-height="600" href="https://api.whatsapp.com/send?text=https%3A%2F%2Finsideevs.com%2Fnews%2F527462%2Frimac-nevera-tesla-plaid-race%2F"><span class="social-bg icon whatsapp"></span><span class="name">Share on WhatsApp</span></a></li><li class="mailto"><a data-button="" data-id="mailTo" target="_blank" rel="nofollow noopener" data-extra-params="id:'527462',type_id:'1'" data-share-url="https://insideevs.com/news/527462/rimac-nevera-tesla-plaid-race/" data-width="600" data-height="400" href="mailto:?body=https%3A%2F%2Finsideevs.com%2Fnews%2F527462%2Frimac-nevera-tesla-plaid-race%2F&subject=Watch%20Rimac%20Nevera%20Destroy%20Tesla%20Model%20S%20Plaid%20In%20Drag%20Races"><span class="social-bg icon mailto"></span><span class="name">Send to email</span></a></li></ul></div></div></div>    </div>


<!--<div class="adminInfoBoxx"></div>-->

<div class="m1-footer-messages"></div>

<script>
     window.gadsId = false;
</script>
<script>
    var m1FooterMessages = [];
    // m1FooterMessages.push({
    //     message: "This website uses cookies to ensure you get the best experience on our website. By closing this banner, scrolling this page you consent to the use of cookies. <a id='cookie_accept_link' data-id='footerMessageAccept' data-button='' href='/info/cookie-policy/'>More info.</a>",
    //     name: "cookie_accept"
    // });
    </script>

<script defer type="text/javascript" src="https://cdn.motor1.com/kp/static4ui/prod_v2_eks_251/design/build/jslangs/insideevs_en_US_555a609a617b1448cc0acdb0c1d8166c.js"></script>
<script defer type="text/javascript" src="https://cdn.motor1.com/kp/static4ui/prod_v2_eks_251/design/dist/js/1_39641646854d632eb710.js"></script><script defer type="text/javascript" src="https://cdn.motor1.com/kp/static4ui/prod_v2_eks_251/design/dist/js/66_39641646854d632eb710.js"></script><script defer type="text/javascript" src="https://cdn.motor1.com/kp/static4ui/prod_v2_eks_251/design/dist/js/0_39641646854d632eb710.js"></script><script defer type="text/javascript" src="https://cdn.motor1.com/kp/static4ui/prod_v2_eks_251/design/dist/js/2_39641646854d632eb710.js"></script><script defer type="text/javascript" src="https://cdn.motor1.com/kp/static4ui/prod_v2_eks_251/design/dist/js/3_39641646854d632eb710.js"></script><script defer type="text/javascript" src="https://cdn.motor1.com/kp/static4ui/prod_v2_eks_251/design/dist/js/4_39641646854d632eb710.js"></script><script defer type="text/javascript" src="https://cdn.motor1.com/kp/static4ui/prod_v2_eks_251/design/dist/js/5_39641646854d632eb710.js"></script><script defer type="text/javascript" src="https://cdn.motor1.com/kp/static4ui/prod_v2_eks_251/design/dist/js/14_39641646854d632eb710.js"></script>

        <script async src="https://console.adgrid.io/adgrid-build/ad-grid-insideevs-com.js"></script>

    
<script>
gtmDataLayer = [{
    'domain': 'insideevs.com',
    'currentEdition': 'ev_us',
    'currentEnv': 'production',
        'pageType': 'detail',
            'entityType': 'video',
            'make': 'Tesla',
            'model': 'Model S',
            'pageId': 'index_articles_detail',
            'entityAuthors': ["Mark Kane"],
            'pageUrl': 'http://insideevs.com:8080/news/527462/rimac-nevera-tesla-plaid-race/',
            'pageUrlCanonical': 'http://insideevs.com:8080/news/527462/rimac-nevera-tesla-plaid-race/',
            'pageLanguage': 'en',
            'entityCategories': ["Races and Chases"],
            'articleType': 'news',
                    'entityTitle': 'Watch Rimac Nevera Destroy Tesla Model S Plaid In Drag Races',
            'pageTitle': 'Watch Rimac Nevera Destroy Tesla Model S Plaid In Drag Races',
            'm1DataSign': '161bad47722873146cc9a43985e46069',
            'articleId': '527462',
            'tags': ["drag race","rimac","dragtimes","tesla drag race","plaid","rimac nevera"],
                'bodyStyles': ["Sedan"],
        'sessionId': '9dc93046580de0ce8a068bfc9c8ca883',
    'msntClientId': '91'
}];
</script>
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
            new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
        j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
        'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
    })(window,document,'script','gtmDataLayer','GTM-TJCLXGW');</script>

    <script>
        (function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
                new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
            j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
            'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
        })(window,document,'script','gtmDataLayer', 'GTM-M4M4LBT');
    </script>



<!-- <script>
    window.onload = function() {

        if ((typeof $.cookie('PHPSESSID') === 'undefined') || (typeof $.cookie('is_logged_in') !== 'undefined')){
            $.get('/layout-auth-data/', function(data) {
                $('.m1-user-side-label').html(data);

                var loginButton = document.getElementsByClassName('login')[0];
                var registerButton = document.getElementsByClassName('register')[0];

                if (msnt) {
                    if (loginButton) {
                        loginButton.addEventListener('click', function(event){
                            event.preventDefault();
                            event.stopPropagation();
                            window.msnt.register = false;
                            msnt.openIframeWindow();
                        });
                    }
                    if (registerButton) {
                        registerButton.addEventListener('click', function(event){
                        event.preventDefault();
                        event.stopPropagation();
                        window.msnt.register = true;
                        msnt.openIframeWindow();
                        });
                    }
                }
            });

            var loginButton = document.getElementsByClassName('login')[0];
            var registerButton = document.getElementsByClassName('register')[0];

            if (msnt) {
                if (loginButton) {
                    loginButton.addEventListener('click', function(event){
                        event.preventDefault();
                        event.stopPropagation();
                        window.msnt.register = false;
                        msnt.openIframeWindow();
                    });
                }

                if (registerButton) {
                    registerButton.addEventListener('click', function(event){
                        event.preventDefault();
                        event.stopPropagation();
                        window.msnt.register = true;
                        msnt.openIframeWindow();
                    });
                }
            }
        }
    }

</script> -->
</body>
</html>
