<!DOCTYPE html><html prefix="og: http://ogp.me/ns#" lang="en">
<head>
    <meta charset="utf-8">
    <title>Rivian&#039;s Electric Trucks Will Charge Faster Than All Production EVs</title>

    <link rel="icon" type="image/png" sizes="32x32" href="https://cdn.motor1.com/images/static/insideevs/favicon-32.png">
    <link rel="icon" type="image/png" sizes="96x96" href="https://cdn.motor1.com/images/static/insideevs/favicon-96.png">
    <link rel="icon" type="image/png" sizes="128x128" href="https://cdn.motor1.com/images/static/insideevs/favicon-128.png">
    <link rel="icon" type="image/png" sizes="195x195" href="https://cdn.motor1.com/images/static/insideevs/favicon-195.png">
    <link rel="icon" type="image/png" sizes="196x196" href="https://cdn.motor1.com/images/static/insideevs/favicon-196.png">
    <link rel="icon" type="image/png" sizes="228x228" href="https://cdn.motor1.com/images/static/insideevs/favicon-228.png">
    <link rel="apple-touch-icon-precomposed" href="https://cdn.motor1.com/images/static/insideevs/favicon-57.png">
    <link rel="apple-touch-icon" sizes="114x114" href="https://cdn.motor1.com/images/static/insideevs/favicon-114.png">
    <link rel="apple-touch-icon" sizes="72x72" href="https://cdn.motor1.com/images/static/insideevs/favicon-72.png">
    <link rel="apple-touch-icon" sizes="144x144" href="https://cdn.motor1.com/images/static/insideevs/favicon-144.png">
    <link rel="apple-touch-icon" sizes="60x60" href="https://cdn.motor1.com/images/static/insideevs/favicon-60.png">
    <link rel="apple-touch-icon" sizes="120x120" href="https://cdn.motor1.com/images/static/insideevs/favicon-120.png">
    <link rel="apple-touch-icon" sizes="76x76" href="https://cdn.motor1.com/images/static/insideevs/favicon-76.png">
    <link rel="apple-touch-icon" sizes="152x152" href="https://cdn.motor1.com/images/static/insideevs/favicon-152.png">
    <link rel="apple-touch-icon" sizes="180x180" href="https://cdn.motor1.com/images/static/insideevs/favicon-180.png">

    <meta name="msapplication-square128x128logo" content="https://cdn.motor1.com/images/static/insideevs/smalltile.png"/>
    <meta name="msapplication-square270x270logo" content="https://cdn.motor1.com/images/static/insideevs/mediumtile.png"/>
    <meta name="msapplication-square580x580logo" content="https://cdn.motor1.com/images/static/insideevs/largetile.png"/>

    <link rel="shortcut icon" type="image/x-icon" href="/favicon.ico"/>
            <link href="https://fonts.googleapis.com/css?family=Open+Sans:300,400,600,700" rel="stylesheet">
    
    

        <script>
        window.polymerLocale = 'en-US';
        window.polymerLocalePath = 'https://cdn.motor1.com/kp/static4ui/prod_v2_eks_131/polymer2/locales1591275642/en-US.json';
        var jsVars = {"services":{"brealtime":{"load":0,"id":"12851701"}},"ads":{"dfp":{"id":"6122441"}},"ui":{"auto_infinite_scroll":true}};    </script>

    
    <link title="Latest news" type="application/rss+xml" rel="alternate" href="/rss/news/all/"/>
    <link title="Latest videos" type="application/rss+xml" rel="alternate" href="/rss/videos/all/"/>
        <meta name="description" content="Rivian&#039;s 300 kW charging claim tops the Porsche Taycan and Model 3 Long Range. It&#039;s likely possible based on patent information for voltage switching tech.">
<meta property="og:title" content="Rivian&#039;s Electric Trucks Will Charge Faster Than All Production EVs">
<meta property="og:type" content="article">
<meta property="og:url" content="https://insideevs.com/news/427197/rivian-electric-truck-patent-charging-rate/">
<meta property="og:image" content="https://cdn.motor1.com/images/mgl/6yozG/s1/rivian-r1t-silver.jpg">
<meta property="og:image:url" content="https://cdn.motor1.com/images/mgl/6yozG/s1/rivian-r1t-silver.jpg">
<meta property="og:image:secure_url" content="https://cdn.motor1.com/images/mgl/6yozG/s1/rivian-r1t-silver.jpg">
<meta property="og:image:type" content="image/jpeg">
<meta property="og:image:width" content="1920">
<meta property="og:image:height" content="1080">
<meta property="og:image:alt" content="Rivian&#039;s Electric Trucks Will Charge Faster Than All Production EVs:  Rivian R1S, Charging">
<meta property="og:description" content="Rivian&#039;s 300 kW charging claim tops the Porsche Taycan and Model 3 Long Range. It&#039;s likely possible based on patent information for voltage switching tech.">
<meta property="og:site_name" content="InsideEVs">
<meta property="fb:admins" content="100001157785488">
<meta property="fb:app_id" content="984245018262500">
<meta property="fb:pages" content="357684877628739">
<meta property="twitter:card" content="summary_large_image">
<meta property="twitter:site" content="InsideEVs">
<meta property="twitter:title" content="Rivian&#039;s Electric Trucks Will Charge Faster Than All Production EVs">
<meta property="twitter:description" content="A patent shows Rivian&#039;s unique battery and charging situation that will allow 300 kW charging.">
<meta property="twitter:image" content="https://cdn.motor1.com/images/mgl/6yozG/s3/rivian-r1t-silver.jpg">
<meta property="robots" content="max-snippet:500, max-image-preview:large">
<meta name="speakable-description" content="We say time and time again that range and charging are still the primary roadblocks to EV adoption, in addition to the price of the vehicles. Rivian&#039;s technology could work to improve all three.">
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<meta http-equiv="X-UA-Compatible" content="IE=edge"><link href="https://insideevs.com/news/427197/rivian-electric-truck-patent-charging-rate/" hreflang="x-default" rel="alternate">
<link href="https://insideevs.com/news/427197/rivian-electric-truck-patent-charging-rate/" rel="canonical">
<link href="https://insideevs.com/news/427197/rivian-electric-truck-patent-charging-rate/amp/" rel="amphtml">    <link rel="stylesheet" type="text/css" href="https://cdn.motor1.com/kp/static4ui/prod_v2_eks_131/design/dist/css/0_8e7130e21e03e856c8a8.css"><link rel="stylesheet" type="text/css" href="https://cdn.motor1.com/kp/static4ui/prod_v2_eks_131/design/dist/css/1_8e7130e21e03e856c8a8.css"><link rel="stylesheet" type="text/css" href="https://cdn.motor1.com/kp/static4ui/prod_v2_eks_131/design/dist/css/3_8e7130e21e03e856c8a8.css"><link rel="stylesheet" type="text/css" href="https://cdn.motor1.com/kp/static4ui/prod_v2_eks_131/design/dist/css/4_8e7130e21e03e856c8a8.css"><link rel="stylesheet" type="text/css" href="https://cdn.motor1.com/kp/static4ui/prod_v2_eks_131/design/dist/css/13_8e7130e21e03e856c8a8.css"><link rel="stylesheet" type="text/css" href="https://cdn.motor1.com/kp/static4ui/prod_v2_eks_131/design/dist/css/21_8e7130e21e03e856c8a8.css"><link rel="stylesheet" type="text/css" href="https://cdn.motor1.com/kp/static4ui/prod_v2_eks_131/design/dist/css/index_articles_detail_8e7130e21e03e856c8a8.css">            <link rel="stylesheet" type="text/css" href="https://cdn.motor1.com/kp/static4ui/prod_v2_eks_131/ev-design/dist/css/0_edd88ecdbeba3e62cded.css">    
    <script>
        window.isAuthorized = 0    </script>


    

        


</head>
<body         class="nojs not-touch
            m1-fullwidth-layout            bgWhite lightHeader hangingHeader                                                            "
        data-spotim-id="" data-edtn="ev_us"
        data-track-url="" >

<div data-role="page" id="page_index_articles_detail" class="root">

    <div id="layout_header_spacer"></div>
<div class="m1-header-main">
    <div class="m1-header-main-box">
        <div class="m1-header-main-box-wrapper">
            <div class="box-item-left">
                <div class="m1-hamburger-button" data-hide-scroll="m1-left-side-box" data-close-delay="0.5" data-delay="0.01" onclick="" data-button data-id="toggleBox" data-value="mainMenu" data-clear="2" data-multi>
                    <span></span>
                    <span></span>
                    <span></span>
                </div>

            </div>
            <div class="wrapper-box-item-center">
                <div class="box-item-center">
                    <a class="m1-header-logo" href="/" title="Home">
                        <img class="logo_placeholder" src="data:image/png;base64,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" alt="logo">
                    </a>
                </div>
            </div>
            <div class="m1-header-main-box-wrapper-sub" style="position: relative;">
                <div class="box-item-pre-left">
                    <ul class="m1-navigation-main print-hide">
                        <li class="grand top left mobile">
            <a href="/news/"  >
                                    News                            </a>
        </li>
                    <li class="grand top left">
            <a href="/reviews/"  >
                                    Reviews                            </a>
        </li>
                    <li class="grand left">
            <a href="/features/"  >
                                    Features                            </a>
        </li>
                    <li class="mobile">
            <a href="/tesla/"  >
                                    Tesla                            </a>
        </li>
                    <li class="top left">
            <a href="/reviews/344001/compare-evs/"  >
                                    Compare EVs                            </a>
        </li>
                    <li class="left">
            <a href="/news/344002/charger-guide/"  >
                                    Charger Guide                            </a>
        </li>
                    <li class="left">
            <a href="/features/category/buying-advice/"  >
                                    Buying Advice                            </a>
        </li>
                    <li class="left">
            <a href="/news/343998/monthly-plug-in-ev-sales-scorecard/"  >
                                    EV Sales Scorecard                            </a>
        </li>
                    <li class="mobile">
            <a href="/news/343998/monthly-plug-in-ev-sales-scorecard/"  >
                                    EV Sales                            </a>
        </li>
                    <li class="left">
            <a href="/news/?sc=1"  >
                                    Categories                            </a>
        </li>
                    <li class="left">
            <a href="/makes/"  >
                                    Makes                            </a>
        </li>
                    <li class="left">
            <a href="/body-styles/"  >
                                    Body Style                            </a>
        </li>
                    <li class="left top _blank">
            <a href="https://insideevsforum.com/community/index.php"  target = "_blank">
                                    Forum                            </a>
        </li>
                    <li class="left _blank">
            <a href="https://www.myev.com/cars-for-sale"  target = "_blank">
                                    Buy                            </a>
        </li>
                    <li class="podcast ico left">
            <a href="https://insideevs.com/features/category/podcast/"  >
                                    Podcast                            </a>
        </li>
                    <li class="photos ico left">
            <a href="/photos/"  >
                                    Photos                            </a>
        </li>
                    <li class="videos ico left">
            <a href="/videos/"  >
                                    Videos                            </a>
        </li>
                    <li class="top plugin-sale">
            <a href="/news/343998/monthly-plug-in-ev-sales-scorecard/"  >
                                    Ev Sales Scorecard                            </a>
        </li>
    </ul>                </div>
                                    <!-- <div class="wrapper-plugin-sale">
                        <div class="top plugin-sale">
                            <a href="https://insideevs.com/monthly-plug-in-sales-scorecard/">Ev Sales Scorecard</a>
                        </div>
                    </div> -->
                                                    <div class="m1-search-form-button-wrapper">
                        <button class="m1-search-form-button-animate icon-search"
                                onclick
                                data-button
                                data-id="toggleBox"
                                data-clear="1"
                                data-value="searchBox"
                                data-multi
                                type="submit">
                        </button>
                        <div class="m1-search-panel">
                            <form action="/search/" class="m1-search-form" method="GET" id="header_search_form" data-native="0" novalidate="novalidate">
                                <input class="m1-search-panel-input m1-search-form-text" id="search_input" type="text" value="" name="q" placeholder="Search" autocomplete="off">
                                <button class="m1-search-panel-button m1-search-form-button-animate icon-search " type="submit">
                                </button>
                                <button onclick=""
                                        data-button
                                        data-id="toggleBox"
                                        data-value="searchBox"
                                        data-clear="1"
                                        data-toggle="1"
                                        data-multi
                                        class="m1-search-panel-button m1-drawer-close-button">
                                </button>
                            </form>
                        </div>
                    </div>
                            </div>

                           <div class="box-item-right">
                    <div class="m1-editions-switcher-m" data-hide-scroll="m1-scrollbar" data-close-delay="0.5"  data-delay="0.01" onclick="" data-button data-id="toggleBox" data-value="editionsMenu" data-clear="2" data-multi>
                                                <span class="edf edf-230"></span>
                                            </div>
                    <div class="m1-editions-switcher" data-hide-scroll="m1-scrollbar" data-close-delay="0.5" data-delay="0.01" onclick="" data-button data-id="toggleBox" data-value="editionsMenu" data-clear="2" data-multi>
                                                <span class="edf edf-230"></span>
                                                <span class="title">USA / Global</span>
                    </div>
                </div>
                    </div>
    </div>
</div>
<div class="m1-header-ad top-banner-placeholder">
    <div class="m1-gapb-topside"><div class="m1-apb mleaderboard"><div class="ap" data-place="10" style="width:320px;min-height:1px;" data-dfp-code="EV/ev_us/Mobile_Leaderboard" data-sizes="320x1,320x50,320x100" data-width="320" data-height="1" data-dfp-attrs='{"msnt_env":"production","m1_banner_place":"top-banners","m1_edition":"ev_us","m1_article_type":"news","m1_page_content_id":427197,"m1_page_type":"detail","m1_page_content_type":"article","m1_makes":["rivian"],"m1_models":["r1s","r1t"],"m1_categories":["battery-tech","charging"],"m1_tags":["electric pickup truck"],"m1_body_types":["truck","truck"],"m1_model_segments":["",""],"m1_banner_position":"top","m1_banner_position_view":"above-the-fold"}'></div></div><div class="m1-apb leaderboard"><div class="ap" data-place="1" style="width:728px;min-height:1px;" data-dfp-code="EV/ev_us/Leaderboard" data-sizes="728x1,1x1,728x90" data-width="728" data-height="1" data-dfp-attrs='{"msnt_env":"production","m1_banner_place":"top-banners","m1_edition":"ev_us","m1_article_type":"news","m1_page_content_id":427197,"m1_page_type":"detail","m1_page_content_type":"article","m1_makes":["rivian"],"m1_models":["r1s","r1t"],"m1_categories":["battery-tech","charging"],"m1_tags":["electric pickup truck"],"m1_body_types":["truck","truck"],"m1_model_segments":["",""],"m1_banner_position":"top","m1_banner_position_view":"above-the-fold"}'></div></div><div class="m1-apb super"><div class="ap" data-place="6" style="width:970px;min-height:1px;" data-dfp-code="EV/ev_us/Super" data-sizes="970x1,1x1,970x90,970x250,980x250" data-width="970" data-height="1" data-dfp-attrs='{"msnt_env":"production","m1_banner_place":"top-banners","m1_edition":"ev_us","m1_article_type":"news","m1_page_content_id":427197,"m1_page_type":"detail","m1_page_content_type":"article","m1_makes":["rivian"],"m1_models":["r1s","r1t"],"m1_categories":["battery-tech","charging"],"m1_tags":["electric pickup truck"],"m1_body_types":["truck","truck"],"m1_model_segments":["",""],"m1_banner_position":"top","m1_banner_position_view":"above-the-fold"}'></div></div></div></div>    <div class="pageAdSkin" id="page_skin_top">
        <div class="adSizer"><img alt="" src="data:image/gif;base64,R0lGODlhAQABAIAAAP///wAAACH5BAEAAAAALAAAAAABAAEAAAICRAEAOw=="></div>
        <a class="pageAdSkinUrl"></a>
    </div>
    
<script type="application/ld+json">
    {"@context":"http:\/\/schema.org","@type":"NewsArticle","headline":"Rivian's Electric Trucks Will Charge Faster Than All Production EVs","name":"Rivian's Electric Trucks Will Charge Faster Than All Production EVs","description":"A patent shows Rivian's unique battery and charging situation that will allow 300 kW charging.","author":{"@type":"Person","name":"Steven Loveday"},"url":"https:\/\/insideevs.com\/news\/427197\/rivian-electric-truck-patent-charging-rate\/","sameAs":["https:\/\/www.facebook.com\/InsideeVs\/","https:\/\/twitter.com\/InsideEVs","https:\/\/www.youtube.com\/channel\/UCw4aq8JMlCMBMOQ0PliCkIQ?sub_confirmation=1","https:\/\/flipboard.com\/@InsideEVs"],"datePublished":"2020-06-05T13:13:08+00:00","dateModified":"2020-06-05T13:13:08+00:00","publisher":{"@type":"Organization","name":"InsideEVs","logo":{"@type":"ImageObject","url":"https:\/\/insideevs.com\/logo.jpg","width":"325","height":"60"}},"image":{"@type":"ImageObject","url":"https:\/\/cdn.motor1.com\/images\/mgl\/6yozG\/s1\/rivian-r1t-silver.jpg","width":"1920","height":"1080"},"mainEntityOfPage":"https:\/\/insideevs.com\/news\/427197\/rivian-electric-truck-patent-charging-rate\/","wordCount":"321"}</script>


    <script type="application/ld+json">
        {"@context":"https:\/\/schema.org\/","@type":"WebPage","name":"Rivian's Electric Trucks Will Charge Faster Than All Production EVs","speakable":{"@type":"SpeakableSpecification","xpath":["\/html\/head\/title","\/html\/head\/meta[@name='speakable-description']\/@content"]},"url":"https:\/\/insideevs.com\/news\/427197\/rivian-electric-truck-patent-charging-rate\/"}    </script>

        <script type="application/ld+json">
        {"@context":"https:\/\/schema.org","@type":"BreadcrumbList","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https:\/\/insideevs.com\/"},{"@type":"ListItem","position":2,"name":"Rivian","item":"https:\/\/insideevs.com\/rivian\/"},{"@type":"ListItem","position":3,"name":"R1S","item":"https:\/\/insideevs.com\/rivian\/r1s\/"},{"@type":"ListItem","position":4,"name":"News","item":"https:\/\/insideevs.com\/rivian\/r1s\/news\/"},{"@type":"ListItem","position":5,"name":"Battery Tech","item":"https:\/\/insideevs.com\/rivian\/r1s\/news\/category\/battery-tech\/"}]}    </script>


    <div class="pre-center breadcrumbs-area ">
                <div slot="breadcrumbs" class="breadcrumbs">
        <a href="/">Home</a><span class="sep"></span><a href="/rivian/">Rivian</a><span class="sep"></span><a href="/rivian/r1s/">R1S</a><span class="sep"></span><a href="/rivian/r1s/news/">News</a><span class="sep"></span><a href="/rivian/r1s/news/category/battery-tech/">Battery Tech</a>    </div>
        <h1 class="m1-article-title">Rivian's Electric Trucks Will Charge Faster Than All Production EVs</h1>
    </div>
            <div class="pre-center">
            <div class="articleHeader">
                <div class="box-center">
                    <div class="originalImage">
                        <img src="https://cdn.motor1.com/images/mgl/6yozG/s4/rivian-r1t-silver.jpg" alt="Rivian's Electric Trucks Will Charge Faster Than All Production EVs" />
                    </div>
                    <div id="article_poster" class="articlePoster scrollTieBox">
                                                    <style type="text/css">
@media only screen{#article_poster{background-image:url(https://cdn.motor1.com/images/mgl/6yozG/s5/rivian-r1t-silver.jpg);}}
@media only screen and (min-width : 445px){#article_poster{background-image:url(https://cdn.motor1.com/images/mgl/6yozG/s4/rivian-r1t-silver.jpg);}}
@media only screen and (min-width : 1024px){#article_poster{background-image:url(https://cdn.motor1.com/images/mgl/6yozG/s3/rivian-r1t-silver.jpg);}}
@media only screen and (min-width : 1280px){#article_poster{background-image:url(https://cdn.motor1.com/images/mgl/6yozG/s2/rivian-r1t-silver.jpg);}}
@media only screen and (min-width : 1440px){#article_poster{background-image:url(https://cdn.motor1.com/images/mgl/6yozG/s1/rivian-r1t-silver.jpg);}}


@media only screen and (-webkit-min-device-pixel-ratio : 2),
       only screen and (min--moz-device-pixel-ratio : 2),
       only screen and (min-device-pixel-ratio : 2){
           #article_poster{
               background-image:url(https://cdn.motor1.com/images/mgl/6yozG/s1/rivian-r1t-silver.jpg);
            }
        }

@media only screen and (min-width : 445px) and (-webkit-min-device-pixel-ratio : 2),
       only screen and (min-width : 445px) and (min--moz-device-pixel-ratio : 2),
       only screen and (min-width : 445px) and (min-device-pixel-ratio : 2){
           #article_poster{
               background-image:url(https://cdn.motor1.com/images/mgl/6yozG/s3/rivian-r1t-silver.jpg);
            }
        }

@media only screen and (min-width : 1024px) and (-webkit-min-device-pixel-ratio : 2),
       only screen and (min-width : 1024px) and (min--moz-device-pixel-ratio : 2),
       only screen and (min-width : 1024px) and (min-device-pixel-ratio : 2){
           #article_poster{
               background-image:url(https://cdn.motor1.com/images/mgl/6yozG/s1/rivian-r1t-silver.jpg);
            }
        }
</style>                                                
<img class="sizer" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAABAAAAAJCAYAAAA7KqwyAAAAGXRFWHRTb2Z0d2FyZQBBZG9iZSBJbWFnZVJlYWR5ccllPAAAABpJREFUeNpi/P//PwMlgImBQjBqwLAwACDAAOVfAw9/ZDvcAAAAAElFTkSuQmCC" alt=""/>                    </div>
                </div>
                <div class="articleTitle">
                    <div class="box-center">
                        <div class="pre-center">
                                                    </div>
                    </div>
                </div>
            </div>
        </div>
    

<div class="pre-center padding h-entry  b-padding-skin pre-center-feature" id="post_box">
    <div data-bubbles="keyword" data-url="/news/store-keywords/" data-name="id"></div>
    <div class="content-area  " id="article_box" >
                    <span class="summary p-name" style="display: none;">Rivian's Electric Trucks Will Charge Faster Than All Production EVs</span>


            <span style="display: none;" class="type">product</span>

                    <span style="display: none;" class="dt-published dtreviewed">2020-06-05 13:13:08</span>

                    <a style="display: none" rel="bookmark" href="https://insideevs.com/news/427197/rivian-electric-truck-patent-charging-rate/" class="permalink u-url">https://insideevs.com/news/427197/rivian-electric-truck-patent-charging-rate/</a>

                <span class="p-item item vcard" style="display: none;">
            <span class="fn">
                                                            Rivian R1S                                            Rivian R1T                                                </span>
        </span>

                <span class="p-category" style="display: none;">
                                                                                                                                                                                                        
            Battery Tech, Charging, electric pickup truck        </span>

        <div class="content-area-box">
                            <div class="postTopInfo ">
                                            <div class="postDate">
                                <span class="date" data-time="1591348388">
                    <a href="/2020/06/05/">
                Jun 05, 2020            </a>
                <span class="small">at</span>
                    9:13am            </span>
                        </div>
                                        
                                            <div class="shareTrendingBox">
                                                                                                <script id="dsq-count-scr" src="//insideevscom.disqus.com/count.js" async></script>                                    <a title="Add a comment" href="/news/427197/rivian-electric-truck-patent-charging-rate/#comments" class="disqus-comment-count" data-disqus-identifier="en-article-427197" data-disqus-url="/news/427197/rivian-electric-truck-patent-charging-rate/"></a>                                                                                                                    <div slot="share-box" class="big-shareBox shareBox share-box-dropdown to-down"><div class="share-box-wrapper"><span class="shareBox-separator" data-value="share-list-1591372928" data-button onClick="" data-id="toggleBox" data-static> <span class="active"><span class="icon-plus">+</span></span><span class="passive"><span class="icon-plus">+</span></span></span><a href="https://insideevs.com/news/427197/rivian-electric-truck-patent-charging-rate/" class="share-button"><span class="name">Share</span><span class="icon share-empty"></span></a><div class="share-list" data-button-target="share-list-1591372928"><ul><li class="facebook"><a data-button="" data-id="share" data-url="/connect/share/" data-name="network_id" target="_blank" data-extra-params="id:'427197',type_id:'1'" data-value="1" data-share-network="Facebook" data-share-url="https://insideevs.com/news/427197/rivian-electric-truck-patent-charging-rate/" data-width="600" data-height="600" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Finsideevs.com%2Fnews%2F427197%2Frivian-electric-truck-patent-charging-rate%2F"><span class="social-bg icon facebook"></span><span class="name">Share on Facebook</span></a></li><li class="twitter"><a data-button="" data-id="share" data-url="/connect/share/" data-name="network_id" target="_blank" data-extra-params="id:'427197',type_id:'1'" data-value="2" data-share-network="Twitter" data-share-url="https://insideevs.com/news/427197/rivian-electric-truck-patent-charging-rate/" data-width="600" data-height="450" href="https://twitter.com/intent/tweet?url=https%3A%2F%2Finsideevs.com%2Fnews%2F427197%2Frivian-electric-truck-patent-charging-rate%2F&text=Rivian%27s+Electric+Trucks+Will+Charge+Faster+Than+All+Production+EVs&via=insideevs.com"><span class="social-bg icon twitter"></span><span class="name">Share on Twitter</span></a></li><li class="linkedin"><a data-button="" data-id="share" data-url="/connect/share/" data-name="network_id" target="_blank" data-extra-params="id:'427197',type_id:'1'" data-value="3" data-share-network="LinkedIn" data-share-url="https://insideevs.com/news/427197/rivian-electric-truck-patent-charging-rate/" data-width="600" data-height="600" href="https://www.linkedin.com/cws/share?url=https%3A%2F%2Finsideevs.com%2Fnews%2F427197%2Frivian-electric-truck-patent-charging-rate%2F"><span class="social-bg icon linkedin"></span><span class="name">Share on LinkedIn</span></a></li><li class="flipboard"><a data-button="" data-id="share" data-url="/connect/share/" data-name="network_id" target="_blank" data-extra-params="id:'427197',type_id:'1'" data-value="7" data-share-network="Flipboard" data-share-url="https://insideevs.com/news/427197/rivian-electric-truck-patent-charging-rate/" data-width="600" data-height="600" href="https://share.flipboard.com/bookmarklet/popout?url=https%3A%2F%2Finsideevs.com%2Fnews%2F427197%2Frivian-electric-truck-patent-charging-rate%2F&title=Rivian%27s+Electric+Trucks+Will+Charge+Faster+Than+All+Production+EVs&v=2"><span class="social-bg icon flipboard"></span><span class="name">Share on Flipboard</span></a></li><li class="reddit"><a data-button="" data-id="share" data-url="/connect/share/" data-name="network_id" target="_blank" data-extra-params="id:'427197',type_id:'1'" data-value="6" data-share-network="Reddit" data-share-url="https://insideevs.com/news/427197/rivian-electric-truck-patent-charging-rate/" data-width="900" data-height="600" href="https://www.reddit.com/submit?url=https%3A%2F%2Finsideevs.com%2Fnews%2F427197%2Frivian-electric-truck-patent-charging-rate%2F"><span class="social-bg icon reddit"></span><span class="name">Share on Reddit</span></a></li><li class="whatsapp"><a data-button="" data-id="share" data-url="/connect/share/" data-name="network_id" target="_blank" data-extra-params="id:'427197',type_id:'1'" data-value="6" data-share-network="WhatsApp" data-share-url="https://insideevs.com/news/427197/rivian-electric-truck-patent-charging-rate/" data-width="600" data-height="600" href="https://api.whatsapp.com/send?text=https%3A%2F%2Finsideevs.com%2Fnews%2F427197%2Frivian-electric-truck-patent-charging-rate%2F"><span class="social-bg icon whatsapp"></span><span class="name">Share on WhatsApp</span></a></li><li class="mailto"><a data-button="" data-id="mailTo" target="_blank" data-extra-params="id:'427197',type_id:'1'" data-share-url="https://insideevs.com/news/427197/rivian-electric-truck-patent-charging-rate/" data-width="600" data-height="400" href="mailto:?body=https%3A%2F%2Finsideevs.com%2Fnews%2F427197%2Frivian-electric-truck-patent-charging-rate%2F&subject=Rivian%27s%20Electric%20Trucks%20Will%20Charge%20Faster%20Than%20All%20Production%20EVs"><span class="social-bg icon mailto"></span><span class="name">Send to email</span></a></li></ul></div></div></div>                        </div>
                    
                        <div class="postAuthorBox withAvatar" xmlns="http://www.w3.org/1999/xhtml">
                    <div class="postAuthorThumb">
                <a class="userRThumb" href="/info/team/steven-loveday/">
                    <img src="https://cdn.motor1.com/images/atr/z37/s4/steven-loveday.jpg" alt="Steven Loveday" />
                </a>
            </div>
                <div class="postAuthorInfo">
            <div class="postAuthor">
                <span class="name">
                    <span class="label">By</span>:
                                            <a class="author h-card reviewer p-author vcard url fn" content="Steven Loveday" href="/info/team/steven-loveday/">Steven Loveday</a>
                                    </span>
            </div>
                                            </div>
    </div>
                    <div class="clear"></div>

                </div>

            <div class="postContent content-wrapper">

                                    <h2 class="preview">
                        A patent shows Rivian's unique battery and charging situation that will allow 300 kW charging.                    </h2>
                                                <div class="postBody description e-content">
                                <p>A few months back, <a href="https://insideevs.com/tag/electric-pickup-truck/" data-inline-widget="internal-links" data-type-id="7" data-params="%7B%22tag%22%3A%22electric%20pickup%20truck%22%2C%22originalTitle%22%3A%22electric%20pickup%20truck%22%2C%22alias%22%3A%22electric-pickup-truck%22%7D">electric pickup truck</a> startup <a href="https://insideevs.com/rivian/" data-inline-widget="internal-links" data-type-id="2" data-params="%7B%22alias%22%3A%22rivian%22%7D">Rivian</a> Automotive filed a <a href="https://pdfaiw.uspto.gov/.aiw?PageNum=0&amp;docid=20190126761&amp;IDKey=14BFA1623261&amp;HomeUrl=http%3A%2F%2Fappft.uspto.gov%2Fnetacgi%2Fnph-Parser%3FSect1%3DPTO1%252526Sect2%3DHITOFF%252526d%3DPG01%252526p%3D1%252526u%3D%2525252Fnetahtml%2525252FPTO%2525252Fsrchnum.html%252526r%3D1%252526f%3DG%252526l%3D50%252526s1%3D%2525252220190126761%25252522.PGNR.%252526OS%3DDN%2F20190126761%252526RS%3DDN%2F20190126761" target="_blank" rel="nofollow noopener">patent application entitled 'Configurable Battery Pack For Fast Charge.'</a> Essentially, its voltage switching mechanism allows 800V charging on a 400V battery pack <span style="font-size: 16px; font-family: var(--main-font-family);">(or 900V on a 450V, etc). The tech can also handle a battery module fault without disconnecting the load.</span></p><div class="apInarticleSmallRes"><div class="ap" data-place="25" style="width:300px;min-height:1px;" data-dfp-code="EV/ev_us/Rectangle" data-sizes="300x1,300x250" data-width="300" data-height="1" data-dfp-attrs='{"lazy":1,"msnt_env":"production","m1_banner_place":"rectangle_first","m1_edition":"ev_us","m1_article_type":"news","m1_page_content_id":427197,"m1_page_type":"detail","m1_page_content_type":"article","m1_makes":["rivian"],"m1_models":["r1s","r1t"],"m1_categories":["battery-tech","charging"],"m1_tags":["electric pickup truck"],"m1_body_types":["truck","truck"],"m1_model_segments":["",""],"m1_banner_position":"first-inarticle-small-res"}'></div></div>
<p><span style="font-size: 16px; font-family: var(--main-font-family);">If Rivian is able to bring this tech to market, it will speed up the electric vehicle <a href="https://insideevs.com/news/category/charging/" data-inline-widget="internal-links" data-type-id="8" data-params="%7B%22section_route%22%3A%22news%22%2C%22alias%22%3A%22charging%22%7D">charging</a> process and make EVs less expensive. Rivian doesn't officially talk about patents. We do know its vehicles – the <a href="https://insideevs.com/rivian/r1t/" data-inline-widget="internal-links" data-type-id="1" data-params="%7B%22make_alias%22%3A%22rivian%22%2C%22alias%22%3A%22r1t%22%7D">R1T</a> pickup truck and <a href="https://insideevs.com/rivian/r1s/" data-inline-widget="internal-links" data-type-id="1" data-params="%7B%22make_alias%22%3A%22rivian%22%2C%22alias%22%3A%22r1s%22%7D">R1S</a> three-row SUV – will have a maximum range of 400 miles using a 180 kWh <a href="https://insideevs.com/news/category/battery-tech/" data-inline-widget="internal-links" data-type-id="8" data-params="%7B%22section_route%22%3A%22news%22%2C%22alias%22%3A%22battery-tech%22%7D">battery</a> pack. Rivian previously said its vehicles could add about 200 miles in 30 minutes via fast-charging stations at up to 160 kW.</span></p>
<section class="relatedContent-new" contenteditable="false" draggable="true" data-widget="related-content" data-widget-size="content" data-params="%7B%22type_id%22%3A0%2C%22title_id%22%3A%22%22%2C%22items%22%3A%5B%7B%22article_edition_id%22%3A%22426546%22%2C%22title%22%3A%22Rivian%20Hires%20Former%20Tesla%20Employees%20To%20Deploy%20Its%20Public%20Fast-Chargers%22%2C%22alias%22%3A%22rivian-adventure-charging-network-tesla-employees%22%2C%22section%22%3A%221%22%2C%22is_checked%22%3Atrue%2C%22is_video%22%3A%220%22%2C%22images%22%3A%7B%22s5%22%3A%22https%3A%2F%2Fcdn.motor1.com%2Fimages%2Fmgl%2Fy04gb%2Fs5%2Frivian-r1t-white-dirt.jpg%22%7D%7D%2C%7B%22article_edition_id%22%3A%22426033%22%2C%22title%22%3A%22Is%20Rivian%20Preparing%20To%20Offer%20Its%20Own%20Insurance%20Policy%3F%22%2C%22alias%22%3A%22rivian-preparing-own-insurance-policy%22%2C%22section%22%3A%221%22%2C%22is_checked%22%3Atrue%2C%22is_video%22%3A%220%22%2C%22images%22%3A%7B%22s5%22%3A%22https%3A%2F%2Fcdn.motor1.com%2Fimages%2Fmgl%2FlZxOW%2Fs5%2Frivian-episode-one-the-climb.jpg%22%7D%7D%2C%7B%22article_edition_id%22%3A%22425396%22%2C%22title%22%3A%22Rivian%20Has%20Reopened%20And%20Is%20Fixing%20Up%20Its%20Factory%22%2C%22alias%22%3A%22rivian-reopen-factory-covid%22%2C%22section%22%3A%221%22%2C%22is_checked%22%3Atrue%2C%22is_video%22%3A%220%22%2C%22images%22%3A%7B%22s5%22%3A%22https%3A%2F%2Fcdn.motor1.com%2Fimages%2Fmgl%2Fepw0K%2Fs5%2Frivian-factory.jpg%22%7D%7D%2C%7B%22article_edition_id%22%3A%22410858%22%2C%22title%22%3A%22Rivian%20R1T%20Electric%20Truck%20%26%20R1S%20SUV%20Estimated%20Order%20%26%20Delivery%20Times%22%2C%22alias%22%3A%22rivian-r1t-r1s-orders-tracked-delivery-estimates%22%2C%22section%22%3A%221%22%2C%22is_checked%22%3Atrue%2C%22is_video%22%3A%220%22%2C%22images%22%3A%7B%22s5%22%3A%22https%3A%2F%2Fcdn.motor1.com%2Fimages%2Fmgl%2Fkj4px%2Fs5%2Frivian-r1t-2022.jpg%22%7D%7D%5D%7D"> <h2 class="trending-content_header">Check Out More Rivian News:</h2> <div class="wrapper-related-item"> <div class="related-item"><a href="https://insideevs.com/news/426546/rivian-adventure-charging-network-tesla-employees/" target="_blank" rel="noopener"> <span class="lazy related-item-img"> <img src="https://cdn.motor1.com/custom/share/placeholder_0.jpg" alt="rivian adventure charging network tesla employees" data-srcset="https://cdn.motor1.com/images/mgl/y04gb/s6/rivian-r1t-white-dirt.jpg 1x,
https://cdn.motor1.com/images/mgl/y04gb/s4/rivian-r1t-white-dirt.jpg 2x" data-src="https://cdn.motor1.com/images/mgl/y04gb/s6/rivian-r1t-white-dirt.jpg" /> </span> <span class="title-related-item">Rivian Hires Former Tesla Employees To Deploy Its Public Fast-Chargers</span> </a></div> <div class="related-item"><a href="https://insideevs.com/news/426033/rivian-preparing-own-insurance-policy/" target="_blank" rel="noopener"> <span class="lazy related-item-img"> <img src="https://cdn.motor1.com/custom/share/placeholder_1.jpg" alt="rivian preparing own insurance policy" data-srcset="https://cdn.motor1.com/images/mgl/lZxOW/s6/rivian-episode-one-the-climb.jpg 1x,
https://cdn.motor1.com/images/mgl/lZxOW/s4/rivian-episode-one-the-climb.jpg 2x" data-src="https://cdn.motor1.com/images/mgl/lZxOW/s6/rivian-episode-one-the-climb.jpg" /> </span> <span class="title-related-item">Is Rivian Preparing To Offer Its Own Insurance Policy?</span> </a></div> <div class="related-item"><a href="https://insideevs.com/news/425396/rivian-reopen-factory-covid/" target="_blank" rel="noopener"> <span class="lazy related-item-img"> <img src="https://cdn.motor1.com/custom/share/placeholder_2.jpg" alt="rivian reopen factory covid" data-srcset="https://cdn.motor1.com/images/mgl/epw0K/s6/rivian-factory.jpg 1x,
https://cdn.motor1.com/images/mgl/epw0K/s4/rivian-factory.jpg 2x" data-src="https://cdn.motor1.com/images/mgl/epw0K/s6/rivian-factory.jpg" /> </span> <span class="title-related-item">Rivian Has Reopened And Is Fixing Up Its Factory</span> </a></div> <div class="related-item"><a href="https://insideevs.com/news/410858/rivian-r1t-r1s-orders-tracked-delivery-estimates/" target="_blank" rel="noopener"> <span class="lazy related-item-img"> <img src="https://cdn.motor1.com/custom/share/placeholder_3.jpg" alt="rivian r1t r1s orders tracked delivery estimates" data-srcset="https://cdn.motor1.com/images/mgl/kj4px/s6/rivian-r1t-2022.jpg 1x,
https://cdn.motor1.com/images/mgl/kj4px/s4/rivian-r1t-2022.jpg 2x" data-src="https://cdn.motor1.com/images/mgl/kj4px/s6/rivian-r1t-2022.jpg" /> </span> <span class="title-related-item">Rivian R1T Electric Truck &amp; R1S SUV Estimated Order &amp; Delivery Times</span> </a></div> </div> </section>
<p>Currently, the <a href="https://insideevs.com/porsche/taycan/" data-inline-widget="internal-links" data-type-id="1" data-params="%7B%22make_alias%22%3A%22porsche%22%2C%22alias%22%3A%22taycan%22%7D">Porsche Taycan</a> tops at 270 kW charging. The <a href="https://insideevs.com/tesla/model-3/" data-inline-widget="internal-links" data-type-id="1" data-params="%7B%22make_alias%22%3A%22tesla%22%2C%22alias%22%3A%22model-3%22%7D">Tesla Model 3</a> Long Range is at 250 kW. Rivian is now saying it will top at 300 kW, likely due to the system described in the patent. There's more information in this video from a few months back. <em>Tesla Raj</em> checks out Rivian's vehicles and chats with Rivian's founder, RJ Scaringe.</p>
<section contenteditable="false" draggable="true" data-widget="video" data-url-params=""><img class="sizer" draggable="false" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAABAAAAAJCAYAAAA7KqwyAAAAGXRFWHRTb2Z0d2FyZQBBZG9iZSBJbWFnZVJlYWR5ccllPAAAABpJREFUeNpi/P//PwMlgImBQjBqwLAwACDAAOVfAw9/ZDvcAAAAAElFTkSuQmCC" alt="" /> <div class="lazy video-player"><iframe width="1280" height="640" frameborder="0" allowfullscreen="" data-src="https://www.youtube.com/embed/xDsXYCGJ5_s" data-src-param=""></iframe></div> </section>
<p>There's a lot we still don't know here. Until we have more specifics and are aware of taper and mi/kWh (or Wh/mi), we won't really be able to compare it to something like the Tesla Model 3 charging at a <a href="https://insideevs.com/tag/tesla-supercharger-v3-0/" data-inline-widget="internal-links" data-type-id="7" data-params="%7B%22tag%22%3A%22V3%20Supercharger%22%2C%22originalTitle%22%3A%22tesla%20supercharger%20v3.0%22%2C%22alias%22%3A%22tesla-supercharger-v3-0%22%7D">V3 Supercharger</a>. Efficiency is a critical factor as well. At this point, there aren't future plans to exceed 350 kW fast-charging infrastructure anyhow, but it's still interesting to dive into this information.</p>
<p><em>*Hat tip to Gary Exner for discovering and dissecting these details.</em></p><div class="item m1-ap-native"><div class="ap" data-place="22"  data-dfp-code="EV/ev_us/Native" data-sizes="fluid,1x1" data-width="1" data-height="1" data-dfp-attrs='{"m1_native":"2","msnt_env":"production","m1_banner_place":"native","m1_edition":"ev_us","m1_article_type":"news","m1_page_content_id":427197,"m1_page_type":"detail","m1_page_content_type":"article","m1_makes":["rivian"],"m1_models":["r1s","r1t"],"m1_categories":["battery-tech","charging"],"m1_tags":["electric pickup truck"],"m1_body_types":["truck","truck"],"m1_model_segments":["",""],"m1_banner_position":"native"}'></div></div>                </div>


                                            <div class="entityInfoBlock m-top">
                                                        Source:
                            
                                                            
<span class="item"><a class="source" target="_blank" href="https://www.trucks.com/2019/05/07/rivian-truck-battery-patent-faster-charging/">Trucks.com</a></span>                                                    </div>
                    
                    <!-- new gallery place -->
                    
                    
                <div class="sapb"><div class="apb mleaderboard" style="padding:15px 0 15px 0;"><div class="ap" data-place="24" style="width:290px;min-height:1px;" data-dfp-code="EV/ev_us/Mobile_Leaderboard/Social" data-sizes="290x1,290x100" data-width="290" data-height="1" data-dfp-attrs='{"lazy":1,"msnt_env":"production","m1_banner_place":"article_socials","m1_edition":"ev_us","m1_article_type":"news","m1_page_content_id":427197,"m1_page_type":"detail","m1_page_content_type":"article","m1_makes":["rivian"],"m1_models":["r1s","r1t"],"m1_categories":["battery-tech","charging"],"m1_tags":["electric pickup truck"],"m1_body_types":["truck","truck"],"m1_model_segments":["",""],"m1_banner_position":"article_socials"}'></div></div><div class="apb leaderboard" style="padding:15px 0 15px 0;"><div class="ap" data-place="23" style="width:650px;min-height:1px;" data-dfp-code="EV/ev_us/Leaderboard/Social" data-sizes="650x1,650x100" data-width="650" data-height="1" data-dfp-attrs='{"lazy":1,"msnt_env":"production","m1_banner_place":"article_socials","m1_edition":"ev_us","m1_article_type":"news","m1_page_content_id":427197,"m1_page_type":"detail","m1_page_content_type":"article","m1_makes":["rivian"],"m1_models":["r1s","r1t"],"m1_categories":["battery-tech","charging"],"m1_tags":["electric pickup truck"],"m1_body_types":["truck","truck"],"m1_model_segments":["",""],"m1_banner_position":"article_socials"}'></div></div></div>

                

                
                

                



                                


                                    <div class="parent-shareBox parent-shareBox-bottom">
                                                                                    <script id="dsq-count-scr" src="//insideevscom.disqus.com/count.js" async></script>                                <a title="Add a comment" href="/news/427197/rivian-electric-truck-patent-charging-rate/#comments" class="disqus-comment-count" data-disqus-identifier="en-article-427197" data-disqus-url="/news/427197/rivian-electric-truck-patent-charging-rate/"></a>                                                                            <div slot="share-box" class="big-shareBox shareBox share-box-dropdown to-down"><div class="share-box-wrapper"><span class="shareBox-separator" data-value="share-list-1591373731" data-button onClick="" data-id="toggleBox" data-static> <span class="active"><span class="icon-plus">+</span></span><span class="passive"><span class="icon-plus">+</span></span></span><a href="https://insideevs.com/news/427197/rivian-electric-truck-patent-charging-rate/" class="share-button"><span class="name">Share</span><span class="icon share-empty"></span></a><div class="share-list" data-button-target="share-list-1591373731"><ul><li class="facebook"><a data-button="" data-id="share" data-url="/connect/share/" data-name="network_id" target="_blank" data-extra-params="id:'427197',type_id:'1'" data-value="1" data-share-network="Facebook" data-share-url="https://insideevs.com/news/427197/rivian-electric-truck-patent-charging-rate/" data-width="600" data-height="600" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Finsideevs.com%2Fnews%2F427197%2Frivian-electric-truck-patent-charging-rate%2F"><span class="social-bg icon facebook"></span><span class="name">Share on Facebook</span></a></li><li class="twitter"><a data-button="" data-id="share" data-url="/connect/share/" data-name="network_id" target="_blank" data-extra-params="id:'427197',type_id:'1'" data-value="2" data-share-network="Twitter" data-share-url="https://insideevs.com/news/427197/rivian-electric-truck-patent-charging-rate/" data-width="600" data-height="450" href="https://twitter.com/intent/tweet?url=https%3A%2F%2Finsideevs.com%2Fnews%2F427197%2Frivian-electric-truck-patent-charging-rate%2F&text=Rivian%27s+Electric+Trucks+Will+Charge+Faster+Than+All+Production+EVs&via=insideevs.com"><span class="social-bg icon twitter"></span><span class="name">Share on Twitter</span></a></li><li class="linkedin"><a data-button="" data-id="share" data-url="/connect/share/" data-name="network_id" target="_blank" data-extra-params="id:'427197',type_id:'1'" data-value="3" data-share-network="LinkedIn" data-share-url="https://insideevs.com/news/427197/rivian-electric-truck-patent-charging-rate/" data-width="600" data-height="600" href="https://www.linkedin.com/cws/share?url=https%3A%2F%2Finsideevs.com%2Fnews%2F427197%2Frivian-electric-truck-patent-charging-rate%2F"><span class="social-bg icon linkedin"></span><span class="name">Share on LinkedIn</span></a></li><li class="flipboard"><a data-button="" data-id="share" data-url="/connect/share/" data-name="network_id" target="_blank" data-extra-params="id:'427197',type_id:'1'" data-value="7" data-share-network="Flipboard" data-share-url="https://insideevs.com/news/427197/rivian-electric-truck-patent-charging-rate/" data-width="600" data-height="600" href="https://share.flipboard.com/bookmarklet/popout?url=https%3A%2F%2Finsideevs.com%2Fnews%2F427197%2Frivian-electric-truck-patent-charging-rate%2F&title=Rivian%27s+Electric+Trucks+Will+Charge+Faster+Than+All+Production+EVs&v=2"><span class="social-bg icon flipboard"></span><span class="name">Share on Flipboard</span></a></li><li class="reddit"><a data-button="" data-id="share" data-url="/connect/share/" data-name="network_id" target="_blank" data-extra-params="id:'427197',type_id:'1'" data-value="6" data-share-network="Reddit" data-share-url="https://insideevs.com/news/427197/rivian-electric-truck-patent-charging-rate/" data-width="900" data-height="600" href="https://www.reddit.com/submit?url=https%3A%2F%2Finsideevs.com%2Fnews%2F427197%2Frivian-electric-truck-patent-charging-rate%2F"><span class="social-bg icon reddit"></span><span class="name">Share on Reddit</span></a></li><li class="whatsapp"><a data-button="" data-id="share" data-url="/connect/share/" data-name="network_id" target="_blank" data-extra-params="id:'427197',type_id:'1'" data-value="6" data-share-network="WhatsApp" data-share-url="https://insideevs.com/news/427197/rivian-electric-truck-patent-charging-rate/" data-width="600" data-height="600" href="https://api.whatsapp.com/send?text=https%3A%2F%2Finsideevs.com%2Fnews%2F427197%2Frivian-electric-truck-patent-charging-rate%2F"><span class="social-bg icon whatsapp"></span><span class="name">Share on WhatsApp</span></a></li><li class="mailto"><a data-button="" data-id="mailTo" target="_blank" data-extra-params="id:'427197',type_id:'1'" data-share-url="https://insideevs.com/news/427197/rivian-electric-truck-patent-charging-rate/" data-width="600" data-height="400" href="mailto:?body=https%3A%2F%2Finsideevs.com%2Fnews%2F427197%2Frivian-electric-truck-patent-charging-rate%2F&subject=Rivian%27s%20Electric%20Trucks%20Will%20Charge%20Faster%20Than%20All%20Production%20EVs"><span class="social-bg icon mailto"></span><span class="name">Send to email</span></a></li></ul></div></div></div>                    </div>
                
                
                
                
                

                                

                
            </div>
        </div>






                    <div class="sidebar" id="post_sidebar">
                                    <div class="apb apb-dmpu"><div class="ap" data-place="4" style="width:300px;min-height:250px;" data-dfp-code="EV/ev_us/DMPU" data-sizes="300x250,300x600" data-width="300" data-height="250" data-dfp-attrs='{"msnt_env":"production","m1_banner_place":"dmpu_first","m1_edition":"ev_us","m1_article_type":"news","m1_page_content_id":427197,"m1_page_type":"detail","m1_page_content_type":"article","m1_makes":["rivian"],"m1_models":["r1s","r1t"],"m1_categories":["battery-tech","charging"],"m1_tags":["electric pickup truck"],"m1_body_types":["truck","truck"],"m1_model_segments":["",""],"m1_banner_position":"sidebar"}'></div></div>                                    
                                                            <div class="trending-content">
                            <div class="content-header">
                                <h2 class="trending-content_header">Trending</h2>
                            </div>
                                                                                                                            <div class="trending-content_item">
                                    <a class="trending-content_thumb thumb zoom"  href="/news/427211/video-drag-race-tesla-model-3-corvette-c8/">
                                                                                            <span class="icon play"></span>
                                                                                    <picture class="lazy">
                                            <img src="https://cdn.motor1.com/custom/share/placeholder_0.jpg" alt="Watch This Tesla Model 3 Performance Drag Race A Brand-New Corvette C8" data-src="https://cdn.motor1.com/images/mgl/NpwP9/s6/tesla-model-3-vs-corvette-c8.jpg" class="desaturate">                                        </picture>
                                    </a>
                                    <a class="trending-content_link"  href="/news/427211/video-drag-race-tesla-model-3-corvette-c8/">Watch This Tesla Model 3 Performance Drag Race A Brand-New Corvette C8</a>
                                </div>
                                                                                                                                                                                            <div class="trending-content_item">
                                    <a class="trending-content_thumb thumb zoom"  href="/news/426988/video-road-rage-gmc-truck-tesla/">
                                                                                            <span class="icon play"></span>
                                                                                    <picture class="lazy">
                                            <img src="https://cdn.motor1.com/custom/share/placeholder_1.jpg" alt="Watch This Crazy GMC Sierra Truck Driver Attack A Tesla Numerous Times" data-src="https://cdn.motor1.com/images/mgl/3oVQp/s6/truck.jpg" class="desaturate">                                        </picture>
                                    </a>
                                    <a class="trending-content_link"  href="/news/426988/video-road-rage-gmc-truck-tesla/">Watch This Crazy GMC Sierra Truck Driver Attack A Tesla Numerous Times</a>
                                </div>
                                                                                                                            <div class="trending-content_item">
                                    <a class="trending-content_thumb thumb zoom"  href="/features/426725/video-exploring-tesla-model-s-high-mileage/">
                                                                                            <span class="icon play"></span>
                                                                                    <picture class="lazy">
                                            <img src="https://cdn.motor1.com/custom/share/placeholder_2.jpg" alt="High-Mileage Tesla Model S: InsideEVs Deep Dive Into What To Expect" data-src="https://cdn.motor1.com/images/mgl/9L32l/s6/model.jpg" class="desaturate">                                        </picture>
                                    </a>
                                    <a class="trending-content_link"  href="/features/426725/video-exploring-tesla-model-s-high-mileage/">High-Mileage Tesla Model S: InsideEVs Deep Dive Into What To Expect</a>
                                </div>
                                                                                                                            <div class="trending-content_item">
                                    <a class="trending-content_thumb thumb zoom"  href="/reviews/426807/video-tesla-model-y-edmunds-long-term/">
                                                                                            <span class="icon play"></span>
                                                                                    <picture class="lazy">
                                            <img src="https://cdn.motor1.com/custom/share/placeholder_3.jpg" alt="Edmunds' Tesla Model Y Long-Term Update: What Other Automakers Can Learn" data-src="https://cdn.motor1.com/images/mgl/y0eXq/s6/tesla-model-y-edmunds.jpg" class="desaturate">                                        </picture>
                                    </a>
                                    <a class="trending-content_link"  href="/reviews/426807/video-tesla-model-y-edmunds-long-term/">Edmunds' Tesla Model Y Long-Term Update: What Other Automakers Can Learn</a>
                                </div>
                                                    </div>
                                                                        <div class="apb apb-dmpu"><div class="ap" data-place="4" style="width:300px;min-height:250px;" data-dfp-code="EV/ev_us/DMPU" data-sizes="300x250,300x600" data-width="300" data-height="250" data-dfp-attrs='{"lazy":1,"msnt_env":"production","m1_banner_place":"dmpu","m1_edition":"ev_us","m1_article_type":"news","m1_page_content_id":427197,"m1_page_type":"detail","m1_page_content_type":"article","m1_makes":["rivian"],"m1_models":["r1s","r1t"],"m1_categories":["battery-tech","charging"],"m1_tags":["electric pickup truck"],"m1_body_types":["truck","truck"],"m1_model_segments":["",""],"m1_banner_position":"sidebar"}'></div></div>                            </div>
                <div class="clear"></div>
    </div>
</div>

        

<div id="container_3rd_party_service" class="container_3rd_party pre-center padding print-hide" data-edtn="ev_us">

    <div class="content-area">
        <div class="content-area-box">
                            <div class="trending-content b-m-padding b-padding trending-content_mobile">
                    <div class="content-header">
                        <h2 class="trending-content_header">Trending</h2>
                    </div>
                                                                    <div class="trending-content_item trending-content_item-mobile">
                            <a class="trending-content_thumb thumb zoom lazy" href="/news/427211/video-drag-race-tesla-model-3-corvette-c8/" data-srcset="https://cdn.motor1.com/images/mgl/NpwP9/s6/tesla-model-3-vs-corvette-c8.jpg" data-srcset2x="https://cdn.motor1.com/images/mgl/NpwP9/s6/tesla-model-3-vs-corvette-c8.jpg">
                                                                    <span class="icon play"></span>
                                                                <picture class="lazy">
                                    <img src="https://cdn.motor1.com/q/images/mgl/VE1yz/s7/motor1-placeholder.jpg" data-src="https://cdn.motor1.com/images/mgl/NpwP9/s6/tesla-model-3-vs-corvette-c8.jpg" alt="Watch This Tesla Model 3 Performance Drag Race A Brand-New Corvette C8"/>
                                </picture>
                            </a>
                            <a class="trending-content_link" href="/news/427211/video-drag-race-tesla-model-3-corvette-c8/">Watch This Tesla Model 3 Performance Drag Race A Brand-New Corvette C8</a>
                        </div>
                                                                                            <div class="trending-content_item trending-content_item-mobile">
                            <a class="trending-content_thumb thumb zoom lazy" href="/news/426988/video-road-rage-gmc-truck-tesla/" data-srcset="https://cdn.motor1.com/images/mgl/3oVQp/s6/truck.jpg" data-srcset2x="https://cdn.motor1.com/images/mgl/3oVQp/s6/truck.jpg">
                                                                    <span class="icon play"></span>
                                                                <picture class="lazy">
                                    <img src="https://cdn.motor1.com/q/images/mgl/VE1yz/s7/motor1-placeholder.jpg" data-src="https://cdn.motor1.com/images/mgl/3oVQp/s6/truck.jpg" alt="Watch This Crazy GMC Sierra Truck Driver Attack A Tesla Numerous Times"/>
                                </picture>
                            </a>
                            <a class="trending-content_link" href="/news/426988/video-road-rage-gmc-truck-tesla/">Watch This Crazy GMC Sierra Truck Driver Attack A Tesla Numerous Times</a>
                        </div>
                                                                    <div class="trending-content_item trending-content_item-mobile">
                            <a class="trending-content_thumb thumb zoom lazy" href="/features/426725/video-exploring-tesla-model-s-high-mileage/" data-srcset="https://cdn.motor1.com/images/mgl/9L32l/s6/model.jpg" data-srcset2x="https://cdn.motor1.com/images/mgl/9L32l/s6/model.jpg">
                                                                    <span class="icon play"></span>
                                                                <picture class="lazy">
                                    <img src="https://cdn.motor1.com/q/images/mgl/VE1yz/s7/motor1-placeholder.jpg" data-src="https://cdn.motor1.com/images/mgl/9L32l/s6/model.jpg" alt="High-Mileage Tesla Model S: InsideEVs Deep Dive Into What To Expect"/>
                                </picture>
                            </a>
                            <a class="trending-content_link" href="/features/426725/video-exploring-tesla-model-s-high-mileage/">High-Mileage Tesla Model S: InsideEVs Deep Dive Into What To Expect</a>
                        </div>
                                                                    <div class="trending-content_item trending-content_item-mobile">
                            <a class="trending-content_thumb thumb zoom lazy" href="/reviews/426807/video-tesla-model-y-edmunds-long-term/" data-srcset="https://cdn.motor1.com/images/mgl/y0eXq/s6/tesla-model-y-edmunds.jpg" data-srcset2x="https://cdn.motor1.com/images/mgl/y0eXq/s6/tesla-model-y-edmunds.jpg">
                                                                    <span class="icon play"></span>
                                                                <picture class="lazy">
                                    <img src="https://cdn.motor1.com/q/images/mgl/VE1yz/s7/motor1-placeholder.jpg" data-src="https://cdn.motor1.com/images/mgl/y0eXq/s6/tesla-model-y-edmunds.jpg" alt="Edmunds' Tesla Model Y Long-Term Update: What Other Automakers Can Learn"/>
                                </picture>
                            </a>
                            <a class="trending-content_link" href="/reviews/426807/video-tesla-model-y-edmunds-long-term/">Edmunds' Tesla Model Y Long-Term Update: What Other Automakers Can Learn</a>
                        </div>
                                    </div>
                    </div>
    </div>
                    <div class="myevFeedContainer" data-tags="electric pickup truck,Rivian,Battery Tech,Charging"></div>
        <script type="text/javascript" src="https://www.myev.com/js/insideevs_v1.2.js" defer></script>
    
    
    
            <div id="sponsored_content">
        </div>
    
                        <div class="sellwild-caption">
                <p>Check out unique & lightly used vehicles/stuff for sale</p>
                <a href="https://sellwild.com/?p=insideevs&utm_source=insideevs" target="_blank">Sell anything (free), get featured here</a>
            </div>
                <div class="sellwild-container">
            <div class="sellwild-wrapper"
                data-partner="insideevs"
                data-color="#77cc4b"
                data-version="1_1_31"
                                    data-overlay="true"
                            >
            </div>
        </div>
        <div class="content-area">
        <div class="content-area-box">
                            <div id="comments" class="comment-container no-apb">
                                                                        <div id="disqus_thread" class="diquas-wrapper" data-cid="article-427197" data-url="/news/427197/rivian-electric-truck-patent-charging-rate/" data-title="Rivian's Electric Trucks Will Charge Faster Than All Production EVs">
                            </div>
                                                            </div>
                                                </div>
        <div class="sidebar">
                            <div class="mobile-adv">
                    <div class="apb apb-dmpu"><div class="ap" data-place="4" style="width:300px;min-height:250px;" data-dfp-code="EV/ev_us/DMPU" data-sizes="300x250,300x600" data-width="300" data-height="250" data-dfp-attrs='{"lazy":1,"msnt_env":"production","m1_banner_place":"dmpu","m1_edition":"ev_us","m1_article_type":"news","m1_page_content_id":427197,"m1_page_type":"detail","m1_page_content_type":"article","m1_makes":["rivian"],"m1_models":["r1s","r1t"],"m1_categories":["battery-tech","charging"],"m1_tags":["electric pickup truck"],"m1_body_types":["truck","truck"],"m1_model_segments":["",""],"m1_banner_position":"sidebar"}'></div></div>                </div>
                <div class="lazy-load-adv">
                    <div class="apb apb-dmpu"><div class="ap" data-place="4" style="width:300px;min-height:250px;" data-dfp-code="EV/ev_us/DMPU" data-sizes="300x250,300x600" data-width="300" data-height="250" data-dfp-attrs='{"lazy":1,"msnt_env":"production","m1_banner_place":"dmpu","m1_edition":"ev_us","m1_article_type":"news","m1_page_content_id":427197,"m1_page_type":"detail","m1_page_content_type":"article","m1_makes":["rivian"],"m1_models":["r1s","r1t"],"m1_categories":["battery-tech","charging"],"m1_tags":["electric pickup truck"],"m1_body_types":["truck","truck"],"m1_model_segments":["",""],"m1_banner_position":"sidebar"}'></div></div>                </div>
                    </div>
        <div class="clear"></div>

    </div>


    


    
                </div>

<div class="pre-center mobile-skyscraper-box">
    <div class="apb apb-dmpu"><div class="ap" data-place="4" style="width:300px;min-height:250px;" data-dfp-code="EV/ev_us/DMPU" data-sizes="300x250,300x600" data-width="300" data-height="250" data-dfp-attrs='{"lazy":1,"msnt_env":"production","m1_banner_place":"dmpu","m1_edition":"ev_us","m1_article_type":"news","m1_page_content_id":427197,"m1_page_type":"detail","m1_page_content_type":"article","m1_makes":["rivian"],"m1_models":["r1s","r1t"],"m1_categories":["battery-tech","charging"],"m1_tags":["electric pickup truck"],"m1_body_types":["truck","truck"],"m1_model_segments":["",""],"m1_banner_position":"sidebar"}'></div></div></div>

<div class="cpre-center print-hide">
    </div>

    <div class="pre-center padding print-hide">
        <div class="content-area">
            <div class="content-area-box">
                <h2 class="text-uppercase">About this article</h2>
                <table class="additionalInfo">
                                            <tr>
                            <td>Category</td>
                            <td><div class="list">
                                                                            <a href="/news/category/battery-tech/">Battery Tech</a>
                                                                            <a href="/news/category/charging/">Charging</a>
                                                                    </div></td>
                        </tr>
                                                                                    <tr>
                            <td>Tags</td>
                            <td>
                                <div class="list">
                                                                            <a href="/tag/electric-pickup-truck/">electric pickup truck</a>
                                                                    </div>
                            </td>
                        </tr>
                                                                                                <tr>
                                <td>Make/Model</td>
                                <td>
                                    <div class="list">
                                                                                                                                <a href="/rivian/r1s/">Rivian R1S</a>
                                                                                                                                <a href="/rivian/r1t/">Rivian R1T</a>
                                                                            </div>
                                </td>
                            </tr>
                                                    <tr>
                                <td>Body Style</td>
                                <td>
                                    <div class="list">
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                    <a href="/body-styles/truck/">
                                                Truck                                            </a>
                                                                            </div>
                                </td>
                            </tr>
                                                            </table>
            </div>
            <div class="sidebar">

            </div>
            <div class="clear"></div>
        </div>
    </div>
    <div id="stop_share_box" class="print-hide"></div>

<div  id="ap_popup_gallery_top"><div class="apb mleaderboard"><div class="ap" data-place="10" style="width:320px;min-height:50px;" data-dfp-code="EV/ev_us/Mobile_Leaderboard" data-sizes="320x50,320x100" data-width="320" data-height="50" data-dfp-attrs='{"lazy":1,"msnt_env":"production","m1_banner_place":"popup_gallery_top","m1_edition":"ev_us","m1_article_type":"news","m1_page_content_id":427197,"m1_page_type":"detail","m1_page_content_type":"article","m1_makes":["rivian"],"m1_models":["r1s","r1t"],"m1_categories":["battery-tech","charging"],"m1_tags":["electric pickup truck"],"m1_body_types":["truck","truck"],"m1_model_segments":["",""],"m1_banner_position":"popup_gallery_top"}'></div></div><div class="apb leaderboard"><div class="ap" data-place="1" style="width:728px;min-height:90px;" data-dfp-code="EV/ev_us/Leaderboard" data-width="728" data-height="90" data-dfp-attrs='{"lazy":1,"msnt_env":"production","m1_banner_place":"popup_gallery_top","m1_edition":"ev_us","m1_article_type":"news","m1_page_content_id":427197,"m1_page_type":"detail","m1_page_content_type":"article","m1_makes":["rivian"],"m1_models":["r1s","r1t"],"m1_categories":["battery-tech","charging"],"m1_tags":["electric pickup truck"],"m1_body_types":["truck","truck"],"m1_model_segments":["",""],"m1_banner_position":"popup_gallery_top"}'></div></div><div class="apb super"><div class="ap" data-place="12" style="width:970px;min-height:90px;" data-dfp-code="EV/ev_us/Super" data-width="970" data-height="90" data-dfp-attrs='{"lazy":1,"msnt_env":"production","m1_banner_place":"popup_gallery_top","m1_edition":"ev_us","m1_article_type":"news","m1_page_content_id":427197,"m1_page_type":"detail","m1_page_content_type":"article","m1_makes":["rivian"],"m1_models":["r1s","r1t"],"m1_categories":["battery-tech","charging"],"m1_tags":["electric pickup truck"],"m1_body_types":["truck","truck"],"m1_model_segments":["",""],"m1_banner_position":"popup_gallery_top"}'></div></div></div><div id="ap_popup_gallery_rectangle"><div class="ap" data-place="4" style="width:300px;min-height:250px;" data-dfp-code="EV/ev_us/DMPU" data-sizes="300x250,300x600" data-width="300" data-height="250" data-dfp-attrs='{"lazy":1,"msnt_env":"production","m1_banner_place":"popup_gallery_rectangle","m1_edition":"ev_us","m1_article_type":"news","m1_page_content_id":427197,"m1_page_type":"detail","m1_page_content_type":"article","m1_makes":["rivian"],"m1_models":["r1s","r1t"],"m1_categories":["battery-tech","charging"],"m1_tags":["electric pickup truck"],"m1_body_types":["truck","truck"],"m1_model_segments":["",""],"m1_banner_position":"popup_gallery_rectangle"}'></div></div>
        </div>


<div class="m1-left-side">
    <div class="m1-drawer left-to-right disabled" data-button-target="mainMenu">
        <div onclick="" data-button data-id="toggleBox" data-close-delay="0.5" data-value="mainMenu" data-hide-scroll="m1-left-side-box" data-clear="2" class="m1-drawer-close-button dark active" data-toggle="1" data-multi></div>
        <div class="m1-left-side-top">
            <div class="m1-user-side-label">
                <span class="label flex-parent two-line">
                   <a class="login" href="/login/" onclick="" data-button data-id="goToUrl">Sign In</a>
                   <span class="hide_mobile">or</span>
                   <a class="register" href="/register/" onclick="" data-button data-id="goToUrl">Sign Up</a>
                </span>
                <span class="hide_mobile userpic icon-user"></span>
            </div>
        </div>
        <div class="m1-left-side-box">
                        <ul class="m1-navigation-main print-hide">
                        <li class="grand top left mobile">
            <a href="/news/" >
                News            </a>
        </li>
                    <li class="grand top left">
            <a href="/reviews/" >
                Reviews            </a>
        </li>
                    <li class="grand left">
            <a href="/features/" >
                Features            </a>
        </li>
                    <li class="mobile">
            <a href="/tesla/" >
                Tesla            </a>
        </li>
                    <li class="top left">
            <a href="/reviews/344001/compare-evs/" >
                Compare EVs            </a>
        </li>
                    <li class="left">
            <a href="/news/344002/charger-guide/" >
                Charger Guide            </a>
        </li>
                    <li class="left">
            <a href="/features/category/buying-advice/" >
                Buying Advice            </a>
        </li>
                    <li class="left">
            <a href="/news/343998/monthly-plug-in-ev-sales-scorecard/" >
                EV Sales Scorecard            </a>
        </li>
                    <li class="mobile">
            <a href="/news/343998/monthly-plug-in-ev-sales-scorecard/" >
                EV Sales            </a>
        </li>
                    <li class="left">
            <a href="/news/?sc=1" >
                Categories            </a>
        </li>
                    <li class="left">
            <a href="/makes/" >
                Makes            </a>
        </li>
                    <li class="left">
            <a href="/body-styles/" >
                Body Style            </a>
        </li>
                    <li class="left top _blank">
            <a href="https://insideevsforum.com/community/index.php" target = "_blank">
                Forum            </a>
        </li>
                    <li class="left _blank">
            <a href="https://www.myev.com/cars-for-sale" target = "_blank">
                Buy            </a>
        </li>
                    <li class="podcast ico left">
            <a href="https://insideevs.com/features/category/podcast/" >
                Podcast            </a>
        </li>
                    <li class="photos ico left">
            <a href="/photos/" >
                Photos            </a>
        </li>
                    <li class="videos ico left">
            <a href="/videos/" >
                Videos            </a>
        </li>
                    <li class="top plugin-sale">
            <a href="/news/343998/monthly-plug-in-ev-sales-scorecard/" >
                Ev Sales Scorecard            </a>
        </li>
    </ul>            <div class="m1-menus-box">
                <div class="m1-extra-menus-box">
                    <a href="/" class="m1-side-logo"></a>
                                        <div class="m1-editions-switcher-mobile">
                        <a href="/info/about-us/" class="m1-editions-switcher" onclick="" data-close-delay="0.5" data-delay="0.01" data-button="" data-hide-scroll="m1-scrollbar" data-id="toggleBox" data-value="editionsMenu" data-clear="2" data-multi="">
                            <span class="title">Edition:</span>
                                                        <span class="edf edf-230"></span>
                                                    </a>
                    </div>
                    
                                            <ul class="m1-social-menu">
                                                                                <li class="facebook"><a class="icon-facebook-redirect-link" href="https://www.facebook.com/InsideeVs/" target="_blank"></a></li>
                                                                                                                                                                <li class="twitter"><a class="icon-twitter-redirect-link" href="https://twitter.com/InsideEVs" target="_blank"></a></li>
                                                                                                                                                                <li class="flipboard"><a class="icon-flipboard-redirect-link" href="https://flipboard.com/@InsideEVs" target="_blank"></a></li>
                                                                                                                                                                                                                    <li class="gnews"><a class="icon-gnews-redirect-link" href="https://news.google.com/publications/CAAqBwgKMLHIlAswkJCqAw" target="_blank"></a></li>
                                                                                                                                                                                                                                                                                                                            <li class="youtube"><a class="icon-youtube-redirect-link" href="https://www.youtube.com/channel/UCw4aq8JMlCMBMOQ0PliCkIQ?sub_confirmation=1" target="_blank"></a></li>
                                                                                                                                                                                                                    <li class="rss"><a class="icon-rss-redirect-link" href="/rss/" ></a></li>
                                                                            </ul>
                    
                    <ul class="m1-info-menu">
                        <li><a href="/info/about-us/">About Us</a></li>
                                                    <li><a href="https://newsletter.insideevs.com/signup/" target="_blank">Newsletter</a></li>
                                                <li><a href="/info/contact/">Contact</a></li>
                        <li><a href="/info/feedback/tip-us/">Tip us</a></li>
                        <li><a href="https://accounts.motorsportnetwork.com/legal/privacy-policy" target="_blank">Privacy policy</a></li>
                        <li><a href="/info/cookie-policy/">Cookie policy</a></li>
                    </ul>

                </div>
                <div class="m1-msn-menus-box">
                    <ul class="m1-msn-menu">

                                                
                        
                        
                                                    <li class="autoclassics"><a href="https://www.autoclassics.com/" target="_blank">www.autoclassics.com</a></li>
                        
                        
                                                    <li class="motor1"><a href="https://www.motor1.com/" target="_blank">www.motor1.com</a></li>
                        
                                                   <li class="myen"><a href="https://www.myev.com/" target="_blank">www.myev.com/</a></li>
                        
                        
                        
                        
                        
                        
                    </ul>
                </div>
                <div class="m1-footer">
                    &copy; 2020 <a target="_blank" class="m1-msn-name" href="https://www.motorsportnetwork.com/company/about">Motorsport Network.</a>                                                         </div>
                            </div>
        </div>
    </div>
    <div class="m1-drawer-overlay"></div>
</div>
    
<div class="m1-right-side">
    <div class="m1-drawer right-to-left disabled" data-button-target="editionsMenu">
        
        <div onclick="" data-button data-id="toggleBox" data-value="editionsMenu" data-close-delay="0.5" data-hide-scroll="m1-scrollbar" data-clear="2" class="m1-drawer-close-button active" data-toggle="1" data-multi></div>
    
        <div class="m1-editions-switcher active" data-close-delay="0.5" data-delay="0.01" onclick="" data-button data-id="toggleBox" data-value="editionsMenu" data-clear="2" data-toggle="1" data-multi>
                        <span class="edf edf-230"></span>
                        <span class="title">USA / Global</span>
        </div>
        <div class="m1-editions-label">Our International Editions</div>
        <div class="m1-editions-box m1-scrollbar">
            
            <ul class="m1-editions-list">
                            <li class="current">
                    <a href="/?select_edition=ev_us">
                                        <span class="flags">
                                            <span class="edf edf-230"></span>
                                        </span>
                    <span class="label">
                                        InsideEVs: USA / Global                    </span>
                    </a>
                </li>
                            <li>
                    <a href="/?select_edition=ev_fr">
                                        <span class="flags">
                                            <span class="edf edf-72"></span>
                                            <span class="edf edf-21"></span>
                                            <span class="edf edf-211"></span>
                                            <span class="edf edf-145"></span>
                                            <span class="edf edf-128"></span>
                                        </span>
                    <span class="label">
                                        InsideEVs: France                    </span>
                    </a>
                </li>
                            <li>
                    <a href="/?select_edition=ev_it">
                                        <span class="flags">
                                            <span class="edf edf-106"></span>
                                        </span>
                    <span class="label">
                                        InsideEVs: Italy                    </span>
                    </a>
                </li>
                            <li>
                    <a href="/?select_edition=ev_br">
                                        <span class="flags">
                                            <span class="edf edf-30"></span>
                                            <span class="edf edf-177"></span>
                                        </span>
                    <span class="label">
                                        InsideEVs: Brasil                    </span>
                    </a>
                </li>
                            <li>
                    <a href="/?select_edition=ev_ru">
                                        <span class="flags">
                                            <span class="edf edf-182"></span>
                                            <span class="edf edf-20"></span>
                                            <span class="edf edf-227"></span>
                                            <span class="edf edf-112"></span>
                                        </span>
                    <span class="label">
                                        InsideEVs: Russia                    </span>
                    </a>
                </li>
                        </ul>
            
        </div>


    
    </div>
    <div class="m1-drawer-overlay"></div>
</div>
<m1-check-availability-response-dialog
        user-data='{"email":"","zip":"19312","phone":"","firstName":"","lastName":""}'
        edition="ev_us"
        oem-url="/buy/new/lead/"
        vin-url="/buy/used/lead/"
></m1-check-availability-response-dialog>


    <div id="share_box_content_wrapper">
        <div slot="share-box" class="big-shareBox shareBox share-box-dropdown to-down"><div class="share-box-wrapper"><span class="shareBox-separator" data-value="share-list-1591373873" data-button onClick="" data-id="toggleBox" data-static> <span class="active"><span class="icon-plus">+</span></span><span class="passive"><span class="icon-plus">+</span></span></span><a href="https://insideevs.com/news/427197/rivian-electric-truck-patent-charging-rate/" class="share-button"><span class="name">Share</span><span class="icon share-empty"></span></a><div class="share-list" data-button-target="share-list-1591373873"><ul><li class="facebook"><a data-button="" data-id="share" data-url="/connect/share/" data-name="network_id" target="_blank" data-extra-params="id:'427197',type_id:'1'" data-value="1" data-share-network="Facebook" data-share-url="https://insideevs.com/news/427197/rivian-electric-truck-patent-charging-rate/" data-width="600" data-height="600" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Finsideevs.com%2Fnews%2F427197%2Frivian-electric-truck-patent-charging-rate%2F"><span class="social-bg icon facebook"></span><span class="name">Share on Facebook</span></a></li><li class="twitter"><a data-button="" data-id="share" data-url="/connect/share/" data-name="network_id" target="_blank" data-extra-params="id:'427197',type_id:'1'" data-value="2" data-share-network="Twitter" data-share-url="https://insideevs.com/news/427197/rivian-electric-truck-patent-charging-rate/" data-width="600" data-height="450" href="https://twitter.com/intent/tweet?url=https%3A%2F%2Finsideevs.com%2Fnews%2F427197%2Frivian-electric-truck-patent-charging-rate%2F&text=Rivian%27s+Electric+Trucks+Will+Charge+Faster+Than+All+Production+EVs&via=insideevs.com"><span class="social-bg icon twitter"></span><span class="name">Share on Twitter</span></a></li><li class="linkedin"><a data-button="" data-id="share" data-url="/connect/share/" data-name="network_id" target="_blank" data-extra-params="id:'427197',type_id:'1'" data-value="3" data-share-network="LinkedIn" data-share-url="https://insideevs.com/news/427197/rivian-electric-truck-patent-charging-rate/" data-width="600" data-height="600" href="https://www.linkedin.com/cws/share?url=https%3A%2F%2Finsideevs.com%2Fnews%2F427197%2Frivian-electric-truck-patent-charging-rate%2F"><span class="social-bg icon linkedin"></span><span class="name">Share on LinkedIn</span></a></li><li class="flipboard"><a data-button="" data-id="share" data-url="/connect/share/" data-name="network_id" target="_blank" data-extra-params="id:'427197',type_id:'1'" data-value="7" data-share-network="Flipboard" data-share-url="https://insideevs.com/news/427197/rivian-electric-truck-patent-charging-rate/" data-width="600" data-height="600" href="https://share.flipboard.com/bookmarklet/popout?url=https%3A%2F%2Finsideevs.com%2Fnews%2F427197%2Frivian-electric-truck-patent-charging-rate%2F&title=Rivian%27s+Electric+Trucks+Will+Charge+Faster+Than+All+Production+EVs&v=2"><span class="social-bg icon flipboard"></span><span class="name">Share on Flipboard</span></a></li><li class="reddit"><a data-button="" data-id="share" data-url="/connect/share/" data-name="network_id" target="_blank" data-extra-params="id:'427197',type_id:'1'" data-value="6" data-share-network="Reddit" data-share-url="https://insideevs.com/news/427197/rivian-electric-truck-patent-charging-rate/" data-width="900" data-height="600" href="https://www.reddit.com/submit?url=https%3A%2F%2Finsideevs.com%2Fnews%2F427197%2Frivian-electric-truck-patent-charging-rate%2F"><span class="social-bg icon reddit"></span><span class="name">Share on Reddit</span></a></li><li class="whatsapp"><a data-button="" data-id="share" data-url="/connect/share/" data-name="network_id" target="_blank" data-extra-params="id:'427197',type_id:'1'" data-value="6" data-share-network="WhatsApp" data-share-url="https://insideevs.com/news/427197/rivian-electric-truck-patent-charging-rate/" data-width="600" data-height="600" href="https://api.whatsapp.com/send?text=https%3A%2F%2Finsideevs.com%2Fnews%2F427197%2Frivian-electric-truck-patent-charging-rate%2F"><span class="social-bg icon whatsapp"></span><span class="name">Share on WhatsApp</span></a></li><li class="mailto"><a data-button="" data-id="mailTo" target="_blank" data-extra-params="id:'427197',type_id:'1'" data-share-url="https://insideevs.com/news/427197/rivian-electric-truck-patent-charging-rate/" data-width="600" data-height="400" href="mailto:?body=https%3A%2F%2Finsideevs.com%2Fnews%2F427197%2Frivian-electric-truck-patent-charging-rate%2F&subject=Rivian%27s%20Electric%20Trucks%20Will%20Charge%20Faster%20Than%20All%20Production%20EVs"><span class="social-bg icon mailto"></span><span class="name">Send to email</span></a></li></ul></div></div></div>    </div>


<!--<div class="adminInfoBoxx"></div>-->
<div class="hiddenBlock">
    <div class="apOutstream"><div class="ap" data-place="8" style="width:1px;min-height:1px;" data-dfp-code="EV/ev_us/Outstream" data-width="1" data-height="1" data-dfp-attrs='{"msnt_env":"production","m1_banner_place":"outstream","m1_edition":"ev_us","m1_article_type":"news","m1_page_content_id":427197,"m1_page_type":"detail","m1_page_content_type":"article","m1_makes":["rivian"],"m1_models":["r1s","r1t"],"m1_categories":["battery-tech","charging"],"m1_tags":["electric pickup truck"],"m1_body_types":["truck","truck"],"m1_model_segments":["",""],"m1_banner_position":"outstream"}'></div></div></div>
<div class="apOverlay m1-ap-overlay"><div class="ap" data-place="17" style="width:0px;min-height:0px;" data-dfp-code="EV/ev_us/Overlay" data-width="0" data-height="0" data-dfp-attrs='{"msnt_env":"production","m1_banner_place":"overlay","m1_edition":"ev_us","m1_article_type":"news","m1_page_content_id":427197,"m1_page_type":"detail","m1_page_content_type":"article","m1_makes":["rivian"],"m1_models":["r1s","r1t"],"m1_categories":["battery-tech","charging"],"m1_tags":["electric pickup truck"],"m1_body_types":["truck","truck"],"m1_model_segments":["",""],"m1_banner_position":"overlay"}'></div></div><div class="apOverlay m1-ap-overlay-2"><div class="ap" data-place="18" style="width:0px;min-height:0px;" data-dfp-code="EV/ev_us/Overlay2" data-width="0" data-height="0" data-dfp-attrs='{"msnt_env":"production","m1_banner_place":"overlay2","m1_edition":"ev_us","m1_article_type":"news","m1_page_content_id":427197,"m1_page_type":"detail","m1_page_content_type":"article","m1_makes":["rivian"],"m1_models":["r1s","r1t"],"m1_categories":["battery-tech","charging"],"m1_tags":["electric pickup truck"],"m1_body_types":["truck","truck"],"m1_model_segments":["",""],"m1_banner_position":"overlay2"}'></div></div><div class="apOverlay m1-ap-overlay-3"><div class="ap" data-place="20" style="width:0px;min-height:0px;" data-dfp-code="EV/ev_us/Overlay3" data-width="0" data-height="0" data-dfp-attrs='{"msnt_env":"production","m1_banner_place":"overlay3","m1_edition":"ev_us","m1_article_type":"news","m1_page_content_id":427197,"m1_page_type":"detail","m1_page_content_type":"article","m1_makes":["rivian"],"m1_models":["r1s","r1t"],"m1_categories":["battery-tech","charging"],"m1_tags":["electric pickup truck"],"m1_body_types":["truck","truck"],"m1_model_segments":["",""],"m1_banner_position":"overlay3"}'></div></div><div class="apOverlay m1-ap-overlay-4"><div class="ap" data-place="21" style="width:0px;min-height:0px;" data-dfp-code="EV/ev_us/Overlay4" data-width="0" data-height="0" data-dfp-attrs='{"msnt_env":"production","m1_banner_place":"overlay4","m1_edition":"ev_us","m1_article_type":"news","m1_page_content_id":427197,"m1_page_type":"detail","m1_page_content_type":"article","m1_makes":["rivian"],"m1_models":["r1s","r1t"],"m1_categories":["battery-tech","charging"],"m1_tags":["electric pickup truck"],"m1_body_types":["truck","truck"],"m1_model_segments":["",""],"m1_banner_position":"overlay4"}'></div></div><div class="m1-footer-messages"></div>

<script>
     window.gadsId = false;
</script>
<script>
    var m1FooterMessages = [];
    m1FooterMessages.push({
        message: "This website uses cookies to ensure you get the best experience on our website. By closing this banner, scrolling this page you consent to the use of cookies. <a id='cookie_accept_link' data-id='footerMessageAccept' data-button='' href='/info/cookie-policy/'>More info.</a>",
        name: "cookie_accept"
    });
    </script>

<script defer type="text/javascript" src="https://cdn.motor1.com/kp/static4ui/prod_v2_eks_131/design/build/jslangs/insideevs_en_US_90b1785de5d9d4d318b64a471cb4dd07.js"></script>
<script defer type="text/javascript" src="https://cdn.motor1.com/kp/static4ui/prod_v2_eks_131/design/dist/js/0_516cd2e5f199721dfe2f.js"></script><script defer type="text/javascript" src="https://cdn.motor1.com/kp/static4ui/prod_v2_eks_131/design/dist/js/2_516cd2e5f199721dfe2f.js"></script><script defer type="text/javascript" src="https://cdn.motor1.com/kp/static4ui/prod_v2_eks_131/design/dist/js/11_516cd2e5f199721dfe2f.js"></script>


    
<script>
gtmDataLayer = [{
    'currentEdition': 'ev_us',
    'currentEnv': 'production',
        'pageType': 'detail',
            'entityType': 'article',
            'make': 'Rivian',
            'model': 'R1S',
            'pageId': 'index_articles_detail',
            'entityAuthors': ["Steven Loveday"],
            'pageUrl': 'https://insideevs.com/news/427197/rivian-electric-truck-patent-charging-rate/',
            'pageUrlCanonical': 'https://insideevs.com/news/427197/rivian-electric-truck-patent-charging-rate/',
            'pageLanguage': 'en',
            'entityCategories': ["Battery Tech","Charging"],
            'articleType': 'news',
                    'entityTitle': 'Rivian\'s Electric Trucks Will Charge Faster Than All Production EVs',
            'pageTitle': 'Rivian&#039;s Electric Trucks Will Charge Faster Than All Production EVs',
            'articleId': '427197',
            'tags': ["electric pickup truck"],
                'bodyStyles': ["Truck","Truck"],
        'sessionId': '47c714d44d9814f021cb1d1d072cae25'
}];
</script>
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','gtmDataLayer','GTM-TJCLXGW');</script>

<script>
(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','gtmDataLayer', 'GTM-M4M4LBT');
</script>




<script>
    window.onload = function() {

        if ((typeof $.cookie('PHPSESSID') === 'undefined') || (typeof $.cookie('is_logged_in') !== 'undefined')){
            $.get('/layout-auth-data/', function(data) {
                $('.m1-user-side-label').html(data);
            });
        }

    }

</script>
</body>
</html>