<!DOCTYPE html><html prefix="og: http://ogp.me/ns#" lang="en">
<head>
    <meta charset="utf-8">
    <title>Watch This To Find Out The Best Tesla To Buy Right Now</title>

    <link rel="icon" type="image/png" sizes="32x32" href="/ev-design/src/img/webapp/favicon-32.png">
    <link rel="icon" type="image/png" sizes="96x96" href="/ev-design/src/img/webapp/favicon-96.png">
    <link rel="icon" type="image/png" sizes="128x128" href="/ev-design/src/img/webapp/favicon-128.png">
    <link rel="icon" type="image/png" sizes="195x195" href="/ev-design/src/img/webapp/favicon-195.png">
    <link rel="icon" type="image/png" sizes="196x196" href="/ev-design/src/img/webapp/favicon-196.png">
    <link rel="icon" type="image/png" sizes="228x228" href="/ev-design/src/img/webapp/favicon-228.png">
    <link rel="apple-touch-icon-precomposed" href="/ev-design/src/img/webapp/favicon-57.png">
    <link rel="apple-touch-icon" sizes="114x114" href="/ev-design/src/img/webapp/favicon-114.png">
    <link rel="apple-touch-icon" sizes="72x72" href="/ev-design/src/img/webapp/favicon-72.png">
    <link rel="apple-touch-icon" sizes="144x144" href="/ev-design/src/img/webapp/favicon-144.png">
    <link rel="apple-touch-icon" sizes="60x60" href="/ev-design/src/img/webapp/favicon-60.png">
    <link rel="apple-touch-icon" sizes="120x120" href="/ev-design/src/img/webapp/favicon-120.png">
    <link rel="apple-touch-icon" sizes="76x76" href="/ev-design/src/img/webapp/favicon-76.png">
    <link rel="apple-touch-icon" sizes="152x152" href="/ev-design/src/img/webapp/favicon-152.png">
    <link rel="apple-touch-icon" sizes="180x180" href="/ev-design/src/img/webapp/favicon-180.png">

    <meta name="msapplication-square128x128logo" content="/ev-design/src/img/webapp/smalltile.png"/>
    <meta name="msapplication-square270x270logo" content="/ev-design/src/img/webapp/mediumtile.png"/>
    <meta name="msapplication-square580x580logo" content="/ev-design/src/img/webapp/largetile.png"/>

    <link rel="shortcut icon" type="image/x-icon" href="/favicon.ico"/>
            <link href="https://fonts.googleapis.com/css?family=Open+Sans:300,400,600,700" rel="stylesheet">
    
    

        <script>
        window.polymerLocale = 'en-US';
        window.polymerLocalePath = 'https://cdn.motor1.com/kp/static4ui/prod_v2_eks_93/polymer2/locales1582218092/en-US.json';
        var jsVars = {"services":{"brealtime":{"load":0,"id":"12851701"}},"ads":{"dfp":{"id":"6122441"}},"ui":{"auto_infinite_scroll":true}};    </script>

    
    <link title="Latest news" type="application/rss+xml" rel="alternate" href="/rss/news/all/"/>
    <link title="Latest videos" type="application/rss+xml" rel="alternate" href="/rss/videos/all/"/>
    <meta name="description" content="We take a look at a Teslanomics video where they compare all currently-available Tesla cars and declare which one is the best one to buy. ">
<meta property="og:title" content="Watch This To Find Out The Best Tesla To Buy Right Now">
<meta property="og:type" content="article">
<meta property="og:url" content="https://insideevs.com/features/399868/best-tesla-buy-now-video/">
<meta property="og:image" content="https://cdn.motor1.com/images/mgl/6BLve/s3/top-five-reasons-why-consumers-buy-tesla-cars-video.jpg">
<meta property="og:image:width" content="1280">
<meta property="og:image:height" content="720">
<meta property="og:description" content="We take a look at a Teslanomics video where they compare all currently-available Tesla cars and declare which one is the best one to buy. ">
<meta property="og:site_name" content="InsideEVs">
<meta property="fb:admins" content="100001157785488">
<meta property="fb:app_id" content="984245018262500">
<meta property="fb:pages" content="357684877628739">
<meta property="twitter:card" content="summary_large_image">
<meta property="twitter:site" content="InsideEVs">
<meta property="twitter:title" content="Watch This To Find Out The Best Tesla To Buy Right Now">
<meta property="twitter:description" content="Teslanomics weighs in to declare the &quot;best buy.&quot;">
<meta property="twitter:image" content="https://cdn.motor1.com/images/mgl/6BLve/s3/top-five-reasons-why-consumers-buy-tesla-cars-video.jpg">
<meta property="robots" content="max-snippet:50, max-video-preview:10">
<meta name="speakable-description" content="Teslanomics evaluated which Tesla is the best buy today.
We check out Teslanomics&#039; video comparison of all three Tesla models to declare which one is the best buy today. ">
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<meta http-equiv="X-UA-Compatible" content="IE=edge"><link href="https://insideevs.com/features/399868/best-tesla-buy-now-video/" hreflang="x-default" rel="alternate">
<link href="https://insideevs.com/features/399868/best-tesla-buy-now-video/" hreflang="en" rel="alternate">
<link href="https://insideevs.com/features/399868/best-tesla-buy-now-video/" rel="canonical">
<link href="https://insideevs.com/features/399868/best-tesla-buy-now-video/amp/" rel="amphtml">    <link rel="stylesheet" type="text/css" href="https://cdn.motor1.com/kp/static4ui/prod_v2_eks_93/design/dist/css/0_9fc83e530579237d065b.css"><link rel="stylesheet" type="text/css" href="https://cdn.motor1.com/kp/static4ui/prod_v2_eks_93/design/dist/css/1_9fc83e530579237d065b.css"><link rel="stylesheet" type="text/css" href="https://cdn.motor1.com/kp/static4ui/prod_v2_eks_93/design/dist/css/3_9fc83e530579237d065b.css"><link rel="stylesheet" type="text/css" href="https://cdn.motor1.com/kp/static4ui/prod_v2_eks_93/design/dist/css/4_9fc83e530579237d065b.css"><link rel="stylesheet" type="text/css" href="https://cdn.motor1.com/kp/static4ui/prod_v2_eks_93/design/dist/css/13_9fc83e530579237d065b.css"><link rel="stylesheet" type="text/css" href="https://cdn.motor1.com/kp/static4ui/prod_v2_eks_93/design/dist/css/21_9fc83e530579237d065b.css"><link rel="stylesheet" type="text/css" href="https://cdn.motor1.com/kp/static4ui/prod_v2_eks_93/design/dist/css/index_articles_detail_9fc83e530579237d065b.css">            <link rel="stylesheet" type="text/css" href="https://cdn.motor1.com/kp/static4ui/prod_v2_eks_93/ev-design/dist/css/0_c0517287628a344c4398.css">    
    <script>
        window.isAuthorized = 0    </script>


    

        


</head>
<body         class="nojs not-touch
            m1-fullwidth-layout            bgWhite                                                            "
        data-spotim-id="" data-edtn="ev_us"
        data-track-url="" >

<div data-role="page" id="page_index_articles_detail" class="root">

    <div id="layout_header_spacer"></div>
<div class="m1-header-main">
    <div class="m1-header-main-box">
        <div class="m1-header-main-box-wrapper">
            <div class="box-item-left">
                <div class="m1-hamburger-button" data-hide-scroll="m1-left-side-box" data-close-delay="0.5" data-delay="0.01" onclick="" data-button data-id="toggleBox" data-value="mainMenu" data-clear="2" data-multi>
                    <span></span>
                    <span></span>
                    <span></span>
                </div>

            </div>
            <div class="wrapper-box-item-center">
                <div class="box-item-center">
                    <a class="m1-header-logo" href="/" title="Home">
                        <img class="logo_placeholder" src="data:image/png;base64,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" alt="logo">
                    </a>
                </div>
            </div>
            <div class="m1-header-main-box-wrapper-sub" style="position: relative;">
                <div class="box-item-pre-left">
                    <ul class="m1-navigation-main print-hide">
                        <li class="grand top left mobile">
            <a href="/news/"  >
                                    News                            </a>
        </li>
                    <li class="grand top left">
            <a href="/reviews/"  >
                                    Reviews                            </a>
        </li>
                    <li class="grand left">
            <a href="/features/"  >
                                    Features                            </a>
        </li>
                    <li class="mobile">
            <a href="/tesla/"  >
                                    Tesla                            </a>
        </li>
                    <li class="top left">
            <a href="/reviews/344001/compare-evs/"  >
                                    Compare EVs                            </a>
        </li>
                    <li class="left">
            <a href="/news/344002/charger-guide/"  >
                                    Charger Guide                            </a>
        </li>
                    <li class="left">
            <a href="/features/category/buying-advice/"  >
                                    Buying Advice                            </a>
        </li>
                    <li class="left">
            <a href="/news/343998/monthly-plug-in-ev-sales-scorecard/"  >
                                    EV Sales Scorecard                            </a>
        </li>
                    <li class="mobile">
            <a href="/news/343998/monthly-plug-in-ev-sales-scorecard/"  >
                                    EV Sales                            </a>
        </li>
                    <li class="left">
            <a href="/news/?sc=1"  >
                                    Categories                            </a>
        </li>
                    <li class="left">
            <a href="/makes/"  >
                                    Makes                            </a>
        </li>
                    <li class="left">
            <a href="/body-styles/"  >
                                    Body Style                            </a>
        </li>
                    <li class="left top _blank">
            <a href="https://insideevsforum.com/community/index.php"  target = "_blank">
                                    Forum                            </a>
        </li>
                    <li class="left _blank">
            <a href="https://www.myev.com/?utm_source=insideevs.com&utm_campaign=IEVmenu"  target = "_blank">
                                    Buy                            </a>
        </li>
                    <li class="photos ico left">
            <a href="/photos/"  >
                                    Photos                            </a>
        </li>
                    <li class="videos ico left">
            <a href="/videos/"  >
                                    Videos                            </a>
        </li>
                    <li class="top plugin-sale">
            <a href="/news/343998/monthly-plug-in-ev-sales-scorecard/"  >
                                    Ev Sales Scorecard                            </a>
        </li>
    </ul>                </div>
                                    <!-- <div class="wrapper-plugin-sale">
                        <div class="top plugin-sale">
                            <a href="https://insideevs.com/monthly-plug-in-sales-scorecard/">Ev Sales Scorecard</a>
                        </div>
                    </div> -->
                                                    <div class="m1-search-form-button-wrapper">
                        <button class="m1-search-form-button-animate icon-search"
                                onclick
                                data-button
                                data-id="toggleBox"
                                data-clear="1"
                                data-value="searchBox"
                                data-multi
                                type="submit">
                        </button>
                        <div class="m1-search-panel">
                            <form action="/search/" class="m1-search-form" method="GET" id="header_search_form" data-native="0" novalidate="novalidate">
                                <input class="m1-search-panel-input m1-search-form-text" id="search_input" type="text" value="" name="q" placeholder="Search" autocomplete="off">
                                <button class="m1-search-panel-button m1-search-form-button-animate icon-search " type="submit">
                                </button>
                                <button onclick=""
                                        data-button
                                        data-id="toggleBox"
                                        data-value="searchBox"
                                        data-clear="1"
                                        data-toggle="1"
                                        data-multi
                                        class="m1-search-panel-button m1-drawer-close-button">
                                </button>
                            </form>
                        </div>
                    </div>
                            </div>

                           <div class="box-item-right">
                    <div class="m1-editions-switcher-m" data-hide-scroll="m1-scrollbar" data-close-delay="0.5"  data-delay="0.01" onclick="" data-button data-id="toggleBox" data-value="editionsMenu" data-clear="2" data-multi>
                                                <span class="edf edf-230"></span>
                                            </div>
                    <div class="m1-editions-switcher" data-hide-scroll="m1-scrollbar" data-close-delay="0.5" data-delay="0.01" onclick="" data-button data-id="toggleBox" data-value="editionsMenu" data-clear="2" data-multi>
                                                <span class="edf edf-230"></span>
                                                <span class="title">USA / Global</span>
                    </div>
                </div>
                    </div>
    </div>
</div>
<div class="m1-header-ad top-banner-placeholder">
    <div class="m1-gapb-topside"><div class="m1-apb mleaderboard"><div class="ap" data-place="10" style="width:320px;min-height:1px;" data-dfp-code="EV/ev_us/Mobile_Leaderboard" data-sizes="320x1,320x50,320x100" data-width="320" data-height="1" data-dfp-attrs='{"msnt_env":"k-production","m1_banner_place":"top-banners","m1_edition":"ev_us","m1_article_type":"features","m1_page_content_id":399868,"m1_page_type":"detail","m1_page_content_type":"video","m1_makes":["tesla"],"m1_models":["model-s","model-3","model-x"],"m1_categories":["buying-advice"],"m1_tags":["Teslanomics"],"m1_body_types":["sedan","sedan","suv"],"m1_model_segments":["f","c","e"],"m1_banner_position":"top","m1_banner_position_view":"above-the-fold"}'></div></div><div class="m1-apb leaderboard"><div class="ap" data-place="1" style="width:728px;min-height:1px;" data-dfp-code="EV/ev_us/Leaderboard" data-sizes="728x1,728x90" data-width="728" data-height="1" data-dfp-attrs='{"msnt_env":"k-production","m1_banner_place":"top-banners","m1_edition":"ev_us","m1_article_type":"features","m1_page_content_id":399868,"m1_page_type":"detail","m1_page_content_type":"video","m1_makes":["tesla"],"m1_models":["model-s","model-3","model-x"],"m1_categories":["buying-advice"],"m1_tags":["Teslanomics"],"m1_body_types":["sedan","sedan","suv"],"m1_model_segments":["f","c","e"],"m1_banner_position":"top","m1_banner_position_view":"above-the-fold"}'></div></div><div class="m1-apb super"><div class="ap" data-place="6" style="width:970px;min-height:1px;" data-dfp-code="EV/ev_us/Super" data-sizes="970x1,970x90,970x250,980x250" data-width="970" data-height="1" data-dfp-attrs='{"msnt_env":"k-production","m1_banner_place":"top-banners","m1_edition":"ev_us","m1_article_type":"features","m1_page_content_id":399868,"m1_page_type":"detail","m1_page_content_type":"video","m1_makes":["tesla"],"m1_models":["model-s","model-3","model-x"],"m1_categories":["buying-advice"],"m1_tags":["Teslanomics"],"m1_body_types":["sedan","sedan","suv"],"m1_model_segments":["f","c","e"],"m1_banner_position":"top","m1_banner_position_view":"above-the-fold"}'></div></div></div></div>    <div class="pageAdSkin" id="page_skin_top">
        <div class="adSizer"><img alt="" src="data:image/gif;base64,R0lGODlhAQABAIAAAP///wAAACH5BAEAAAAALAAAAAABAAEAAAICRAEAOw=="></div>
        <a class="pageAdSkinUrl"></a>
    </div>
    
<script type="application/ld+json">
    {"@context":"http:\/\/schema.org","@type":"NewsArticle","headline":"Watch This To Find Out The Best Tesla To Buy Right Now","name":"Watch This To Find Out The Best Tesla To Buy Right Now","description":"Teslanomics weighs in to declare the \"best buy.\"","author":{"@type":"Person","name":"Tom Moloughney"},"url":"https:\/\/insideevs.com\/features\/399868\/best-tesla-buy-now-video\/","sameAs":["https:\/\/www.facebook.com\/InsideeVs\/","https:\/\/twitter.com\/InsideEVs","https:\/\/flipboard.com\/@InsideEVs"],"datePublished":"2020-02-21T12:19:58+00:00","dateModified":"2020-02-21T12:19:58+00:00","publisher":{"@type":"Organization","name":"InsideEVs","logo":{"@type":"ImageObject","url":"https:\/\/insideevs.com\/logo.jpg","width":"325","height":"60"}},"image":{"@type":"ImageObject","url":"https:\/\/cdn.motor1.com\/images\/mgl\/6BLve\/s1\/top-five-reasons-why-consumers-buy-tesla-cars-video.jpg","width":"1920","height":"1080"},"mainEntityOfPage":"https:\/\/insideevs.com\/features\/399868\/best-tesla-buy-now-video\/","wordCount":"308"}</script>

    <script type="application/ld+json">
        {"@context":"http:\/\/schema.org","@type":"VideoObject","contentURL":"https:\/\/insideevs.com\/features\/399868\/best-tesla-buy-now-video\/","name":"Watch This To Find Out The Best Tesla To Buy Right Now","description":"Teslanomics weighs in to declare the \"best buy.\"","uploadDate":"2020-02-21T12:19:58+00:00","thumbnailUrl":"https:\/\/cdn.motor1.com\/images\/mgl\/6BLve\/s1\/top-five-reasons-why-consumers-buy-tesla-cars-video.jpg","duration":"PT13M52S"}    </script>

    <script type="application/ld+json">
        {"@context":"https:\/\/schema.org\/","@type":"WebPage","name":"Watch This To Find Out The Best Tesla To Buy Right Now","speakable":{"@type":"SpeakableSpecification","xpath":["\/html\/head\/title","\/html\/head\/meta[@name='speakable-description']\/@content"]},"url":"https:\/\/insideevs.com\/features\/399868\/best-tesla-buy-now-video\/"}    </script>

        <script type="application/ld+json">
        {"@context":"https:\/\/schema.org","@type":"BreadcrumbList","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https:\/\/insideevs.com\/"},{"@type":"ListItem","position":2,"name":"Tesla","item":"https:\/\/insideevs.com\/tesla\/"},{"@type":"ListItem","position":3,"name":"Model S","item":"https:\/\/insideevs.com\/tesla\/model-s\/"},{"@type":"ListItem","position":4,"name":"Features","item":"https:\/\/insideevs.com\/tesla\/model-s\/features\/"},{"@type":"ListItem","position":5,"name":"Buying Advice","item":"https:\/\/insideevs.com\/tesla\/model-s\/features\/category\/buying-advice\/"}]}    </script>



    <div class="pre-center breadcrumbs-area">
                <div slot="breadcrumbs" class="breadcrumbs">
        <a href="/">Home</a><span class="sep"></span><a href="/tesla/">Tesla</a><span class="sep"></span><a href="/tesla/model-s/">Model S</a><span class="sep"></span><a href="/tesla/model-s/features/">Features</a><span class="sep"></span><a href="/tesla/model-s/features/category/buying-advice/">Buying Advice</a>    </div>
        <h1 class="m1-article-title">Watch This To Find Out The Best Tesla To Buy Right Now</h1>
    </div>
    <div class="kpre-center videoBoxArticle">
        <div class="videoBoxArticle-wrapper">
            
<img class="sizer" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAABAAAAAJCAYAAAA7KqwyAAAAGXRFWHRTb2Z0d2FyZQBBZG9iZSBJbWFnZVJlYWR5ccllPAAAABpJREFUeNpi/P//PwMlgImBQjBqwLAwACDAAOVfAw9/ZDvcAAAAAElFTkSuQmCC" alt=""/>            <div class="video-player">
                <iframe width="560" height="315" src="https://www.youtube.com/embed/E0ZcrB5yMQM" frameborder="0" allow="accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe>            </div>
        </div> 
    </div>


<div class="pre-center padding h-entry b-padding-skin pre-center-feature" id="post_box">
    <div data-bubbles="keyword" data-url="/news/store-keywords/" data-name="id"></div>
    <div class="content-area " id="article_box" >
                    <span class="summary p-name" style="display: none;">Watch This To Find Out The Best Tesla To Buy Right Now</span>


            <span style="display: none;" class="type">product</span>

                    <span style="display: none;" class="dt-published dtreviewed">2020-02-21 12:19:58</span>

                    <a style="display: none" rel="bookmark" href="https://insideevs.com/features/399868/best-tesla-buy-now-video/" class="permalink u-url">https://insideevs.com/features/399868/best-tesla-buy-now-video/</a>

                <span class="p-item item vcard" style="display: none;">
            <span class="fn">
                                                            Tesla Model S                                            Tesla Model 3                                            Tesla Model X                                                </span>
        </span>

                <span class="p-category" style="display: none;">
                                                                                                                                                                    
            Buying Advice, Teslanomics        </span>

        <div class="content-area-box">
                            <div class="postTopInfo">
                                        <div class="postDate">
                            <span class="date" data-time="1582269598">
                    <a href="/2020/02/21/">
                Feb 21, 2020            </a>
                <span class="small">at</span>
                    7:19am            </span>
                    </div>

                    <div class="shareTrendingBox">
                                                                                    <script id="dsq-count-scr" src="//insideevscom.disqus.com/count.js" async></script>                                <a title="Add a comment" href="/features/399868/best-tesla-buy-now-video/#comments" class="disqus-comment-count" data-disqus-identifier="en-article-399868" data-disqus-url="/features/399868/best-tesla-buy-now-video/"></a>                                                                                                    <div slot="share-box" class="big-shareBox shareBox share-box-dropdown to-down"><div class="share-box-wrapper"><span class="shareBox-separator" data-value="share-list-1582288864" data-button onClick="" data-id="toggleBox" data-static> <span class="active"><span class="icon-plus">+</span></span><span class="passive"><span class="icon-plus">+</span></span></span><a href="https://insideevs.com/features/399868/best-tesla-buy-now-video/" class="share-button"><span class="name">Share</span><span class="icon share-empty"></span></a><div class="share-list" data-button-target="share-list-1582288864"><ul><li class="facebook"><a data-button="" data-id="share" data-url="/connect/share/" data-name="network_id" target="_blank" data-extra-params="id:'399868',type_id:'1'" data-value="1" data-share-network="Facebook" data-share-url="https://insideevs.com/features/399868/best-tesla-buy-now-video/" data-width="600" data-height="600" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Finsideevs.com%2Ffeatures%2F399868%2Fbest-tesla-buy-now-video%2F"><span class="social-bg icon facebook"></span><span class="name">Share on Facebook</span></a></li><li class="twitter"><a data-button="" data-id="share" data-url="/connect/share/" data-name="network_id" target="_blank" data-extra-params="id:'399868',type_id:'1'" data-value="2" data-share-network="Twitter" data-share-url="https://insideevs.com/features/399868/best-tesla-buy-now-video/" data-width="600" data-height="450" href="https://twitter.com/intent/tweet?url=https%3A%2F%2Finsideevs.com%2Ffeatures%2F399868%2Fbest-tesla-buy-now-video%2F&text=Watch+This+To+Find+Out+The+Best+Tesla+To+Buy+Right+Now&via=insideevs.com"><span class="social-bg icon twitter"></span><span class="name">Share on Twitter</span></a></li><li class="linkedin"><a data-button="" data-id="share" data-url="/connect/share/" data-name="network_id" target="_blank" data-extra-params="id:'399868',type_id:'1'" data-value="3" data-share-network="LinkedIn" data-share-url="https://insideevs.com/features/399868/best-tesla-buy-now-video/" data-width="600" data-height="600" href="https://www.linkedin.com/cws/share?url=https%3A%2F%2Finsideevs.com%2Ffeatures%2F399868%2Fbest-tesla-buy-now-video%2F"><span class="social-bg icon linkedin"></span><span class="name">Share on LinkedIn</span></a></li><li class="flipboard"><a data-button="" data-id="share" data-url="/connect/share/" data-name="network_id" target="_blank" data-extra-params="id:'399868',type_id:'1'" data-value="7" data-share-network="Flipboard" data-share-url="https://insideevs.com/features/399868/best-tesla-buy-now-video/" data-width="600" data-height="600" href="https://share.flipboard.com/bookmarklet/popout?url=https%3A%2F%2Finsideevs.com%2Ffeatures%2F399868%2Fbest-tesla-buy-now-video%2F&title=Watch+This+To+Find+Out+The+Best+Tesla+To+Buy+Right+Now&v=2"><span class="social-bg icon flipboard"></span><span class="name">Share on Flipboard</span></a></li><li class="reddit"><a data-button="" data-id="share" data-url="/connect/share/" data-name="network_id" target="_blank" data-extra-params="id:'399868',type_id:'1'" data-value="6" data-share-network="Reddit" data-share-url="https://insideevs.com/features/399868/best-tesla-buy-now-video/" data-width="900" data-height="600" href="https://www.reddit.com/submit?url=https%3A%2F%2Finsideevs.com%2Ffeatures%2F399868%2Fbest-tesla-buy-now-video%2F"><span class="social-bg icon reddit"></span><span class="name">Share on Reddit</span></a></li><li class="whatsapp"><a data-button="" data-id="share" data-url="/connect/share/" data-name="network_id" target="_blank" data-extra-params="id:'399868',type_id:'1'" data-value="6" data-share-network="WhatsApp" data-share-url="https://insideevs.com/features/399868/best-tesla-buy-now-video/" data-width="600" data-height="600" href="https://api.whatsapp.com/send?text=https%3A%2F%2Finsideevs.com%2Ffeatures%2F399868%2Fbest-tesla-buy-now-video%2F"><span class="social-bg icon whatsapp"></span><span class="name">Share on WhatsApp</span></a></li><li class="mailto"><a data-button="" data-id="mailTo" target="_blank" data-extra-params="id:'399868',type_id:'1'" data-share-url="https://insideevs.com/features/399868/best-tesla-buy-now-video/" data-width="600" data-height="400" href="mailto:?body=https%3A%2F%2Finsideevs.com%2Ffeatures%2F399868%2Fbest-tesla-buy-now-video%2F&subject=Watch%20This%20To%20Find%20Out%20The%20Best%20Tesla%20To%20Buy%20Right%20Now"><span class="social-bg icon mailto"></span><span class="name">Send to email</span></a></li></ul></div></div></div>                    </div>

                        <div class="postAuthorBox withAvatar" xmlns="http://www.w3.org/1999/xhtml">
                    <div class="postAuthorThumb">
                <a class="userRThumb" href="/info/team/tom-moloughney/">
                    <img src="https://cdn.motor1.com/images/atr/y2go/s4/tom-moloughney.jpg" alt="Tom Moloughney" />
                </a>
            </div>
                <div class="postAuthorInfo">
            <div class="postAuthor">
                <span class="name">
                    <span class="label">By</span>:
                                            <a class="author h-card reviewer p-author vcard url fn" content="Tom Moloughney" href="/info/team/tom-moloughney/">Tom Moloughney</a>
                                    </span>
            </div>
                                            </div>
    </div>
                    <div class="clear"></div>

                </div>

            <div class="postContent content-wrapper">

                                    <h2 class="preview">
                        Teslanomics weighs in to declare the "best buy."                    </h2>
                                                <div class="postBody description e-content">
                                <p>Ben Sullins of <a href="https://insideevs.com/tag/teslanomics/" target="_blank" rel="noopener">Teslanomics</a> recently put out another excellent <a href="https://insideevs.com/tesla/" target="_blank" rel="noopener" data-inline-widget="internal-links" data-type-id="1" data-params="%7B%22is_checked%22%3Atrue%2C%22alias%22%3A%22tesla%22%7D">Tesla</a> video, this time comparing the <a href="https://insideevs.com/tesla/model-s/" target="_blank" rel="noopener" data-inline-widget="internal-links" data-type-id="0" data-params="%7B%22is_checked%22%3Atrue%2C%22make_alias%22%3A%22tesla%22%2C%22alias%22%3A%22model-s%22%7D">Model S</a>, X, and 3, and declaring which one is currently the "Best Buy."</p>
<p>Sullins grades Tesla's three offerings in five categories: range, performance, tech, price, and style. The grading system is 1 to 3, with #1 going to the best car in that category. Therefore, after adding up all 5 categories, the lowest score should be the winner. </p>
<section class="relatedContent-new" contenteditable="false" draggable="true" data-widget="related-content" data-widget-size="content" data-params="%7B%22type_id%22%3A0%2C%22title_id%22%3A%22%22%2C%22items%22%3A%5B%7B%22article_edition_id%22%3A%22399837%22%2C%22title%22%3A%22Tesla%20Is%20Now%20Consumer%20Reports'%20Highest%20Ranked%20U.S.%20Automotive%20Brand%22%2C%22alias%22%3A%22tesla-tops-consumer-reports-u-s%22%2C%22section%22%3A%221%22%2C%22is_checked%22%3Atrue%2C%22is_video%22%3A%220%22%2C%22images%22%3A%7B%22s5%22%3A%22https%3A%2F%2Fcdn.motor1.com%2Fimages%2Fmgl%2FA81oL%2Fs5%2F2019-tesla-model-3-comparison.jpg%22%7D%7D%2C%7B%22article_edition_id%22%3A%22399826%22%2C%22title%22%3A%22Nissan%20LEAF%20Driver%20Unplugs%20Tesla%20To%20Get%20Some%20Juice%20In%20Dallas%2C%20TX%22%2C%22alias%22%3A%22nissan-leaf-driver-unplugs-tesla-video%22%2C%22section%22%3A%221%22%2C%22is_checked%22%3Atrue%2C%22is_video%22%3A%221%22%2C%22images%22%3A%7B%22s5%22%3A%22https%3A%2F%2Fcdn.motor1.com%2Fimages%2Fmgl%2FQ0Bo7%2Fs5%2Ftesla-gets-unplugged-by-nissan-leaf-driver-in-dallas-tx.jpg%22%7D%7D%2C%7B%22article_edition_id%22%3A%22399848%22%2C%22title%22%3A%22Will%20Tesla%20Autopilot%20Hit%20A%20Dog%2C%20A%20Human%20Or%20A%20Traffic%20Cone%3F%22%2C%22alias%22%3A%22tesla-autopilot-hit-dog-person%22%2C%22section%22%3A%221%22%2C%22is_checked%22%3Atrue%2C%22is_video%22%3A%221%22%2C%22images%22%3A%7B%22s5%22%3A%22https%3A%2F%2Fcdn.motor1.com%2Fimages%2Fmgl%2Fjvr1N%2Fs5%2Fmaxresdefault.jpg%22%7D%7D%2C%7B%22article_edition_id%22%3A%22399758%22%2C%22title%22%3A%22With%20Lowest%20Depreciation%2C%20Tesla%20Model%203%20Is%20Best%20Car%20To%20Buy%20New%22%2C%22alias%22%3A%22tesla-model-3-best-car-buy-new%22%2C%22section%22%3A%221%22%2C%22is_checked%22%3Atrue%2C%22is_video%22%3A%220%22%2C%22images%22%3A%7B%22s5%22%3A%22https%3A%2F%2Fcdn.motor1.com%2Fimages%2Fmgl%2F4MzjA%2Fs5%2Fwith-lowest-depreciation-tesla-model-3-is-the-best-car-to-buy-new.jpg%22%7D%7D%5D%7D"> <h2 class="trending-content_header">Tesla news</h2> <div class="wrapper-related-item"> <div class="related-item"><a href="https://insideevs.com/news/399837/tesla-tops-consumer-reports-u-s/" target="_blank" rel="noopener"> <span class="lazy related-item-img"> <img src="https://cdn.motor1.com/custom/share/placeholder_0.jpg" alt="tesla tops consumer reports u s" data-srcset="https://cdn.motor1.com/images/mgl/A81oL/s6/2019-tesla-model-3-comparison.jpg 1x,
https://cdn.motor1.com/images/mgl/A81oL/s4/2019-tesla-model-3-comparison.jpg 2x" data-src="https://cdn.motor1.com/images/mgl/A81oL/s6/2019-tesla-model-3-comparison.jpg" /> </span> <span class="title-related-item">Tesla Is Now Consumer Reports' Highest Ranked U.S. Automotive Brand</span> </a></div> <div class="related-item"><a href="https://insideevs.com/news/399826/nissan-leaf-driver-unplugs-tesla-video/" target="_blank" rel="noopener"> <span class="lazy related-item-img"> <span class="icon play">⠀</span> <img src="https://cdn.motor1.com/custom/share/placeholder_1.jpg" alt="nissan leaf driver unplugs tesla video" data-srcset="https://cdn.motor1.com/images/mgl/Q0Bo7/s6/tesla-gets-unplugged-by-nissan-leaf-driver-in-dallas-tx.jpg 1x,
https://cdn.motor1.com/images/mgl/Q0Bo7/s4/tesla-gets-unplugged-by-nissan-leaf-driver-in-dallas-tx.jpg 2x" data-src="https://cdn.motor1.com/images/mgl/Q0Bo7/s6/tesla-gets-unplugged-by-nissan-leaf-driver-in-dallas-tx.jpg" /> </span> <span class="title-related-item">Nissan LEAF Driver Unplugs Tesla To Get Some Juice In Dallas, TX</span> </a></div> <div class="related-item"><a href="https://insideevs.com/news/399848/tesla-autopilot-hit-dog-person/" target="_blank" rel="noopener"> <span class="lazy related-item-img"> <span class="icon play">⠀</span> <img src="https://cdn.motor1.com/custom/share/placeholder_2.jpg" alt="tesla autopilot hit dog person" data-srcset="https://cdn.motor1.com/images/mgl/jvr1N/s6/maxresdefault.jpg 1x,
https://cdn.motor1.com/images/mgl/jvr1N/s4/maxresdefault.jpg 2x" data-src="https://cdn.motor1.com/images/mgl/jvr1N/s6/maxresdefault.jpg" /> </span> <span class="title-related-item">Will Tesla Autopilot Hit A Dog, A Human Or A Traffic Cone?</span> </a></div> <div class="related-item"><a href="https://insideevs.com/news/399758/tesla-model-3-best-car-buy-new/" target="_blank" rel="noopener"> <span class="lazy related-item-img"> <img src="https://cdn.motor1.com/custom/share/placeholder_3.jpg" alt="tesla model 3 best car buy new" data-srcset="https://cdn.motor1.com/images/mgl/4MzjA/s6/with-lowest-depreciation-tesla-model-3-is-the-best-car-to-buy-new.jpg 1x,
https://cdn.motor1.com/images/mgl/4MzjA/s4/with-lowest-depreciation-tesla-model-3-is-the-best-car-to-buy-new.jpg 2x" data-src="https://cdn.motor1.com/images/mgl/4MzjA/s6/with-lowest-depreciation-tesla-model-3-is-the-best-car-to-buy-new.jpg" /> </span> <span class="title-related-item">With Lowest Depreciation, Tesla Model 3 Is Best Car To Buy New</span> </a></div> </div> </section>
<p>The <a href="https://insideevs.com/tesla/model-s/" target="_blank" rel="noopener" data-inline-widget="internal-links" data-type-id="0" data-params="%7B%22is_checked%22%3Atrue%2C%22make_alias%22%3A%22tesla%22%2C%22alias%22%3A%22model-s%22%7D">M<span style="font-size: 16px; font-family: var(--main-font-family);">odel S</span></a><span style="font-size: 16px; font-family: var(--main-font-family);"> wins on points, with a total score of only 6. The second-place score of 11 went to the <a href="https://insideevs.com/tesla/model-x/" target="_blank" rel="noopener" data-inline-widget="internal-links" data-type-id="0" data-params="%7B%22is_checked%22%3Atrue%2C%22make_alias%22%3A%22tesla%22%2C%22alias%22%3A%22model-x%22%7D">Model X</a> and bringing up the rear was the <a href="https://insideevs.com/tesla/model-3/" target="_blank" rel="noopener" data-inline-widget="internal-links" data-type-id="0" data-params="%7B%22is_checked%22%3Atrue%2C%22make_alias%22%3A%22tesla%22%2C%22alias%22%3A%22model-3%22%7D">Model 3</a> with a total score of 12.</span></p><div class="apInarticleSmallRes"><div class="ap" data-place="16" style="width:300px;min-height:1px;" data-dfp-code="EV/ev_us/Mobile_Rectangle" data-sizes="300x1,300x250,300x600" data-width="300" data-height="1" data-dfp-attrs='{"lazy":1,"msnt_env":"k-production","m1_banner_place":"inarticle-small-res","m1_edition":"ev_us","m1_article_type":"features","m1_page_content_id":399868,"m1_page_type":"detail","m1_page_content_type":"video","m1_makes":["tesla"],"m1_models":["model-s","model-3","model-x"],"m1_categories":["buying-advice"],"m1_tags":["Teslanomics"],"m1_body_types":["sedan","sedan","suv"],"m1_model_segments":["f","c","e"],"m1_banner_position":"inarticle-small-res"}'></div></div>
<p><span style="font-size: 16px; font-family: var(--main-font-family);">However, when Sullins completes the comparison he declares the Model 3 the clear winner, even stating "It has to be". When he explains his reasoning, we realize each category doesn't carry the same weight in his judgment. </span></p>
<section contenteditable="false" draggable="true" data-widget="image" data-border="" data-id="4780356" data-title="My Long-Range AWD Tesla Model 3 in the mountains of Vermont"><picture class="lazy"> <source srcset="https://cdn.motor1.com/custom/share/placeholder_0.jpg" data-srcset="https://cdn.motor1.com/images/mgl/v1lVv/s1/tesla-model-3.jpg 1x,
https://cdn.motor1.com/images/mgl/v1lVv/s1/tesla-model-3.jpg 2x" /> <img draggable="false" src="https://cdn.motor1.com/custom/share/placeholder_0.jpg" alt="Tesla Model 3" data-srcset="https://cdn.motor1.com/images/mgl/v1lVv/s3/tesla-model-3.jpg 1x,
https://cdn.motor1.com/images/mgl/v1lVv/s1/tesla-model-3.jpg 2x" data-src="https://cdn.motor1.com/images/mgl/v1lVv/s3/tesla-model-3.jpg" /> </picture> <div class="photo-title">My Long-Range AWD Tesla Model 3 in the mountains of Vermont</div> </section>
<p><span style="font-size: 16px; font-family: var(--main-font-family);">Sullens point to the advantages the Model 3 has over the other Teslas because of the price and also the V3 charging rates. The higher speed of charging that the Model 3 is capable of makes it possibly a better road trip car than a longer-range Model S. </span></p><div class="item m1-ap-native"><div class="ap" data-place="22"  data-dfp-code="EV/ev_us/Native" data-sizes="fluid,1x1" data-width="1" data-height="1" data-dfp-attrs='{"m1_native":"2","msnt_env":"k-production","m1_banner_place":"native","m1_edition":"ev_us","m1_article_type":"features","m1_page_content_id":399868,"m1_page_type":"detail","m1_page_content_type":"video","m1_makes":["tesla"],"m1_models":["model-s","model-3","model-x"],"m1_categories":["buying-advice"],"m1_tags":["Teslanomics"],"m1_body_types":["sedan","sedan","suv"],"m1_model_segments":["f","c","e"],"m1_banner_position":"native"}'></div></div>
<p><span style="font-size: 16px; font-family: var(--main-font-family);">Take a look at the video and let us know if you agree with Ben. Personally, I'm not arguing with him because I happen to drive the specific model he points out as his "best buy", a dual-motor long-range Model 3, and I wouldn't trade it for any other Tesla. </span></p>                </div>


<!--                !ToDO NEw SOURCES -->
                    
                <div class="sapb"><div class="apb mleaderboard" style="padding:15px 0 15px 0;"><div class="ap" data-place="24" style="width:290px;min-height:1px;" data-dfp-code="EV/ev_us/Mobile_Leaderboard/Social" data-sizes="290x1,290x100" data-width="290" data-height="1" data-dfp-attrs='{"lazy":1,"msnt_env":"k-production","m1_banner_place":"article_socials","m1_edition":"ev_us","m1_article_type":"features","m1_page_content_id":399868,"m1_page_type":"detail","m1_page_content_type":"video","m1_makes":["tesla"],"m1_models":["model-s","model-3","model-x"],"m1_categories":["buying-advice"],"m1_tags":["Teslanomics"],"m1_body_types":["sedan","sedan","suv"],"m1_model_segments":["f","c","e"],"m1_banner_position":"article_socials"}'></div></div><div class="apb leaderboard" style="padding:15px 0 15px 0;"><div class="ap" data-place="23" style="width:650px;min-height:1px;" data-dfp-code="EV/ev_us/Leaderboard/Social" data-sizes="650x1,650x100" data-width="650" data-height="1" data-dfp-attrs='{"lazy":1,"msnt_env":"k-production","m1_banner_place":"article_socials","m1_edition":"ev_us","m1_article_type":"features","m1_page_content_id":399868,"m1_page_type":"detail","m1_page_content_type":"video","m1_makes":["tesla"],"m1_models":["model-s","model-3","model-x"],"m1_categories":["buying-advice"],"m1_tags":["Teslanomics"],"m1_body_types":["sedan","sedan","suv"],"m1_model_segments":["f","c","e"],"m1_banner_position":"article_socials"}'></div></div></div>

                

                
                

                



                                


                
                
                <div class="parent-shareBox parent-shareBox-bottom">
                                                                        <script id="dsq-count-scr" src="//insideevscom.disqus.com/count.js" async></script>                            <a title="Add a comment" href="/features/399868/best-tesla-buy-now-video/#comments" class="disqus-comment-count" data-disqus-identifier="en-article-399868" data-disqus-url="/features/399868/best-tesla-buy-now-video/"></a>                                                                <div slot="share-box" class="big-shareBox shareBox share-box-dropdown to-down"><div class="share-box-wrapper"><span class="shareBox-separator" data-value="share-list-1582289611" data-button onClick="" data-id="toggleBox" data-static> <span class="active"><span class="icon-plus">+</span></span><span class="passive"><span class="icon-plus">+</span></span></span><a href="https://insideevs.com/features/399868/best-tesla-buy-now-video/" class="share-button"><span class="name">Share</span><span class="icon share-empty"></span></a><div class="share-list" data-button-target="share-list-1582289611"><ul><li class="facebook"><a data-button="" data-id="share" data-url="/connect/share/" data-name="network_id" target="_blank" data-extra-params="id:'399868',type_id:'1'" data-value="1" data-share-network="Facebook" data-share-url="https://insideevs.com/features/399868/best-tesla-buy-now-video/" data-width="600" data-height="600" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Finsideevs.com%2Ffeatures%2F399868%2Fbest-tesla-buy-now-video%2F"><span class="social-bg icon facebook"></span><span class="name">Share on Facebook</span></a></li><li class="twitter"><a data-button="" data-id="share" data-url="/connect/share/" data-name="network_id" target="_blank" data-extra-params="id:'399868',type_id:'1'" data-value="2" data-share-network="Twitter" data-share-url="https://insideevs.com/features/399868/best-tesla-buy-now-video/" data-width="600" data-height="450" href="https://twitter.com/intent/tweet?url=https%3A%2F%2Finsideevs.com%2Ffeatures%2F399868%2Fbest-tesla-buy-now-video%2F&text=Watch+This+To+Find+Out+The+Best+Tesla+To+Buy+Right+Now&via=insideevs.com"><span class="social-bg icon twitter"></span><span class="name">Share on Twitter</span></a></li><li class="linkedin"><a data-button="" data-id="share" data-url="/connect/share/" data-name="network_id" target="_blank" data-extra-params="id:'399868',type_id:'1'" data-value="3" data-share-network="LinkedIn" data-share-url="https://insideevs.com/features/399868/best-tesla-buy-now-video/" data-width="600" data-height="600" href="https://www.linkedin.com/cws/share?url=https%3A%2F%2Finsideevs.com%2Ffeatures%2F399868%2Fbest-tesla-buy-now-video%2F"><span class="social-bg icon linkedin"></span><span class="name">Share on LinkedIn</span></a></li><li class="flipboard"><a data-button="" data-id="share" data-url="/connect/share/" data-name="network_id" target="_blank" data-extra-params="id:'399868',type_id:'1'" data-value="7" data-share-network="Flipboard" data-share-url="https://insideevs.com/features/399868/best-tesla-buy-now-video/" data-width="600" data-height="600" href="https://share.flipboard.com/bookmarklet/popout?url=https%3A%2F%2Finsideevs.com%2Ffeatures%2F399868%2Fbest-tesla-buy-now-video%2F&title=Watch+This+To+Find+Out+The+Best+Tesla+To+Buy+Right+Now&v=2"><span class="social-bg icon flipboard"></span><span class="name">Share on Flipboard</span></a></li><li class="reddit"><a data-button="" data-id="share" data-url="/connect/share/" data-name="network_id" target="_blank" data-extra-params="id:'399868',type_id:'1'" data-value="6" data-share-network="Reddit" data-share-url="https://insideevs.com/features/399868/best-tesla-buy-now-video/" data-width="900" data-height="600" href="https://www.reddit.com/submit?url=https%3A%2F%2Finsideevs.com%2Ffeatures%2F399868%2Fbest-tesla-buy-now-video%2F"><span class="social-bg icon reddit"></span><span class="name">Share on Reddit</span></a></li><li class="whatsapp"><a data-button="" data-id="share" data-url="/connect/share/" data-name="network_id" target="_blank" data-extra-params="id:'399868',type_id:'1'" data-value="6" data-share-network="WhatsApp" data-share-url="https://insideevs.com/features/399868/best-tesla-buy-now-video/" data-width="600" data-height="600" href="https://api.whatsapp.com/send?text=https%3A%2F%2Finsideevs.com%2Ffeatures%2F399868%2Fbest-tesla-buy-now-video%2F"><span class="social-bg icon whatsapp"></span><span class="name">Share on WhatsApp</span></a></li><li class="mailto"><a data-button="" data-id="mailTo" target="_blank" data-extra-params="id:'399868',type_id:'1'" data-share-url="https://insideevs.com/features/399868/best-tesla-buy-now-video/" data-width="600" data-height="400" href="mailto:?body=https%3A%2F%2Finsideevs.com%2Ffeatures%2F399868%2Fbest-tesla-buy-now-video%2F&subject=Watch%20This%20To%20Find%20Out%20The%20Best%20Tesla%20To%20Buy%20Right%20Now"><span class="social-bg icon mailto"></span><span class="name">Send to email</span></a></li></ul></div></div></div>                </div>



                



                
            </div>
        </div>






        <div class="sidebar" id="post_sidebar">
                            <div class="apb apb-dmpu"><div class="ap" data-place="4" style="width:300px;min-height:250px;" data-dfp-code="EV/ev_us/DMPU" data-sizes="300x250,300x600" data-width="300" data-height="250" data-dfp-attrs='{"msnt_env":"k-production","m1_banner_place":"dmpu_first","m1_edition":"ev_us","m1_article_type":"features","m1_page_content_id":399868,"m1_page_type":"detail","m1_page_content_type":"video","m1_makes":["tesla"],"m1_models":["model-s","model-3","model-x"],"m1_categories":["buying-advice"],"m1_tags":["Teslanomics"],"m1_body_types":["sedan","sedan","suv"],"m1_model_segments":["f","c","e"],"m1_banner_position":"sidebar"}'></div></div>                            
                                                <div class="trending-content">
                        <div class="content-header">
                            <h2 class="trending-content_header">Trending</h2>
                        </div>
                                                                                <div class="trending-content_item">
                                <a class="trending-content_thumb thumb zoom" href="/news/399826/nissan-leaf-driver-unplugs-tesla-video/">
                                                                                    <span class="icon play"></span>
                                                                            <picture class="lazy">
                                        <img src="https://cdn.motor1.com/custom/share/placeholder_0.jpg" alt="Nissan LEAF Driver Unplugs Tesla To Get Some Juice In Dallas, TX" data-src="https://cdn.motor1.com/images/mgl/Q0Bo7/s6/tesla-gets-unplugged-by-nissan-leaf-driver-in-dallas-tx.jpg" class="desaturate">                                    </picture>
                                </a>
                                <a class="trending-content_link" href="/news/399826/nissan-leaf-driver-unplugs-tesla-video/">Nissan LEAF Driver Unplugs Tesla To Get Some Juice In Dallas, TX</a>
                            </div>
                                                                                <div class="trending-content_item">
                                <a class="trending-content_thumb thumb zoom" href="/news/399823/video-tesla-mustang-miss-race-porsche/">
                                                                                    <span class="icon play"></span>
                                                                            <picture class="lazy">
                                        <img src="https://cdn.motor1.com/custom/share/placeholder_1.jpg" alt="Watch Tesla Model X Dodge Ford Mustang, Escape Finger-Flicking Porsche" data-src="https://cdn.motor1.com/images/mgl/yKYJb/s6/teslacam-mustang-and-porsche.jpg" class="desaturate">                                    </picture>
                                </a>
                                <a class="trending-content_link" href="/news/399823/video-tesla-mustang-miss-race-porsche/">Watch Tesla Model X Dodge Ford Mustang, Escape Finger-Flicking Porsche</a>
                            </div>
                                                                                <div class="trending-content_item">
                                <a class="trending-content_thumb thumb zoom" href="/news/399744/video-tesla-cybertruck-race-roadster/">
                                                                            <picture class="lazy">
                                        <img src="https://cdn.motor1.com/custom/share/placeholder_2.jpg" alt="Tesla Cybertruck Meets Metallic Roadster: Simulated 0-60 Race Follows" data-src="https://cdn.motor1.com/images/mgl/M7Z0n/s6/race2.jpg" class="desaturate">                                    </picture>
                                </a>
                                <a class="trending-content_link" href="/news/399744/video-tesla-cybertruck-race-roadster/">Tesla Cybertruck Meets Metallic Roadster: Simulated 0-60 Race Follows</a>
                            </div>
                                                                                <div class="trending-content_item">
                                <a class="trending-content_thumb thumb zoom" href="/news/399581/video-tesla-model3-ice-snowmobile/">
                                                                                    <span class="icon play"></span>
                                                                            <picture class="lazy">
                                        <img src="https://cdn.motor1.com/custom/share/placeholder_3.jpg" alt="Tesla Model 3 Tested On Snow Versus Electric Snowmobile" data-src="https://cdn.motor1.com/images/mgl/Q0BGY/s6/tesla-model-3-vs-electric-snowmobile.jpg" class="desaturate">                                    </picture>
                                </a>
                                <a class="trending-content_link" href="/news/399581/video-tesla-model3-ice-snowmobile/">Tesla Model 3 Tested On Snow Versus Electric Snowmobile</a>
                            </div>
                                                                                <div class="trending-content_item">
                                <a class="trending-content_thumb thumb zoom" href="/features/396563/electric-pickup-trucks-buy-future/">
                                                                            <picture class="lazy">
                                        <img src="https://cdn.motor1.com/custom/share/placeholder_4.jpg" alt="Future Electric Pickup Trucks Worth Waiting For" data-src="https://cdn.motor1.com/images/mgl/bXwlM/s6/gmc-hummer-electric-pickup-truck-render.jpg" class="desaturate">                                    </picture>
                                </a>
                                <a class="trending-content_link" href="/features/396563/electric-pickup-trucks-buy-future/">Future Electric Pickup Trucks Worth Waiting For</a>
                            </div>
                                            </div>
                                                        <div class="apb apb-dmpu"><div class="ap" data-place="4" style="width:300px;min-height:250px;" data-dfp-code="EV/ev_us/DMPU" data-sizes="300x250,300x600" data-width="300" data-height="250" data-dfp-attrs='{"lazy":1,"msnt_env":"k-production","m1_banner_place":"dmpu","m1_edition":"ev_us","m1_article_type":"features","m1_page_content_id":399868,"m1_page_type":"detail","m1_page_content_type":"video","m1_makes":["tesla"],"m1_models":["model-s","model-3","model-x"],"m1_categories":["buying-advice"],"m1_tags":["Teslanomics"],"m1_body_types":["sedan","sedan","suv"],"m1_model_segments":["f","c","e"],"m1_banner_position":"sidebar"}'></div></div>                    </div>
        <div class="clear"></div>
    </div>
</div>

        

<div id="container_3rd_party_service" class="container_3rd_party pre-center padding print-hide" data-edtn="ev_us">

    <div class="content-area">
        <div class="content-area-box">
                            <div class="trending-content b-m-padding b-padding trending-content_mobile">
                    <div class="content-header">
                        <h2 class="trending-content_header">Trending</h2>
                    </div>
                                                                    <div class="trending-content_item trending-content_item-mobile">
                            <a class="trending-content_thumb thumb zoom lazy" href="/news/399826/nissan-leaf-driver-unplugs-tesla-video/" data-srcset="https://cdn.motor1.com/images/mgl/Q0Bo7/s6/tesla-gets-unplugged-by-nissan-leaf-driver-in-dallas-tx.jpg" data-srcset2x="https://cdn.motor1.com/images/mgl/Q0Bo7/s6/tesla-gets-unplugged-by-nissan-leaf-driver-in-dallas-tx.jpg">
                                                                    <span class="icon play"></span>
                                                                <picture class="lazy">
                                    <img src="https://cdn.motor1.com/q/images/mgl/VE1yz/s7/motor1-placeholder.jpg" data-src="https://cdn.motor1.com/images/mgl/Q0Bo7/s6/tesla-gets-unplugged-by-nissan-leaf-driver-in-dallas-tx.jpg" alt="Nissan LEAF Driver Unplugs Tesla To Get Some Juice In Dallas, TX"/>
                                </picture>
                            </a>
                            <a class="trending-content_link" href="/news/399826/nissan-leaf-driver-unplugs-tesla-video/">Nissan LEAF Driver Unplugs Tesla To Get Some Juice In Dallas, TX</a>
                        </div>
                                                                    <div class="trending-content_item trending-content_item-mobile">
                            <a class="trending-content_thumb thumb zoom lazy" href="/news/399823/video-tesla-mustang-miss-race-porsche/" data-srcset="https://cdn.motor1.com/images/mgl/yKYJb/s6/teslacam-mustang-and-porsche.jpg" data-srcset2x="https://cdn.motor1.com/images/mgl/yKYJb/s6/teslacam-mustang-and-porsche.jpg">
                                                                    <span class="icon play"></span>
                                                                <picture class="lazy">
                                    <img src="https://cdn.motor1.com/q/images/mgl/VE1yz/s7/motor1-placeholder.jpg" data-src="https://cdn.motor1.com/images/mgl/yKYJb/s6/teslacam-mustang-and-porsche.jpg" alt="Watch Tesla Model X Dodge Ford Mustang, Escape Finger-Flicking Porsche"/>
                                </picture>
                            </a>
                            <a class="trending-content_link" href="/news/399823/video-tesla-mustang-miss-race-porsche/">Watch Tesla Model X Dodge Ford Mustang, Escape Finger-Flicking Porsche</a>
                        </div>
                                                                    <div class="trending-content_item trending-content_item-mobile">
                            <a class="trending-content_thumb thumb zoom lazy" href="/news/399744/video-tesla-cybertruck-race-roadster/" data-srcset="https://cdn.motor1.com/images/mgl/M7Z0n/s6/race2.jpg" data-srcset2x="https://cdn.motor1.com/images/mgl/M7Z0n/s6/race2.jpg">
                                                                <picture class="lazy">
                                    <img src="https://cdn.motor1.com/q/images/mgl/VE1yz/s7/motor1-placeholder.jpg" data-src="https://cdn.motor1.com/images/mgl/M7Z0n/s6/race2.jpg" alt="Tesla Cybertruck Meets Metallic Roadster: Simulated 0-60 Race Follows"/>
                                </picture>
                            </a>
                            <a class="trending-content_link" href="/news/399744/video-tesla-cybertruck-race-roadster/">Tesla Cybertruck Meets Metallic Roadster: Simulated 0-60 Race Follows</a>
                        </div>
                                                                    <div class="trending-content_item trending-content_item-mobile">
                            <a class="trending-content_thumb thumb zoom lazy" href="/news/399581/video-tesla-model3-ice-snowmobile/" data-srcset="https://cdn.motor1.com/images/mgl/Q0BGY/s6/tesla-model-3-vs-electric-snowmobile.jpg" data-srcset2x="https://cdn.motor1.com/images/mgl/Q0BGY/s6/tesla-model-3-vs-electric-snowmobile.jpg">
                                                                    <span class="icon play"></span>
                                                                <picture class="lazy">
                                    <img src="https://cdn.motor1.com/q/images/mgl/VE1yz/s7/motor1-placeholder.jpg" data-src="https://cdn.motor1.com/images/mgl/Q0BGY/s6/tesla-model-3-vs-electric-snowmobile.jpg" alt="Tesla Model 3 Tested On Snow Versus Electric Snowmobile"/>
                                </picture>
                            </a>
                            <a class="trending-content_link" href="/news/399581/video-tesla-model3-ice-snowmobile/">Tesla Model 3 Tested On Snow Versus Electric Snowmobile</a>
                        </div>
                                                                    <div class="trending-content_item trending-content_item-mobile">
                            <a class="trending-content_thumb thumb zoom lazy" href="/features/396563/electric-pickup-trucks-buy-future/" data-srcset="https://cdn.motor1.com/images/mgl/bXwlM/s6/gmc-hummer-electric-pickup-truck-render.jpg" data-srcset2x="https://cdn.motor1.com/images/mgl/bXwlM/s6/gmc-hummer-electric-pickup-truck-render.jpg">
                                                                <picture class="lazy">
                                    <img src="https://cdn.motor1.com/q/images/mgl/VE1yz/s7/motor1-placeholder.jpg" data-src="https://cdn.motor1.com/images/mgl/bXwlM/s6/gmc-hummer-electric-pickup-truck-render.jpg" alt="Future Electric Pickup Trucks Worth Waiting For"/>
                                </picture>
                            </a>
                            <a class="trending-content_link" href="/features/396563/electric-pickup-trucks-buy-future/">Future Electric Pickup Trucks Worth Waiting For</a>
                        </div>
                                    </div>
                    </div>
    </div>
                    <div class="myevFeedContainer" data-tags="Teslanomics,Tesla,Buying Advice"></div>
        <script type="text/javascript" src="https://www.myev.com/js/insideevs_v1.2.js" defer></script>
    
    
    
                <div class="sellwild-container">
            <div class="sellwild-wrapper"
                data-partner="insideEVs"
                data-color="#77cc4b"
                data-version="1_1_6"
            >
            </div>
        </div>
        <div class="content-area">
        <div class="content-area-box">
                            <div id="comments" class="comment-container no-apb">
                                                                        <div id="disqus_thread" class="diquas-wrapper" data-cid="article-399868" data-url="/features/399868/best-tesla-buy-now-video/" data-title="Watch This To Find Out The Best Tesla To Buy Right Now">
                            </div>
                                                            </div>
                            
        </div>
        <div class="sidebar">
                            <div class="mobile-adv">
                    <div class="apb apb-dmpu"><div class="ap" data-place="4" style="width:300px;min-height:250px;" data-dfp-code="EV/ev_us/DMPU" data-sizes="300x250,300x600" data-width="300" data-height="250" data-dfp-attrs='{"lazy":1,"msnt_env":"k-production","m1_banner_place":"dmpu","m1_edition":"ev_us","m1_article_type":"features","m1_page_content_id":399868,"m1_page_type":"detail","m1_page_content_type":"video","m1_makes":["tesla"],"m1_models":["model-s","model-3","model-x"],"m1_categories":["buying-advice"],"m1_tags":["Teslanomics"],"m1_body_types":["sedan","sedan","suv"],"m1_model_segments":["f","c","e"],"m1_banner_position":"sidebar"}'></div></div>                </div>
                <div class="lazy-load-adv">
                    <div class="apb apb-dmpu"><div class="ap" data-place="4" style="width:300px;min-height:250px;" data-dfp-code="EV/ev_us/DMPU" data-sizes="300x250,300x600" data-width="300" data-height="250" data-dfp-attrs='{"lazy":1,"msnt_env":"k-production","m1_banner_place":"dmpu","m1_edition":"ev_us","m1_article_type":"features","m1_page_content_id":399868,"m1_page_type":"detail","m1_page_content_type":"video","m1_makes":["tesla"],"m1_models":["model-s","model-3","model-x"],"m1_categories":["buying-advice"],"m1_tags":["Teslanomics"],"m1_body_types":["sedan","sedan","suv"],"m1_model_segments":["f","c","e"],"m1_banner_position":"sidebar"}'></div></div>                </div>
                    </div>
        <div class="clear"></div>

    </div>


    


    
                </div>

<div class="pre-center mobile-skyscraper-box">
    <div class="apb apb-dmpu"><div class="ap" data-place="4" style="width:300px;min-height:250px;" data-dfp-code="EV/ev_us/DMPU" data-sizes="300x250,300x600" data-width="300" data-height="250" data-dfp-attrs='{"lazy":1,"msnt_env":"k-production","m1_banner_place":"dmpu","m1_edition":"ev_us","m1_article_type":"features","m1_page_content_id":399868,"m1_page_type":"detail","m1_page_content_type":"video","m1_makes":["tesla"],"m1_models":["model-s","model-3","model-x"],"m1_categories":["buying-advice"],"m1_tags":["Teslanomics"],"m1_body_types":["sedan","sedan","suv"],"m1_model_segments":["f","c","e"],"m1_banner_position":"sidebar"}'></div></div></div>

<div class="cpre-center print-hide">
    </div>


    <div class="pre-center padding print-hide">
        <div class="content-area">
            <div class="content-area-box">
                <h2 class="text-uppercase">About this article</h2>
                <table class="additionalInfo">
                                            <tr>
                            <td>Category</td>
                            <td><div class="list">
                                                                            <a href="/features/category/buying-advice/">Buying Advice</a>
                                                                    </div></td>
                        </tr>
                                                                                    <tr>
                            <td>Tags</td>
                            <td>
                                <div class="list">
                                                                            <a href="/tag/teslanomics/">Teslanomics</a>
                                                                    </div>
                            </td>
                        </tr>
                                                                    <tr>
                                <td>Make/Model</td>
                                <td>
                                    <div class="list">
                                                                                    <a href="/tesla/model-s/">Tesla Model S</a>
                                                                                    <a href="/tesla/model-3/">Tesla Model 3</a>
                                                                                    <a href="/tesla/model-x/">Tesla Model X</a>
                                                                            </div>
                                </td>
                            </tr>
                                                    <tr>
                                <td>Body Style</td>
                                <td>
                                    <div class="list">
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                    <a href="/body-styles/sedan/">
                                                Sedan                                            </a>
                                                                                    <a href="/body-styles/suv/">
                                                SUV/Crossover                                            </a>
                                                                            </div>
                                </td>
                            </tr>
                                                            </table>
            </div>
            <div class="sidebar">

            </div>
            <div class="clear"></div>
        </div>
    </div>
    <div id="stop_share_box" class="print-hide"></div>

<div  id="ap_popup_gallery_top"><div class="apb mleaderboard"><div class="ap" data-place="10" style="width:320px;min-height:50px;" data-dfp-code="EV/ev_us/Mobile_Leaderboard" data-sizes="320x50,320x100" data-width="320" data-height="50" data-dfp-attrs='{"lazy":1,"msnt_env":"k-production","m1_banner_place":"popup_gallery_top","m1_edition":"ev_us","m1_article_type":"features","m1_page_content_id":399868,"m1_page_type":"detail","m1_page_content_type":"video","m1_makes":["tesla"],"m1_models":["model-s","model-3","model-x"],"m1_categories":["buying-advice"],"m1_tags":["Teslanomics"],"m1_body_types":["sedan","sedan","suv"],"m1_model_segments":["f","c","e"],"m1_banner_position":"popup_gallery_top"}'></div></div><div class="apb leaderboard"><div class="ap" data-place="1" style="width:728px;min-height:90px;" data-dfp-code="EV/ev_us/Leaderboard" data-width="728" data-height="90" data-dfp-attrs='{"lazy":1,"msnt_env":"k-production","m1_banner_place":"popup_gallery_top","m1_edition":"ev_us","m1_article_type":"features","m1_page_content_id":399868,"m1_page_type":"detail","m1_page_content_type":"video","m1_makes":["tesla"],"m1_models":["model-s","model-3","model-x"],"m1_categories":["buying-advice"],"m1_tags":["Teslanomics"],"m1_body_types":["sedan","sedan","suv"],"m1_model_segments":["f","c","e"],"m1_banner_position":"popup_gallery_top"}'></div></div><div class="apb super"><div class="ap" data-place="12" style="width:970px;min-height:90px;" data-dfp-code="EV/ev_us/Super" data-width="970" data-height="90" data-dfp-attrs='{"lazy":1,"msnt_env":"k-production","m1_banner_place":"popup_gallery_top","m1_edition":"ev_us","m1_article_type":"features","m1_page_content_id":399868,"m1_page_type":"detail","m1_page_content_type":"video","m1_makes":["tesla"],"m1_models":["model-s","model-3","model-x"],"m1_categories":["buying-advice"],"m1_tags":["Teslanomics"],"m1_body_types":["sedan","sedan","suv"],"m1_model_segments":["f","c","e"],"m1_banner_position":"popup_gallery_top"}'></div></div></div><div id="ap_popup_gallery_rectangle"><div class="ap" data-place="4" style="width:300px;min-height:250px;" data-dfp-code="EV/ev_us/DMPU" data-sizes="300x250,300x600" data-width="300" data-height="250" data-dfp-attrs='{"lazy":1,"msnt_env":"k-production","m1_banner_place":"popup_gallery_rectangle","m1_edition":"ev_us","m1_article_type":"features","m1_page_content_id":399868,"m1_page_type":"detail","m1_page_content_type":"video","m1_makes":["tesla"],"m1_models":["model-s","model-3","model-x"],"m1_categories":["buying-advice"],"m1_tags":["Teslanomics"],"m1_body_types":["sedan","sedan","suv"],"m1_model_segments":["f","c","e"],"m1_banner_position":"popup_gallery_rectangle"}'></div></div>
        </div>


<div class="m1-left-side">
    <div class="m1-drawer left-to-right disabled" data-button-target="mainMenu">
        <div onclick="" data-button data-id="toggleBox" data-close-delay="0.5" data-value="mainMenu" data-hide-scroll="m1-left-side-box" data-clear="2" class="m1-drawer-close-button dark active" data-toggle="1" data-multi></div>
        <div class="m1-left-side-top">
            <div class="m1-user-side-label">
                <span class="label flex-parent two-line">
                   <a class="login" href="/login/" onclick="" data-button data-id="goToUrl">Sign In</a>
                   <span class="hide_mobile">or</span>
                   <a class="register" href="/register/" onclick="" data-button data-id="goToUrl">Sign Up</a>
                </span>
                <span class="hide_mobile userpic icon-user"></span>
            </div>
        </div>
        <div class="m1-left-side-box">
                        <ul class="m1-navigation-main print-hide">
                        <li class="grand top left mobile">
            <a href="/news/" >
                News            </a>
        </li>
                    <li class="grand top left">
            <a href="/reviews/" >
                Reviews            </a>
        </li>
                    <li class="grand left">
            <a href="/features/" >
                Features            </a>
        </li>
                    <li class="mobile">
            <a href="/tesla/" >
                Tesla            </a>
        </li>
                    <li class="top left">
            <a href="/reviews/344001/compare-evs/" >
                Compare EVs            </a>
        </li>
                    <li class="left">
            <a href="/news/344002/charger-guide/" >
                Charger Guide            </a>
        </li>
                    <li class="left">
            <a href="/features/category/buying-advice/" >
                Buying Advice            </a>
        </li>
                    <li class="left">
            <a href="/news/343998/monthly-plug-in-ev-sales-scorecard/" >
                EV Sales Scorecard            </a>
        </li>
                    <li class="mobile">
            <a href="/news/343998/monthly-plug-in-ev-sales-scorecard/" >
                EV Sales            </a>
        </li>
                    <li class="left">
            <a href="/news/?sc=1" >
                Categories            </a>
        </li>
                    <li class="left">
            <a href="/makes/" >
                Makes            </a>
        </li>
                    <li class="left">
            <a href="/body-styles/" >
                Body Style            </a>
        </li>
                    <li class="left top _blank">
            <a href="https://insideevsforum.com/community/index.php" target = "_blank">
                Forum            </a>
        </li>
                    <li class="left _blank">
            <a href="https://www.myev.com/?utm_source=insideevs.com&utm_campaign=IEVmenu" target = "_blank">
                Buy            </a>
        </li>
                    <li class="photos ico left">
            <a href="/photos/" >
                Photos            </a>
        </li>
                    <li class="videos ico left">
            <a href="/videos/" >
                Videos            </a>
        </li>
                    <li class="top plugin-sale">
            <a href="/news/343998/monthly-plug-in-ev-sales-scorecard/" >
                Ev Sales Scorecard            </a>
        </li>
    </ul>            <div class="m1-menus-box">
                <div class="m1-extra-menus-box">
                    <a href="/" class="m1-side-logo"></a>
                                        <div class="m1-editions-switcher-mobile">
                        <a href="/info/about-us/" class="m1-editions-switcher" onclick="" data-close-delay="0.5" data-delay="0.01" data-button="" data-hide-scroll="m1-scrollbar" data-id="toggleBox" data-value="editionsMenu" data-clear="2" data-multi="">
                            <span class="title">Edition:</span>
                                                        <span class="edf edf-230"></span>
                                                    </a>
                    </div>
                    
                                            <ul class="m1-social-menu">
                                                                                <li class="facebook"><a title="Facebook" class="icon-facebook" href="https://www.facebook.com/InsideeVs/" target="_blank"></a></li>
                                                                                                                                                                <li class="twitter"><a title="Twitter" class="icon-twitter" href="https://twitter.com/InsideEVs" target="_blank"></a></li>
                                                                                                                                                                <li class="flipboard"><a title="flipboard" class="icon-flipboard" href="https://flipboard.com/@InsideEVs" target="_blank"></a></li>
                                                                                                                                                                                                                    <li class="gnews"><a title="Google News" class="icon-gnews" href="https://news.google.com/publications/CAAqBwgKMLHIlAswkJCqAw" target="_blank"></a></li>
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                        <li class="rss"><a title="RSS" class="icon-rss" href="/rss/" ></a></li>
                                                                            </ul>
                    
                    <ul class="m1-info-menu">
                        <li><a href="/info/about-us/">About Us</a></li>
                                                    <li><a href="https://newsletter.insideevs.com/signup/" target="_blank">Newsletter</a></li>
                                                <li><a href="/info/contact/">Contact</a></li>
                        <li><a href="/info/feedback/tip-us/">Tip us</a></li>
                        <li><a href="https://accounts.motorsportnetwork.com/legal/privacy-policy" target="_blank">Privacy policy</a></li>
                        <li><a href="/info/cookie-policy/">Cookie policy</a></li>
                    </ul>

                </div>
                <div class="m1-msn-menus-box">
                    <ul class="m1-msn-menu">

                        
                        
                        
                        
                                                    <li class="autoclassics"><a href="https://www.autoclassics.com/" target="_blank">www.autoclassics.com</a></li>
                        
                        
                                                    <li class="motor1"><a href="https://www.motor1.com/" target="_blank">www.motor1.com</a></li>
                        
                                                   <li class="myen"><a href="https://www.myev.com/" target="_blank">www.myev.com/</a></li>
                        
                        
                        
                        
                        
                    </ul>
                </div>
                <div class="m1-footer">
                    &copy; 2020 <a target="_blank" class="m1-msn-name" href="https://www.motorsportnetwork.com/company/about">Motorsport Network.</a>                                                         </div>
                            </div>
        </div>
    </div>
    <div class="m1-drawer-overlay"></div>
</div>
    
<div class="m1-right-side">
    <div class="m1-drawer right-to-left disabled" data-button-target="editionsMenu">
        
        <div onclick="" data-button data-id="toggleBox" data-value="editionsMenu" data-close-delay="0.5" data-hide-scroll="m1-scrollbar" data-clear="2" class="m1-drawer-close-button active" data-toggle="1" data-multi></div>
    
        <div class="m1-editions-switcher active" data-close-delay="0.5" data-delay="0.01" onclick="" data-button data-id="toggleBox" data-value="editionsMenu" data-clear="2" data-toggle="1" data-multi>
                        <span class="edf edf-230"></span>
                        <span class="title">USA / Global</span>
        </div>
        <div class="m1-editions-label">Our International Editions</div>
        <div class="m1-editions-box m1-scrollbar">
            
            <ul class="m1-editions-list">
                            <li class="current">
                    <a href="/?select_edition=ev_us">
                                        <span class="flags">
                                            <span class="edf edf-230"></span>
                                        </span>
                    <span class="label">
                                        InsideEVs: USA / Global                    </span>
                    </a>
                </li>
                            <li>
                    <a href="/?select_edition=ev_fr">
                                        <span class="flags">
                                            <span class="edf edf-72"></span>
                                            <span class="edf edf-21"></span>
                                            <span class="edf edf-211"></span>
                                            <span class="edf edf-145"></span>
                                            <span class="edf edf-128"></span>
                                        </span>
                    <span class="label">
                                        InsideEVs: France                    </span>
                    </a>
                </li>
                            <li>
                    <a href="/?select_edition=ev_it">
                                        <span class="flags">
                                            <span class="edf edf-106"></span>
                                        </span>
                    <span class="label">
                                        InsideEVs: Italy                    </span>
                    </a>
                </li>
                            <li>
                    <a href="/?select_edition=ev_br">
                                        <span class="flags">
                                            <span class="edf edf-30"></span>
                                            <span class="edf edf-177"></span>
                                        </span>
                    <span class="label">
                                        InsideEVs: Brasil                    </span>
                    </a>
                </li>
                        </ul>
            
        </div>


    
    </div>
    <div class="m1-drawer-overlay"></div>
</div>
<m1-check-availability-response-dialog
        user-data='{"email":"","zip":"","phone":"","firstName":"","lastName":""}'
        edition="ev_us"
        oem-url="/buy/new/lead/"
        vin-url="/buy/used/lead/"
></m1-check-availability-response-dialog>


    <div id="share_box_content_wrapper">
        <div slot="share-box" class="big-shareBox shareBox share-box-dropdown to-down"><div class="share-box-wrapper"><span class="shareBox-separator" data-value="share-list-1582289062" data-button onClick="" data-id="toggleBox" data-static> <span class="active"><span class="icon-plus">+</span></span><span class="passive"><span class="icon-plus">+</span></span></span><a href="https://insideevs.com/features/399868/best-tesla-buy-now-video/" class="share-button"><span class="name">Share</span><span class="icon share-empty"></span></a><div class="share-list" data-button-target="share-list-1582289062"><ul><li class="facebook"><a data-button="" data-id="share" data-url="/connect/share/" data-name="network_id" target="_blank" data-extra-params="id:'399868',type_id:'1'" data-value="1" data-share-network="Facebook" data-share-url="https://insideevs.com/features/399868/best-tesla-buy-now-video/" data-width="600" data-height="600" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Finsideevs.com%2Ffeatures%2F399868%2Fbest-tesla-buy-now-video%2F"><span class="social-bg icon facebook"></span><span class="name">Share on Facebook</span></a></li><li class="twitter"><a data-button="" data-id="share" data-url="/connect/share/" data-name="network_id" target="_blank" data-extra-params="id:'399868',type_id:'1'" data-value="2" data-share-network="Twitter" data-share-url="https://insideevs.com/features/399868/best-tesla-buy-now-video/" data-width="600" data-height="450" href="https://twitter.com/intent/tweet?url=https%3A%2F%2Finsideevs.com%2Ffeatures%2F399868%2Fbest-tesla-buy-now-video%2F&text=Watch+This+To+Find+Out+The+Best+Tesla+To+Buy+Right+Now&via=insideevs.com"><span class="social-bg icon twitter"></span><span class="name">Share on Twitter</span></a></li><li class="linkedin"><a data-button="" data-id="share" data-url="/connect/share/" data-name="network_id" target="_blank" data-extra-params="id:'399868',type_id:'1'" data-value="3" data-share-network="LinkedIn" data-share-url="https://insideevs.com/features/399868/best-tesla-buy-now-video/" data-width="600" data-height="600" href="https://www.linkedin.com/cws/share?url=https%3A%2F%2Finsideevs.com%2Ffeatures%2F399868%2Fbest-tesla-buy-now-video%2F"><span class="social-bg icon linkedin"></span><span class="name">Share on LinkedIn</span></a></li><li class="flipboard"><a data-button="" data-id="share" data-url="/connect/share/" data-name="network_id" target="_blank" data-extra-params="id:'399868',type_id:'1'" data-value="7" data-share-network="Flipboard" data-share-url="https://insideevs.com/features/399868/best-tesla-buy-now-video/" data-width="600" data-height="600" href="https://share.flipboard.com/bookmarklet/popout?url=https%3A%2F%2Finsideevs.com%2Ffeatures%2F399868%2Fbest-tesla-buy-now-video%2F&title=Watch+This+To+Find+Out+The+Best+Tesla+To+Buy+Right+Now&v=2"><span class="social-bg icon flipboard"></span><span class="name">Share on Flipboard</span></a></li><li class="reddit"><a data-button="" data-id="share" data-url="/connect/share/" data-name="network_id" target="_blank" data-extra-params="id:'399868',type_id:'1'" data-value="6" data-share-network="Reddit" data-share-url="https://insideevs.com/features/399868/best-tesla-buy-now-video/" data-width="900" data-height="600" href="https://www.reddit.com/submit?url=https%3A%2F%2Finsideevs.com%2Ffeatures%2F399868%2Fbest-tesla-buy-now-video%2F"><span class="social-bg icon reddit"></span><span class="name">Share on Reddit</span></a></li><li class="whatsapp"><a data-button="" data-id="share" data-url="/connect/share/" data-name="network_id" target="_blank" data-extra-params="id:'399868',type_id:'1'" data-value="6" data-share-network="WhatsApp" data-share-url="https://insideevs.com/features/399868/best-tesla-buy-now-video/" data-width="600" data-height="600" href="https://api.whatsapp.com/send?text=https%3A%2F%2Finsideevs.com%2Ffeatures%2F399868%2Fbest-tesla-buy-now-video%2F"><span class="social-bg icon whatsapp"></span><span class="name">Share on WhatsApp</span></a></li><li class="mailto"><a data-button="" data-id="mailTo" target="_blank" data-extra-params="id:'399868',type_id:'1'" data-share-url="https://insideevs.com/features/399868/best-tesla-buy-now-video/" data-width="600" data-height="400" href="mailto:?body=https%3A%2F%2Finsideevs.com%2Ffeatures%2F399868%2Fbest-tesla-buy-now-video%2F&subject=Watch%20This%20To%20Find%20Out%20The%20Best%20Tesla%20To%20Buy%20Right%20Now"><span class="social-bg icon mailto"></span><span class="name">Send to email</span></a></li></ul></div></div></div>    </div>


<!--<div class="adminInfoBoxx"></div>-->
<div class="hiddenBlock">
    <div class="apOutstream"><div class="ap" data-place="8" style="width:1px;min-height:1px;" data-dfp-code="EV/ev_us/Outstream" data-width="1" data-height="1" data-dfp-attrs='{"msnt_env":"k-production","m1_banner_place":"outstream","m1_edition":"ev_us","m1_article_type":"features","m1_page_content_id":399868,"m1_page_type":"detail","m1_page_content_type":"video","m1_makes":["tesla"],"m1_models":["model-s","model-3","model-x"],"m1_categories":["buying-advice"],"m1_tags":["Teslanomics"],"m1_body_types":["sedan","sedan","suv"],"m1_model_segments":["f","c","e"],"m1_banner_position":"outstream"}'></div></div></div>
<div class="apOverlay m1-ap-overlay"><div class="ap" data-place="17" style="width:0px;min-height:0px;" data-dfp-code="EV/ev_us/Overlay" data-width="0" data-height="0" data-dfp-attrs='{"msnt_env":"k-production","m1_banner_place":"overlay","m1_edition":"ev_us","m1_article_type":"features","m1_page_content_id":399868,"m1_page_type":"detail","m1_page_content_type":"video","m1_makes":["tesla"],"m1_models":["model-s","model-3","model-x"],"m1_categories":["buying-advice"],"m1_tags":["Teslanomics"],"m1_body_types":["sedan","sedan","suv"],"m1_model_segments":["f","c","e"],"m1_banner_position":"overlay"}'></div></div><div class="apOverlay m1-ap-overlay-2"><div class="ap" data-place="18" style="width:0px;min-height:0px;" data-dfp-code="EV/ev_us/Overlay2" data-width="0" data-height="0" data-dfp-attrs='{"msnt_env":"k-production","m1_banner_place":"overlay2","m1_edition":"ev_us","m1_article_type":"features","m1_page_content_id":399868,"m1_page_type":"detail","m1_page_content_type":"video","m1_makes":["tesla"],"m1_models":["model-s","model-3","model-x"],"m1_categories":["buying-advice"],"m1_tags":["Teslanomics"],"m1_body_types":["sedan","sedan","suv"],"m1_model_segments":["f","c","e"],"m1_banner_position":"overlay2"}'></div></div><div class="apOverlay m1-ap-overlay-3"><div class="ap" data-place="20" style="width:0px;min-height:0px;" data-dfp-code="EV/ev_us/Overlay3" data-width="0" data-height="0" data-dfp-attrs='{"msnt_env":"k-production","m1_banner_place":"overlay3","m1_edition":"ev_us","m1_article_type":"features","m1_page_content_id":399868,"m1_page_type":"detail","m1_page_content_type":"video","m1_makes":["tesla"],"m1_models":["model-s","model-3","model-x"],"m1_categories":["buying-advice"],"m1_tags":["Teslanomics"],"m1_body_types":["sedan","sedan","suv"],"m1_model_segments":["f","c","e"],"m1_banner_position":"overlay3"}'></div></div><div class="apOverlay m1-ap-overlay-4"><div class="ap" data-place="21" style="width:0px;min-height:0px;" data-dfp-code="EV/ev_us/Overlay4" data-width="0" data-height="0" data-dfp-attrs='{"msnt_env":"k-production","m1_banner_place":"overlay4","m1_edition":"ev_us","m1_article_type":"features","m1_page_content_id":399868,"m1_page_type":"detail","m1_page_content_type":"video","m1_makes":["tesla"],"m1_models":["model-s","model-3","model-x"],"m1_categories":["buying-advice"],"m1_tags":["Teslanomics"],"m1_body_types":["sedan","sedan","suv"],"m1_model_segments":["f","c","e"],"m1_banner_position":"overlay4"}'></div></div><div class="m1-footer-messages"></div>

<script>
     window.gadsId = false;
</script>
<script>
    var m1FooterMessages = [];
    m1FooterMessages.push({
        message: "This website uses cookies to ensure you get the best experience on our website. By closing this banner, scrolling this page you consent to the use of cookies. <a id='cookie_accept_link' data-id='footerMessageAccept' data-button='' href='/info/cookie-policy/'>More info.</a>",
        name: "cookie_accept"
    });
    </script>

<script defer type="text/javascript" src="https://cdn.motor1.com/kp/static4ui/prod_v2_eks_93/design/build/jslangs/insideevs_en_US_90b1785de5d9d4d318b64a471cb4dd07.js"></script>
<script defer type="text/javascript" src="https://cdn.motor1.com/kp/static4ui/prod_v2_eks_93/design/dist/js/0_a23334e0c4d1ac693f7a.js"></script><script defer type="text/javascript" src="https://cdn.motor1.com/kp/static4ui/prod_v2_eks_93/design/dist/js/2_a23334e0c4d1ac693f7a.js"></script><script defer type="text/javascript" src="https://cdn.motor1.com/kp/static4ui/prod_v2_eks_93/design/dist/js/11_a23334e0c4d1ac693f7a.js"></script>


    
<script>
gtmDataLayer = [{
    'currentEdition': 'ev_us',
    'currentEnv': 'k-production',
        'pageType': 'detail',
            'entityType': 'video',
            'make': 'Tesla',
            'model': 'Model S',
            'pageId': 'index_articles_detail',
            'entityAuthors': ["Tom Moloughney"],
            'pageUrl': 'http://insideevs.com:8080/features/399868/best-tesla-buy-now-video/',
            'pageUrlCanonical': 'http://insideevs.com:8080/features/399868/best-tesla-buy-now-video/',
            'pageLanguage': 'en',
            'entityCategories': ["Buying Advice"],
            'articleType': 'features',
                    'entityTitle': 'Watch This To Find Out The Best Tesla To Buy Right Now',
            'pageTitle': 'Watch This To Find Out The Best Tesla To Buy Right Now',
            'articleId': '399868',
            'tags': ["Teslanomics"],
                'bodyStyles': ["Sedan","Sedan","SUV\/Crossover"],
        'sessionId': '4713bbf472662d4a9b9265579253d9e1'
}];
</script>
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','gtmDataLayer','GTM-TJCLXGW');</script>

<script>
(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','gtmDataLayer', 'GTM-M4M4LBT');
</script>




<script>
    window.onload = function() {

        if ((typeof $.cookie('PHPSESSID') === 'undefined') || (typeof $.cookie('is_logged_in') !== 'undefined')){
            $.get('/layout-auth-data/', function(data) {
                $('.m1-user-side-label').html(data);
            });
        }

    }

</script>
</body>
</html>